Ir ao conteúdo
  • Cadastre-se
Luciana Goes

Excel Excluir células vazias da validação de dados condicional

Posts recomendados

Olá!

Algué sabe se há uma forma de ignorar as células vazias na validação de dados condicional?

Na validação de dados simples funciona perfeitamente bem, mas não estou sabendo montar a fórmula junto com o "Indireto" na validação condicional (nem sei se é possível).

Segue a planilha anexa.

Obrigada.

 

VALIDAÇÃO CONDICIONAL.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, Luciana.

Segue uma alternativa. Veja se pode ser útil.

 

1. inicialmente, tal como você já fez em D16:D21 para os itens REFERÊNCIAS, é preciso replicar todas as listas sem as células vazias intercaladas, ou seja, replicar as listas PARAFUSO, SERRA, DOBRADIÇA e ALICATE, em intervalos auxiliares que escolhi, e que depois você poderá colocá-los em outra região da planilha. Para isso:
a) cole em D16 uma cópia da fórmula matricial abaixo e arraste até D21 (esta fórmula é diferente da sua e não utiliza a tabela auxiliar que você elaborou em B16:B21, que poderá ser limpada). Lembrando que por ser matricial, após colar a fórmula na célula D16 aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter e em seguida arraste.
=SEERRO(ÍNDICE(B$4:G$4;MENOR(SE(B$4:G$4<>"";COLUNA(A$4:F$4));LIN(A1)));"")
b) via menu Gerenciador de Nomes exclua os nomes PARAFUSO, SERRA, DOBRADIÇA e ALICATE, em seguida cole cópia da fórmula matricial abaixo em B24 (lembrando F2 + Ctrl+Shift+Enter) e arraste até G33.
=SEERRO(ÍNDICE(B$5:B$14;MENOR(SE(B$5:B$14<>"";LIN($A$1:$A$10));LINS($1:1)));"")  ou utilize a fórmula abaixo
=SEERRO(ÍNDICE(B$5:B$14;AGREGAR(15;6;(LIN(B$5:B$14)-LIN($B$4))/(B$5:B$14<>"");LINS(C$4:C4)));"")

 

2. copie B4:G4 e cole em B23:G23

 

3. em seguida nomeie os Intervalos Dinâmicos com os nomes PARAFUSO, SERRA, DOBRADIÇA e ALICATE com a fórmula abaixo. Essa fórmula serve para nomear PARAFUSO. Para os demais nomes basta alterar a coluna de acordo.
=DESLOC(Sheet1!$B$24;0;0;CONT.SE(Sheet1!$B$24:$B$33;">""");1)

 

4. em seguida aplique a Validação de Dados em I5:I14 utilizando a fórmula abaixo
=DESLOC(Sheet1!$D$16;0;0;CONT.SE(Sheet1!$D$16:$D$21;">""");1)

 

5. por último aplique a Validação de Dados em J5:J14 utilizando a fórmula abaixo (se ao finalizar apresentar mensagem de erro clique em "Sim")
=ESCOLHER(CORRESP($I5;$B$23:$G$23;0);PARAFUSO;SERRA;DOBRADIÇA;"sem nome1";ALICATE;"sem nome2")

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!