Ir ao conteúdo
  • Cadastre-se
Leoasustgx

VisualG Questão para prova com VisualG

Posts recomendados

para i de 1 ate 5 faca
   escreval(i, "-", i^2)

Estou com dificuldades nessa questão inicie o curso recentemente CODE

 

1-Entra com 5 números inteiros e imprimir a soma dos quadrados dos números pares digitados

 

2-Entra com vários números e imprimir a quantidade de números pares e a quantidade de números ímpares digitalizados. O programa encerra ao se digitar o numero 0 (zero).

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

gostaria somente de uma ajuda a como começar 

o resto eu faço somente para esclarecer a pergunta

Compartilhar este post


Link para o post
Compartilhar em outros sites
9 horas atrás, Leoasustgx disse:

gostaria somente de uma ajuda a como começar 

o resto eu faço somente para esclarecer a pergunta

 

Sugiro seguinte:

- Faça um programa que leia um número qualquer e imprima o seu quadrado; Posta o código aqui.

- Faça OUTRO PROGRAMA que recebe um número qualquer e retorna se é par ou ímpar.

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites
13 horas atrás, Leoasustgx disse:

1-Entra com 5 números inteiros e imprimir a soma dos quadrados dos números pares digitados

 

2-Entra com vários números e imprimir a quantidade de números pares e a quantidade de números ímpares digitalizados. O programa encerra ao se digitar o numero 0 (zero).

 

i inteiro
Num inteiro
Soma inteiro

Soma = 0

Para i = 1 até 5

Leia( num)

Se num mod 2 = 0

soma = soma+( num * num)

Fimse

Fimpara

Escreval( soma)

 


---------
Segundo exercício

Num inteiro
Contpar inteiro
Contimpar inteiro
--
Faca

Leia num

Se num mod 2 = 0 e num != 0

contpar= contpar + 1

Caso contrário

Contimpar = contimpar+1

Fimse

Enquanto num !=0

Escreval("pares " & contpar)
Escreval("ímpares"&contimpar)


 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Leoasustgx, qual programa utilizar para rodar os códigos? pelo que vi, essa sintaxe não é do VisualG.

Compartilhar este post


Link para o post
Compartilhar em outros sites
7 minutos atrás, Simon Viegas disse:

@Leoasustgx, qual programa utilizar para rodar os códigos? pelo que vi, essa sintaxe não é do VisualG.

E visual G mas acho que fiz tudo errado.

Eu sou novo no curso de programação 

 

 

adicionado 1 minuto depois

O programa é Visual G

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 minuto atrás, Leoasustgx disse:

E visual G mas acho que fiz tudo errado.

Eu sou novo no curso de programação

 

"Tudo errado" é exagero. Falta apenas ajustar para sintaxe do programa. Algo assim:

algoritmo "Execício 1"
var
   i    :inteiro
   num  :inteiro
   soma :inteiro
inicio
   soma <- 0
   para i de 1 ate 5 faca
      leia( num)
      se num mod 2 = 0 entao
         soma <- soma + (num * num)
      fimSe
   fimpara
   escreval(soma)
fimAlgoritmo

 

e

 

algoritmo "Execício 2"
var
   num       :inteiro
   contPar   :inteiro
   contImpar :inteiro
inicio
   repita
      leia(num)
      se (num mod 2 = 0) e (num <> 0)entao
         contPar <- contPar + 1
      senao
         contImpar <- contImpar+1
      fimSe
   ate num = 0
   escreval("Pares  : ", contPar)
   escreval("Ímpares: ", contImpar)
fimAlgoritmo

 

Então, na verdade, você precisa já implementar de acordo com sintaxe da "linguagem" que está estudando.

 

Você precisa ir evoluindo o nível dos problemas aos poucos... por exemplo: não faz muito sentido você ainda não saber a base da sintaxe do VisualG, mas já ter noção de como funciona um laço de repetição...

 

Vá evoluindo aos poucos mesmo. Sugiro ver outras postagem sobre VisualG aqui no fórum...

 

Obs.: para o segundo exercício falta fazer "ignorar o zero". Ele está entrando na conta.

Compartilhar este post


Link para o post
Compartilhar em outros sites

obrigado pela ajuda vou ver mas atividades bem simples pra eu poder aprender 

Compartilhar este post


Link para o post
Compartilhar em outros sites
4 horas atrás, Simon Viegas disse:

 

"Tudo errado" é exagero. Falta apenas ajustar para sintaxe do programa. Algo assim:


algoritmo "Execício 1"
var
   i    :inteiro
   num  :inteiro
   soma :inteiro
inicio
   soma <- 0
   para i de 1 ate 5 faca
      leia( num)
      se num mod 2 = 0 entao
         soma <- soma + (num * num)
      fimSe
   fimpara
   escreval(soma)
fimAlgoritmo

 

e

 


algoritmo "Execício 2"
var
   num       :inteiro
   contPar   :inteiro
   contImpar :inteiro
inicio
   repita
      leia(num)
      se (num mod 2 = 0) e (num <> 0)entao
         contPar <- contPar + 1
      senao
         contImpar <- contImpar+1
      fimSe
   ate num = 0
   escreval("Pares  : ", contPar)
   escreval("Ímpares: ", contImpar)
fimAlgoritmo

 

Então, na verdade, você precisa já implementar de acordo com sintaxe da "linguagem" que está estudando.

 

Você precisa ir evoluindo o nível dos problemas aos poucos... por exemplo: não faz muito sentido você ainda não saber a base da sintaxe do VisualG, mas já ter noção de como funciona um laço de repetição...

 

Vá evoluindo aos poucos mesmo. Sugiro ver outras postagem sobre VisualG aqui no fórum...

 

Obs.: para o segundo exercício falta fazer "ignorar o zero". Ele está entrando na conta.

esta dando erro em leia (num)

quando tiro ele funcionar 

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Leoasustgx disse:

esta dando erro em leia (num)

 

Qual erro?

 

 

 

1 hora atrás, Leoasustgx disse:

quando tiro ele funcionar 

 

Sem ele não tem como funcionar... pode no máximo "rodar sem erros" de sintaxe (mas necessariamente estará com erro de lógica). :)

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 20/09/2019 às 17:08, Leoasustgx disse:

esta dando erro em leia (num)

quando tiro ele funcionar 

Tem como tu verificar se esta correto essas eu fiz hoje.

 

1)Imprimir todos os números de 1 até 20.
 

Var

i:inteiro



inicio



Para i de 1 ate 20 faca



     escreval(i)



     fimpara



fimalgoritmo

2) Entrar com dois números e imprimir todos os números do

menor para o maior.

 

Var

i:inteiro

inicio

Para i de 20 ate 0 passo -1 faca

 escreval(i)

 fimpara



fimalgoritmo

 

3) Entrar com vários números até que o número 0 seja digitado

e imprimir o somatório desses números.

 

Var

numero,soma:inteiro

inicio

escreva("Digite um numero inteiro,ou 0 para encerrar:")

leia(numero)



enquanto numero <> 0 faca

soma<- soma + numero



escreva("Digite um numero inteiro,ou 0 para encerrar:")

leia(numero)



fimenquanto



escreval(" A soma dos números: ", soma)

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sobre:

Em 21/09/2019 às 17:08, Leoasustgx disse:

1)Imprimir todos os números de 1 até 20.

 

Está legal.

 

 

 

Sobre:

Em 21/09/2019 às 17:08, Leoasustgx disse:

2) Entrar com dois números e imprimir todos os números do menor para o maior.

 

Esse precisa corrigir. Por exemplo: se eu inserir 4 e 10, deverá aparecer na tela:

4
5
6
7
8
9
10

Você precisa ler os dois número, aí poderia utilizar um para ir do menor até o maior.

 

 

 

Em 21/09/2019 às 17:08, Leoasustgx disse:

3) Entrar com vários números até que o número 0 seja digitado e imprimir o somatório desses números.

 

Está legal também. Uma outra forma seria com repita/ate.

algoritmo "Exercicio 03"
var
   numero, soma:inteiro
inicio
   repita
      escreva("Digite um numero inteiro,ou 0 para encerrar:")
      leia(numero)
      soma <- soma + numero
   ate numero = 0
   escreval(" A soma dos números: ", soma)
fimAlgoritmo

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
13 horas atrás, Simon Viegas disse:

Sobre:

 

Está legal.

 

 

 

Sobre:

 

Esse precisa corrigir. Por exemplo: se eu inserir 4 e 10, deverá aparecer na tela:


4
5
6
7
8
9
10

Você precisa ler os dois número, aí poderia utilizar um para ir do menor até o maior.

 

 

 

 

Está legal também. Uma outra forma seria com repita/ate.


algoritmo "Exercicio 03"
var
   numero, soma:inteiro
inicio
   repita
      escreva("Digite um numero inteiro,ou 0 para encerrar:")
      leia(numero)
      soma <- soma + numero
   ate numero = 0
   escreval(" A soma dos números: ", soma)
fimAlgoritmo

 

 

Nesse caso como ficaria a segunda questao

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Leoasustgx disse:

Nesse caso como ficaria a segunda questao

 

Foi uma pergunta?

 

Então, primeiramente entenda o problema.... e a busca de uma solução deve inicialmente partir de você, mas eu já dei uma boa dica:

1 hora atrás, Leoasustgx disse:

Você precisa ler os dois número, aí poderia utilizar um para ir do menor até o maior.

 

Vá tentando aí e poste o código de até onde conseguiu fazer e onde está com dúvidas.

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Simon Viegas disse:

 

Foi uma pergunta?

 

Então, primeiramente entenda o problema.... e a busca de uma solução deve inicialmente partir de você, mas eu já dei uma boa dica:

 

Vá tentando aí e poste o código de até onde conseguiu fazer e onde está com dúvidas.

veja ai se esta no caminho

n1: inteiro
n2: inteiro
inicio
n1 = inteiro(leia("Digite um Número"))
n2 = inteiro(leia('Digite outro Número'))
se (n1 > n2) {
escreva( n2, n1)
} se não {
escreva(n1, n2)
}
adicionado 0 minutos depois

segunda questão

Compartilhar este post


Link para o post
Compartilhar em outros sites
27 minutos atrás, Leoasustgx disse:

veja ai se esta no caminho


n1: inteiro
n2: inteiro
inicio
n1 = inteiro(leia("Digite um Número"))
n2 = inteiro(leia('Digite outro Número'))
se (n1 > n2) {
escreva( n2, n1)
} se não {
escreva(n1, n2)
}
adicionado 0 minutos depois

segunda questão

 

Que "segunda questão" você se refere? esse código acima me parece um algoritmo que recebe 2 números e exibe-os ordem decrescente. Era isso?

 

Sugiro que poste o enunciado completo do que está sendo pedindo. Após, poste o que você entendeu do problema e onde está com dúvidas (para entender o problema... a dúvida para criar uma algoritmo que resolva o problema é uma etapa posterior! primeiro entenda o que se trata).

Compartilhar este post


Link para o post
Compartilhar em outros sites
29 minutos atrás, Simon Viegas disse:

 

Que "segunda questão" você se refere? esse código acima me parece um algoritmo que recebe 2 números e exibe-os ordem decrescente. Era isso?

 

Sugiro que poste o enunciado completo do que está sendo pedindo. Após, poste o que você entendeu do problema e onde está com dúvidas (para entender o problema... a dúvida para criar uma algoritmo que resolva o problema é uma etapa posterior! primeiro entenda o que se trata).

Essa e a pergunta da questão

 

Entrar com dois números e imprimir todos os números do
menor para o maior.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vamos lá:

 

O enunciado está pedindo alguma coisa. Temos:

1 hora atrás, Leoasustgx disse:

Entrar com dois números e imprimir todos os números do menor para o maior.

 

O que você entendeu disso? por favor. Me explique como você entendeu ou onde está com dúvidas.

 

Eu entendi que tem que fazer isso:

 

5 horas atrás, Leoasustgx disse:

[...] se eu inserir 4 e 10, deverá aparecer na tela:


4
5
6
7
8
9
10

 

Primeiro você precisa entender o problema. Ou seja: se você também entendeu que é assim, você deve fazer um programa que, ao receber 4 e 10, vai aparecer na tela como citado acima, OU, se você discorda desse entendimento, você precisa explicar a forma que você entendeu. :)

 

 

Outro ponto é que, se está programando em VisualG, tem que implementar na sintaxe dele.

 

Segue teu código na sintaxe do VisualG:

algoritmo "semnome"
var
   n1 :inteiro
   n2 :inteiro
inicio
   escreval("Digite um Número")
   leia(n1)
   escreval("Digite outro Número")
   leia(n2)
   se (n1 > n2) entao
      escreva(n2, n1)
   senao
      escreva(n1, n2)
   fimSe
fimAlgoritmo

 

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
45 minutos atrás, Simon Viegas disse:

Vamos lá:

 

O enunciado está pedindo alguma coisa. Temos:

 

O que você entendeu disso? por favor. Me explique como você entendeu ou onde está com dúvidas.

 

Eu entendi que tem que fazer isso:

 

 

Primeiro você precisa entender o problema. Ou seja: se você também entendeu que é assim, você deve fazer um programa que, ao receber 4 e 10, vai aparecer na tela como citado acima, OU, se você discorda desse entendimento, você precisa explicar a forma que você entendeu. :)

 

 

Outro ponto é que, se está programando em VisualG, tem que implementar na sintaxe dele.

 

Segue teu código na sintaxe do VisualG:


algoritmo "semnome"
var
   n1 :inteiro
   n2 :inteiro
inicio
   escreval("Digite um Número")
   leia(n1)
   escreval("Digite outro Número")
   leia(n2)
   se (n1 > n2) entao
      escreva(n2, n1)
   senao
      escreva(n1, n2)
   fimSe
fimAlgoritmo

 

 

 

 

eu entendi mas fazer estou com dificuldade em montar esse algoritmo

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
14 minutos atrás, Leoasustgx disse:

eu entendi mas fazer estou com dificuldade em montar esse algoritmo

 

Entendeu o quê?

 

O cerne aqui não é em montar um algoritmo que resolva um programa, mas sim entender o problema em si. O que você entendeu do problema ou qual a sua dúvida (em entender esse problema?)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!