×
Ir ao conteúdo
  • Cadastre-se

VisualG Problema com (Esperava encontrar FACA) visualg


Ir à solução Resolvido por Simon Viegas,

Posts recomendados

Eu estou tendo um problema em não conseguir executar meu arquivo .alg, ele fala que o faça esta faltando em meu algoritmo, mas ele simplesmente está no algoritmo. E mesmo eu reiniciando meu programa, ele continua dando erro, e eu não acho esse tal erro, já tentei mudar tipo de var, mas nada muda.

 

No momento ele está assim:

 

algoritmo "semnome"
var
   R, D, Con, S: REAL
inicio
      D <- 1
      S <- 0
      Enquanto(D <= 5) faca
               Escreva("Qual o valor em R$? ")
               Leia(R)
               D <- R/5,62
               EscrevaL("O Valor convertido e US$", D:5:2)
               Con <- Con + 1
               S <- S + D
      FimEnquanto
fimalgoritmo

 

Lembrando que o algoritmo não está de fato pronto, so executei o para saber se o valor estava sendo colocado na variável certa.

Link para o comentário
Compartilhar em outros sites

  • Moderador

@CriadorDeTravaZap, provavelmente algum caractere bugando no meio da linha.. apaga toda a linha e escreva novamente.

 

Segue:

algoritmo "semnome"
var
   R, D, Con, S: REAL
inicio
   D <- 1
   S <- 0
   enquanto (D <= 5) faca
      escreva("Qual o valor em R$? ")
      leia(R)
      D <- R/5,62
      escrevaL("O Valor convertido e US$", D:5:2)
      Con <- Con + 1
      S <- S + D
   fimEnquanto
fimAlgoritmo

 

Link para o comentário
Compartilhar em outros sites

  • 3 meses depois...
Em 27/10/2020 às 21:37, CriadorDeTravaZap disse:

Eu estou tendo um problema em não conseguir executar meu arquivo .alg, ele fala que o faça esta faltando em meu algoritmo, mas ele simplesmente está no algoritmo. E mesmo eu reiniciando meu programa, ele continua dando erro, e eu não acho esse tal erro, já tentei mudar tipo de var, mas nada muda.

 

No momento ele está assim:

 


algoritmo "semnome"
var
   R, D, Con, S: REAL
inicio
      D <- 1
      S <- 0
      Enquanto(D <= 5) faca
               Escreva("Qual o valor em R$? ")
               Leia(R)
               D <- R/5,62
               EscrevaL("O Valor convertido e US$", D:5:2)
               Con <- Con + 1
               S <- S + D
      FimEnquanto
fimalgoritmo

 

Lembrando que o algoritmo não está de fato pronto, so executei o para saber se o valor estava sendo colocado na variável certa.

comigo está ocorrendo a mesma, fechei e abri a IDE e nada , fiz já uns testes pra ver ser realmente erra erro meu ou erro da IDE , escrevi e apaguei varias vezes e nada também.....

 

image.thumb.png.4a72ce360af879214ef645244f9e662e.png

Link para o comentário
Compartilhar em outros sites

@Simon Viegas, fiz o código simples apenas pra teste. Não sei se é algum erro na parte de tradução do português.

 

// Função :
// Autor :
// Data : 10/02/2021
// Seção de Declarações 
var
   n: inteiro
inicio
        n<- 0
        Enquanto(n <= 0) faca
                   Escreval(n)
                   n<- n +1
        FimEnquanto
fimalgoritmo
Link para o comentário
Compartilhar em outros sites

  • Moderador
  • Solução

@NOT DEAD, aparentemente é a falta de espaço após o Enquanto.

 

Dá uma testada aí nos avisa.

 

Dica:

Mantenha o código sempre indentado. No VisualG, pressione Ctrl+G para ganhar uma ajuda.

 

Segue um exemplo de código um pouco mais organizado:

algoritmo "sem nome"
var
   n: inteiro
inicio
   n <- 0
   enquanto (n <= 0) faca
      escreval(n)
      n <- n+1
   fimEnquanto
fimAlgoritmo

 

ADENDO:

Sugiro também utilizar a versão 3.0.6.5, que seria a mais estável.

Exemplo de fonte para download:
https://baixe.net/download/4313/visualg/

 

Link para o comentário
Compartilhar em outros sites

  • 9 meses depois...

@Simon Viegas meu código está dando a mesma coisa, não entendo porque.

 

ALGORITMO "semnome"
VAR
   idade:inteiro
   cabelo:caractere
   genero:caractere
   q: inteiro
   j: inteiro
   continuar:caractere
INICIO
   continuar <- "S"
   enquanto(continuar = "S") faca
      ecreval("quantos anos")
      leia(idade)
      ecreval("cor do cabelo")
      escreval("loiro[L]escuro[E]claro[C]azul[A]")
      leia(cabelo)
      ecreval("homem ou mulher[H][M]")
      leia(genero)
      se(genero = "H")e(cabelo = "L")e(idade >18)e(idade <25)   entao
         q <- q+1
      fimse
      se(genero = "M")e(cabelo = "A")e(idade >16)e(idade <30)   entao
         j <- j+1
      fimse
      escreval("deseja continuar?")
      leia(continuar)
   fimenquanto
   escreval("o numero de homens com cabelo loiro e com idade entre 18 e 25 anos é: ",q)
   escreval("o numero de mulheres com cabelo azul e idade entre 16 e 30 anos é : ",j)
FIMALGORITMO

 

Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Ebook grátis: Aprenda a ler resistores e capacitores!

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!