Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
ET Bilu

Matrizes - produtos de uma loja

Recommended Posts

Estou extremamente perdido nesse exercício:

 

"Faça um programa que preencha: a. Um vetor de 8 posições, contendo nomes de lojas; b. Outro vetor com quatro posições contendo nomes de produtos; c. Uma matriz com os preços de todos os produtos em cada loja. O programa deverá mostrar todas as relações (nome do produto – nome da loja) em que o preço não ultrapasse R$ 120,00."

 

Como faço para associar uma matriz com dados de caractere?? cada elemento ter sua identificação, buguei. Aqui está o que eu fiz:

 

algoritmo "semnome"
// Função :
// Autor :
// Data : 25/11/2016
// Seção de Declarações
var
v:vetor[1..8] de caractere
v2:vetor[1..4] de caractere
m:vetor[1..8,1..4] de inteiro
l,c,i,i2:inteiro
inicio
para i de 1 ate 8 faca
   escreva("nome da loja")
   leia(v[i])
fimpara
para i de 1 ate 4 faca
   escreva("nome do produto")
   leia(v2[i])
fimpara
para c de 1 ate 8 faca
   para l de 1 ate 4 faca
      escreva
   fimpara
fimpara



fimalgoritmo

 

Editado por ET Bilu
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Parei pra fazer do zero, e parece razoável. 

     

    algoritmo "ex5"
    // Função :
    // Autor :
    // Data : 27/11/2016
    // Seção de Declarações
    var
    lojas:vetor[1..8] de caractere
    produtos:vetor[1..4] de caractere
    precos:vetor[1..8,1..4] de real
    i,c,l:inteiro
    inicio
    para i de 1 ate 8 faca
       escreval("lojas")
       leia(lojas[i])
    fimpara
    para i de 1 ate 4 faca
       escreval("produtos")
       leia(produtos[i])
    fimpara
    para c de 1 ate 8 faca
       para l de 1 ate 4 faca
          escreval("preço produto loja ",lojas[c],"produto ",produtos[l])
          leia(precos[c,l])
       fimpara
    fimpara
    para c de 1 ate 8 faca
       para l de 1 ate 4 faca
          se precos[c,l]<=120 então
             escreval("loja ",lojas[c]," produto ",produtos[l]," preço",precos[c,l:3])
          fimse
       fimpara
    fimpara
    
    
    
    fimalgoritmo

    E muita coisa e eu n parei p ver se tem erro, pelo gerador de numeros aleatorios me parece funcionável o programa.

    adicionado 13 minutos depois

    ARRUMADO:

     

    algoritmo "ex5"
    // Função :
    // Autor :
    // Data : 27/11/2016
    // Seção de Declarações
    var
    lojas:vetor[1..8] de caractere
    produtos:vetor[1..4] de caractere
    precos:vetor[1..8,1..4] de real
    i,c,l:inteiro
    inicio
    para i de 1 ate 8 faca
       escreval("lojas")
       leia(lojas[i])
    fimpara
    para i de 1 ate 4 faca
       escreval("produtos")
       leia(produtos[i])
    fimpara
    para c de 1 ate 8 faca
       para l de 1 ate 4 faca
          escreval("preço produto ",produtos[l])
          leia(precos[c,l])
          se precos[c,l]<=120 então
             escreval("loja ",lojas[c]," produto ",produtos[l]," preço",precos[c,l])
          fimse
       fimpara
    fimpara
    fimalgoritmo

     

    Editado por ET Bilu
    novo alg
    • Curtir 2

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Olá.

     

    Em 25/11/2016 às 22:39, ET Bilu disse:

    O programa deverá mostrar todas as relações (nome do produto – nome da loja) em que o preço não ultrapasse R$ 120,00."

     

    Pelo que eu entendi, você está exibindo os dados da matriz junto com a leitura deles... acho que deveria separar: primeiro ler, depois exibe.

     

    PS: por que está utilizando "c" e "l" para matriz? é inicial de algo?

     

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Olá.

     

    4 horas atrás, ET Bilu disse:

    Acho que isso eu já tinha consertado.  

     

     

    Sobre:

    6 horas atrás, Simon Viegas disse:

    Pelo que eu entendi, você está exibindo os dados da matriz junto com a leitura deles... acho que deveria separar: primeiro ler, depois exibe.

     

    Estou me referindo a esse trecho.

    19 horas atrás, ET Bilu disse:
    
    para c de 1 ate 8 faca
       para l de 1 ate 4 faca
          escreval("preço produto ",produtos[l])
          leia(precos[c,l])
          se precos[c,l]<=120 então
             escreval("loja ",lojas[c]," produto ",produtos[l]," preço",precos[c,l])
          fimse
       fimpara
    fimpara

     

     

    Você está lendo o preço, logo exibindo os dados...

     

    Eu não estou dizendo que necessariamente tem que ser separado, mas o seu código acima está junto.

     

    Se for como estou sugerindo, primeiro você ler todos os preços... após exibe os dados como foi pedido.

     

    Editado por Simon Viegas
    • Curtir 2

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×