Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
SouzaPro

formula procv excel

Recommended Posts

Alguem poderia me dizer o que ha de errado com minha formula, ela só procura o primeiro valor na Empresa 1, a segunda parte que seria pesquisar ainda na Empresa1 e a partir dela ela não esta fazendo !!!
FORMULA:

=SE(E(Pedidos!B18=Fabricas!A3;Pedidos!E18=J12);SEERRO(PROCV(Pedidos!A20;Empresa1!$A$15:E$3000;2;0));SE(E(Pedidos!B18=Fabricas!A3;Pedidos!E18=J13);SEERRO(PROCV(Pedidos!A20;Empresa1!$I$15:Microsoft3000;2;0)); SE(E(Pedidos!B18=Fabricas!A4;Pedidos!E18=12);SEERRO(PROCV(Pedidos!A20;Empresa2!$A$15:E$3000;2;0)); SE(E(Pedidos!B18=Fabricas!A4;Pedidos!E18=13);SEERRO(PROCV(Pedidos!A20;Empresa2!$I$15:Microsoft3000;2;0));SE(E(Pedidos!B18=Fabricas!A5;Pedidos!E18=12);SEERRO(PROCV(Pedidos!A20;Empresa3!$A$15:E$3000;2;0)); SE(E(Pedidos!B18=Fabricas!A5;Pedidos!E18=J13);SEERRO(PROCV(Pedidos!A20;Empresa3!$I$15:Microsoft3000;2;0));SE(E(Pedidos!B18=Fabricas!A6;Pedidos!E18=J12);SEERRO(PROCV(Pedidos!A20;Empresa4!$A$15:E$3000;2;0)); SE(E(Pedidos!B18=Fabricas!A6;Pedidos!E18=J13);SEERRO(PROCV(Pedidos!A20;Empresa4!$I$15:Microsoft3000;2;0));SE(E(Pedidos!B18=Fabricas!A7;Pedidos!E18=J12);SEERRO(PROCV(Pedidos!A20;Empresa5!$A$15:E$3000;2;0)); SE(E(Pedidos!B18=Fabricas!A7;Pedidos!E18=J13);SEERRO(PROCV(Pedidos!A20;Empresa5!$I$15:Microsoft3000;2;0));

Teste.rar

Editado por SouzaPro

Compartilhar este post


Link para o post
Compartilhar em outros sites

Cola a planilha para ter uma idea melhor e se possível onde o Excel indica que é o erro.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

Para facilitar, anexe uma planilha demonstrando manualmente o resultado esperado.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

Troque sua fórmula por esta e verifique se deu certo:

 

=SE(E(Pedidos!B18=Fabricas!A3;Pedidos!E18=J12);PROCV(Pedidos!A20;Empresa1!$A$15:E$3000;2;0);SE(E(Pedidos!B18=Fabricas!A3;Pedidos!E18=J13);PROCV(Pedidos!A20;Empresa1!$I$15:Microsoft3000;2;0); SE(E(Pedidos!B18=Fabricas!A4;Pedidos!E18=12);PROCV(Pedidos!A20;Empresa2!$A$15:E$3000;2;0); SE(E(Pedidos!B18=Fabricas!A4;Pedidos!E18=13);PROCV(Pedidos!A20;Empresa2!$I$15:Microsoft3000;2;0);SE(E(Pedidos!B18=Fabricas!A5;Pedidos!E18=12);PROCV(Pedidos!A20;Empresa3!$A$15:E$3000;2;0); SE(E(Pedidos!B18=Fabricas!A5;Pedidos!E18=J13);PROCV(Pedidos!A20;Empresa3!$I$15:Microsoft3000;2;0);SE(E(Pedidos!B18=Fabricas!A6;Pedidos!E18=J12);PROCV(Pedidos!A20;Empresa4!$A$15:E$3000;2;0); SE(E(Pedidos!B18=Fabricas!A6;Pedidos!E18=J13);PROCV(Pedidos!A20;Empresa4!$I$15:Microsoft3000;2;0);SE(E(Pedidos!B18=Fabricas!A7;Pedidos!E18=J12);PROCV(Pedidos!A20;Empresa5!$A$15:E$3000;2;0); SE(E(Pedidos!B18=Fabricas!A7;Pedidos!E18=J13);PROCV(Pedidos!A20;Empresa5!$I$15:Microsoft3000;2;0);""))))))))))

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Arquivo !!!

    Teste.rar

    adicionado 1 minuto depois

    @diego_janjao Então agora pelo menos não fica FALSO quando não tem nada selecionado, porém funciona somente para primeira situação, para as outras ela não funciona igual a minha, coloquei o arquivo para ver se melhora visualização pois só falta isso para acabar.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×