Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Jardelson Oliveira

copiando formulas complexas no excel

Recommended Posts

Bom dias colegas, estou montado uma formular no excel e preciso repetir uma formular que busca resultados em diferentes celulas, como faço para não ter que copiar uma a uma? Segue modelo da formula:

Linha 4 =SE(C4<>0;SOMA(P89:P91);"")

Linha 5 =SE(C5<>0;SOMA(P96:P98);"")

Linha 6 =SE(C6<>0;SOMA(P103:P105);"")

Linha 7 ........

Tenho que repetir mais de 100 vezes. Existe uma forma de copiar as formulas seguindo esse mesmo padrão?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Uma forma de fazer

 

=SE(C4<>0;SOMA(INDIRETO("P"&(LIN($A$82)+(7*LIN(A1)))&":P"&(LIN($A$84)+(7*LIN(A1)))));"")

 

Se foi útil clica no curtir é uma forma de agradecimento pela ajuda

 

Decio

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Na primeira linha funcionou, já quando copio para próximas linhas não aparece o soma. É uma forma diferente de copiar para outras linhas?

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Boa noite Jardelson

     

    Para facilitar anexe uma planilha de exemplo.

     

    []s

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    @Jardelson Oliveira , Bom Dia.

     

    Conforme sua formula pulando de 7 em 7, olha o modelo que fiz, pode arrastar mais uma para baixo vê o resultado, sera 120,, mas lembra para aparecer o resultado a célula C7 tem que ter valor, conforme sua formula,  ela funciona normalmente.

     

    Mas segue orientação do colega @Patropi , poste um modelo

     

    Decio

     

    Modelo Decio.xlsx

    Editado por deciog
    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • 14 horas atrás, deciog disse:

    @Jardelson Oliveira , Bom Dia.

     

    Conforme sua formula pulando de 7 em 7, olha o modelo que fiz, pode arrastar mais uma para baixo vê o resultado, sera 120,, mas lembra para aparecer o resultado a célula C7 tem que ter valor, conforme sua formula,  ela funciona normalmente.

     

    Mas segue orientação do colega @Patropi , poste um modelo

     

    Decio

     

    Modelo Decio.xlsx

    Muito obrigado amigo, deu certinho... valeu mesmo :tw_thumbsup:

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×