Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Iyhoga GC

VisualG Programa para gerenciar quis

Recommended Posts

Então pessoal quero fazer um quis,  se a pessoa errar tem que voltar para a mesma questão, tentei com repita + não deu certo, e no final se a pessoa acerta igual ou maior que 7 acertos então mostrar na tela aprovado se menos então mostrar reprovado.

inicio

escreval("1)Victor desenhou o triângulo determinado pelas coordenadas")
escreval("dos pontos cartesianos A(7;5), B(3;2) e C(7;2)")
escreval("Ao calcular a área e o perímetro desse triângulo,")
escreval("os valores obtidos foram, respectivamente,")
escreval("(imaginando que a dez colunas verticais e dez horizontais)")
escreval("utilizem o teorema de Pitágoras :")
escreval("a) 3 e 3")
escreval("b) 3 e 6")
escreval("c) 6 e 6")
escreval("d) 6 e 12")
escreval("e) 12 e 12")
leia(resposta)

se resposta="d" então
escreval("resposta correta")


fimse

 

Editado por Iyhoga GC
Favor ler tópico e seguir orientações sobre POSTAGEM DE CÓDIGOS: http://www.clubedohardware.com.br/announcement/27-poste-seus-c%C3%B3digos-corretamente/

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • 9 horas atrás, Simon Viegas disse:

    Olá @Iyhoga GC.

     

    Poste o código completo para podermos analisar.


    Então é que o código é praticamente a mesma coisa depois, eu tentei fazer algumas alterações para colocar repita + dava erro é por isso q to perguntando pra vê se alguém sabe como faz

    var
    resposta:literal
    d:real
    inicio
    // Seção de Comandos 
    
    escreval("1)Victor desenhou o triângulo determinado pelas coordenadas")
    escreval("dos pontos cartesianos A(7;5), B(3;2) e C(7;2)")
    escreval("Ao calcular a área e o perímetro desse triângulo,")
    escreval("os valores obtidos foram, respectivamente,")
    escreval("(imaginando que a dez colunas verticais e dez horizontais)")
    escreval("utilizem o teorema de Pitágoras :")
    escreval("a)3 e 3")
    escreval("b) 3 e 6")
    escreval("c) 6 e 6")
    escreval("d) 6 e 12")
    escreval("e) 12 e 12")
    leia(resposta)
    
    se resposta="d" então
    escreval("resposta correta")
    
    
    fimse
    escreval("2)    México, Colômbia, Peru e Chile decidiram seguir um")
    escreval("caminho mais curto para a integração regional. Os quatro")
    escreval("países, em meados de 2012, criaram a Aliança do Pacífico e")
    escreval("eliminaram, em 2013, as tarifas aduaneiras de 90% do total")
    escreval("de produtos comercializados entre suas fronteiras.")
    escreval("a) promover a livre circulação de trabalhadores.")
    escreval("b) fomentar a competitividade no mercado externo.")
    escreval("c) restringir investimentos de empresas multinacionais.")
    escreval("d) adotar medidas cambiais para subsidiar o setor agrícola.")
    escreval("e) reduzir a fiscalização alfandegária para incentivar o consumo.")
    leia(resposta)
    
    se resposta="b" então
    escreval("resposta correta")
    fimse
    limpatela
    escreval("3)Como descobrir quantos degraus são visíveis numa escada")
    escreval("rolante. foi feito o seguinte: duas pessoas começaram a subir")
    escreval("a escada juntas, Pedro subindo um degrau de cada vez")
    escreval("enquanto Lucas subia dois. Ao chegar ao topo, o primeiro")
    escreval("contou 21 degraus enquanto o outro 28. Com esses dados foi")
    escreval("possível responder a questão. Quantos degraus são visíveis")
    escreval("nessa escada rolante? (obs: a escada está andando).")
    escreval("A)São visíveis 45 degraus na escada rolante")
    escreval("B)São visíveis 42 degraus  na escada rolante")
    escreval("C)São visíveis 38 degraus na escada rolante")
    escreval("D)São visíveis 28 degraus na escada rolante")
    escreval("E)São visíveis 29 degraus na escada rolante")
    leia(resposta)
    
    se resposta="b" então
    escreval("resposta correta")
    fimse
    escreval("4)    Forme o número 24 usando apenas os números 3, 3, 7, 7,")
    escreval("uma vez cada. Você pode usar as operações +, -, *, /, e")
    escreval("também os parênteses, se achar necessário.")
    escreval("a)(3-(7/3) / 7")
    escreval("b)3+7+7/3")
    escreval("c)(3+(3/7) x 7)")
    escreval("d)(7+(7/3) +3)")
    escreval("e)7-( 3/7)+3")
    
    se resposta="c" então
    escreval("resposta correta")
    fimse
    limpatela
    escreval(" 5)    Art. 231. São reconhecidos aos índios sua organização")
    escreval("  social, costumes, línguas, crenças e tradições, e os direitos")
    escreval("  originários sobre as terras que tradicionalmente ocupam,")
    escreval("  competindo à União demarcá-las, proteger e fazer respeitar")
    escreval("  todos os seus bens.")
    escreval("  A persistência das reivindicações relativas à aplicação desse")
    escreval("  preceito normativo tem em vista a vinculação histórica")
    escreval("  fundamental entre")
    escreval("  a) etnia e miscigenação racial.")
    escreval("  sociedade e igualdade jurídica.")
    escreval("  c) espaço e sobrevivência cultural.")
    escreval("  d) progresso e educação ambiental.")
    escreval("  e) bem-estar e modernização econômica.")
    
    se resposta="c" então
    escreval("resposta correta")
    fimse
    escreval("As soluções-tampão são utilizadas para regular a acidez")
    escreval("de alguns sistemas, pois resistem às variações do pH quando")
    escreval("pequenas quantidades de um ácido ou de uma base são")
    escreval("adicionadas a esses sistemas. Os tampões têm importante")
    escreval("função nos processos químicos e biológicos, como, por")
    escreval("exemplo, a de impedir grandes variações do pH do sangue ")
    escreval("Um dos sistemas que contribuem para o tamponamento do")
    escreval("sangue é constituído pelas substâncias H2CO3 e NaHCO3.")
    escreval("As equações químicas abaixo representam os equilíbrios")
    escreval("dessas substâncias no sangue.")
    escreval(" H2CO3(aq) ? CO2(g) + H2O(l)")
    escreval(" NaHCO3(aq) ? HCO?3(aq) + Na+3(aq)")
    escreval("O pH desse sistema-tampão pode ser calculado pela")
    escreval("seguinte expressão:")
    escreval("pH = pKA + log10 [HCO?3][H2CO3]")
    escreval(" No sangue, a concentração de ácido carbônico varia com a ")
    escreval(" pressão parcial do CO2. Uma pessoa em repouso respira")
    escreval(" normalmente. Em determinado momento, porém, ela prende")
    escreval(" a respiração, ficando em apneia pelo maior tempo que")
    escreval(" consegue suportar, provocando, daí em diante,")
    escreval(" hiperventilação pulmonar. As curvas mostradas no gráfico ")
    escreval("abaixo representam alterações de pH do sangue num")
    escreval("determinado período de tempo, a partir do início da apneia. ")
    escreval("A)    W ")
    escreval("B)    X ")
    escreval("C)    Y ")
    escreval("D)    Z  ")
    escreval("E)    K ")
    leia(resposta)
    
    se resposta="c" então
    escreval("resposta correta")
    fimse
    limpatela
    escreval("7) Só um maluco pularia de uma rampa de 26 metros de")
    escreval("altura, certo? Certo. Os skatistas só enfrentam a")
    escreval("megarrampa porque dormiram nas aulas de física. Eles são")
    escreval("loucos, diz o professor de física Pierluiggi Piazzi. Ele está")
    escreval("se referindo ao desafio do Skate Big Air, o maior dos")
    escreval("esportes radicais. Criada há dez anos pelo skatista")
    escreval(" americano Danny Way, a megarrampa se tornou")
    escreval(" mundialmente conhecida quando foi incluída nos X Games,")
    escreval(" a Olimpíada dos esportes radicais. Na megarrampa, a ação")
    escreval(" da gravidade é primordial para a execução do salto. É ela ")
    escreval(" que freia e acelera o atleta durante a trajetória. Contudo, a ")
    escreval(" energia acumulada no ponto mais alto da rampa é o")
    escreval(" ingrediente que dará o tom emocionante ao esporte. Sob tais")
    escreval(" condições, esse esporte induz nos participantes o aumento")
    escreval(" na produc?a?o de adrenalina. Observe a fórmula estrutural")
    escreval(" desse composto:")
    escreval(" A)    A glândula responsável pela produção do hormônio é a hipófise e sua função é vasoconstrictora.")
    escreval("   A adrenalina é uma molécula aquiral.")
    escreval(" C)    No topo da rampa a energia acumulada é cinética.")
    escreval(" D)    A presença de uma base de Lewis faz com que a substância apresente atividade óptica.")
    escreval(" E)    A energia acumulada pelo atleta no topo da rampa é potencial, que é convertida em cinética durante a descida")
    
    se resposta="e" então
    escreval("resposta correta")
    fimse
    fimalgoritmo

     

    Editado por Simon Viegas
    Favor ler tópico e seguir orientações sobre POSTAGEM DE CÓDIGOS: http://www.clubedohardware.com.br/announcement/27-poste-seus-c%C3%B3digos-corretamente/

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Olá @Iyhoga GC.

     

     

    19 horas atrás, Iyhoga GC disse:

    Então pessoal quero fazer um quis, [...]

     

    A primeira coisa que verificar é de fato o que você precisa. Então, de onde surgiu "essa necessidade"? é algo que você resolveu fazer ou é algum exercício/trabalho? caso seja este último, poste o enunciado completo para analisarmos quais os requisitos e mais ou menos como deverá funcionar o seu algoritmo.

     

     

     

     

    19 horas atrás, Iyhoga GC disse:

    [...]se a pessoa errar tem que voltar para a mesma questão tentei com repita + não deu certo, [...]

     

    Pelo que eu entendi, teria que ter um repita/até para cada questão. Nesse caso, ficará repetindo a mesma estrutura várias vezes. Isso dá para resolver posteriormente.  Por enquanto tente fazer apenas com um e poste o código aqui para analisarmos.

     

     

    19 horas atrás, Iyhoga GC disse:

    [...] e no final se a pessoa acerta igual ou maior que 7 acertos então mostrar na tela aprovado se menos então mostrar reprovado.

    Então, essa parte eu não entendi.. se ao errar volta para a mesma questão, necessariamente todos vão acertar todos ou terá que ter alguma lógica para contabilizar os erros ou algo do tipo.

     

     

     

    No aguardo.

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • então é uma batalha que contra a pessoa q to competindo ela faz um enunciado e eu tenho q fazer o programa e eu faço enunciado e ela faz o programa, enunciado abaixo

     

    Faça com que as perguntas apareçam na tela junto as alternativas fazendo com que a alternativa certa siga para a próxima e a errada volte para a mesma questão que errou. Ao final do questionário calcule os acertos, se  igual  ou maior que 7 acertos então mostrar na tela aprovado se menos então mostrar reprovado 

     

    essa parte do igual ou maior que 7 também não entendi direito  

     

    var
    resposta:literal
    d:real
    inicio
    // Seção de Comandos
    repita
    escreval("1)Victor desenhou o triângulo determinado pelas coordenadas")
    escreval("dos pontos cartesianos A(7;5), B(3;2) e C(7;2)")
    escreval("Ao calcular a área e o perímetro desse triângulo,")
    escreval("os valores obtidos foram, respectivamente,")
    escreval("(imaginando que a dez colunas verticais e dez horizontais)")
    escreval("utilizem o teorema de Pitágoras :")
    escreval("a)3 e 3")
    escreval("b) 3 e 6")
    escreval("c) 6 e 6")
    escreval("d) 6 e 12")
    escreval("e) 12 e 12")
    leia(resposta)

    se resposta="d" então
    escreval("resposta correta")
    ate resposta="d"
    fimse
    fimalgoritmo

     

     

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Olá @Iyhoga GC.

     

    Prezado, favor editar sua postagem, apagar e reinserir o código, mas seguindo a orientação de utilizar a tag CODE.

     

    Favor ler tópico Poste seus códigos corretamente! contida no tópico desta pagina.

     

     

     

    No aguardo.

    adicionado 29 minutos depois

    ...

     

     

     

    11 horas atrás, Iyhoga GC disse:

    então é uma batalha que contra a pessoa q to competindo ela faz um enunciado e eu tenho q fazer o programa e eu faço enunciado e ela faz o programa, enunciado abaixo

    Beleza. Entendi.

     

     

     

    11 horas atrás, Iyhoga GC disse:

    Faça com que as perguntas apareçam na tela junto as alternativas fazendo com que a alternativa certa siga para a próxima e a errada volte para a mesma questão que errou. Ao final do questionário calcule os acertos, se  igual  ou maior que 7 acertos então mostrar na tela aprovado se menos então mostrar reprovado 

     

    essa parte do igual ou maior que 7 também não entendi direito  

     

    Ai você precisa verificar como vai ficar o programa. Pense assim... tente fazer esse desafio no papel.. como você faria? o Visualg entra apenas para automatizar... ou seja, como no seu atual, abaixo apenas corrigi os erros de sintaxe (regrada da linguagem). A parte da lógica tem que parti de você.

     

    Então, tente fazer esse exercício no papel.. como se fosse um jogo. Verás que alguns pontos têm que ser observados, por exemplo: Como faria para computador os pontos? por que ao errar volta para a mesma pergunta?

     

     

     

    Seu código tem apenas pequenos erros:

    - o tipo é caractere, não mais literal;

    - aparentemente você tentou declarar uma resposta como se fosse uma variável, mas não é assim que funciona. Você tem a penas a variável que recebe a resposta, e nos lugares apropriados (se e até) ela é comparada com um um "texto" que você definiu como certo. Entende?

     

     

    Tomando como base o Visualg 3.0.6.5, segue orientações:

    obs.: deixei o que está errado entre { } apenas para demonstrar. Pode apagar após ter entendio.

    algoritmo "FCdH"
    var
       {resposta:literal} //o tipo utilizado é o caractere
       resposta:caractere
       {d :real}          //variável não utilizada
    inicio
    repita
       escreval("1)Victor desenhou o triângulo determinado pelas coordenadas")
       escreval("dos pontos cartesianos A(7;5), B(3;2) e C(7;2)")
       escreval("Ao calcular a área e o perímetro desse triângulo,")
       escreval("os valores obtidos foram, respectivamente,")
       escreval("(imaginando que a dez colunas verticais e dez horizontais)")
       escreval("utilizem o teorema de Pitágoras :")
       escreval("a) 3 e 3")
       escreval("b) 3 e 6")
       escreval("c) 6 e 6")
       escreval("d) 6 e 12")
       escreval("e) 12 e 12")
       leia(resposta)
       se resposta="d" então
          escreval("resposta correta")
       fimse //você tinha colocado depois do repita
    ate resposta="d"
    fimalgoritmo

     

     

    Agora, tente elaborar como vai funcionar o seu quis. Daí você tenta implementar no seu algoritmo...

     

    Qualquer dúvidas é só postar.

     

     

    No aguardo.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×