• Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   13-02-2016

      Prezados membros do Clube do Hardware,

      Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:
        Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas ao formulário abaixo:    Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
Entre para seguir isso  
Seguidores 0
digao

Modem LG / Netodragon + Fedora 2.0

5 posts neste tópico

Salve pessoal

Comprei o Fedora 2.0 numa revista pra experimentar e gostei muito dele, mas ainda não consegui instalar o modem, já tentei instalar da mesma forma que fiz no Mandrake, mas não deu certo, parece que o driver que tenho (versão 2.7.10) não é compatível com o Kernel 2.6 do fedora.

Peguei um driver novo no site da Smartlink, slmodem-2.9.10, mas estou tendo dificuldades pra instalar o driver no Fedora, toda vez que tento dá erro. Alguém pode me dar umas dicas de como instalar corretamente nessa distro?

Linux sem net não tem graça... :cry:

Valeu

Compartilhar este post


Link para o post
Compartilhar em outros sites

Coloca aí qual a mensagem de erro que aparece, pode ser biblioteca faltando, conflito com kernel.

Eu tinha esse modem rodando no conectiva 10 (acho que o kernel é o mesmo 2.6) e usando esse driver da smartlink (baixei de www.netodragon.com) e funcionou numa boa.

Se você já instalou e ele não tá funcionando, usa o comando "modprobe slamr" e "slmodemd" e coloca no kppp o dispositivo /dev/modem (dá uma olhada no REAME do modem)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Czar_Bruno - mais tarde quando chegar em casa eu tento de novo e posto o erro aqui, acho que está faltando mesmo alguma coisa... :muro:

douglasgm - Obrigado pelo tutorial, já havia tentado com ele mas não deu certo, mas ele me indicou um outro tópico aqui no fórum que contém algumas dicas que vou seguir mais tarde :D

Obrigado :joia:

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bem galera, aparentemente o driver foi instalado, mas agora quando eu tento usar o comamdo "slmodemd" dá erro, dessa forma não consigo configurar o modem

root@localhost slmodem-2.9.10]# make install
make -C modem all
make[1]: Entering directory `/home/rodrigo/slmodem-2.9.10/modem'
make[1]: Leaving directory `/home/rodrigo/slmodem-2.9.10/modem'
make -C drivers KERNEL_DIR=/lib/modules/2.6.5-1.358/build
make[1]: Entering directory `/home/rodrigo/slmodem-2.9.10/drivers'
cc -I/lib/modules/2.6.5-1.358/build/include -o kernel-ver kernel-ver.c
make all KERNEL_VER=2.6.5-1.358
make[2]: Entering directory `/home/rodrigo/slmodem-2.9.10/drivers'
make modules -C /lib/modules/2.6.5-1.358/build SUBDIRS=/home/rodrigo/slmodem-2.9.10/drivers
make[3]: Entering directory `/lib/modules/2.6.5-1.358/build'
 Building modules, stage 2.
 MODPOST
make[3]: Leaving directory `/lib/modules/2.6.5-1.358/build'
make[2]: Leaving directory `/home/rodrigo/slmodem-2.9.10/drivers'
make[1]: Leaving directory `/home/rodrigo/slmodem-2.9.10/drivers'
make install -C drivers KERNEL_DIR=/lib/modules/2.6.5-1.358/build
make[1]: Entering directory `/home/rodrigo/slmodem-2.9.10/drivers'
cc -I/lib/modules/2.6.5-1.358/build/include -o kernel-ver kernel-ver.c
mkdir -p /dev
mknod -m 600 /dev/slamr0 c 212 0;   mknod -m 600 /dev/slamr1 c 212 1;   mknod -m 600 /dev/slamr2 c 212 2;   mknod -m 600 /dev/slamr3 c 212 3;  echo -n
mknod: `/dev/slamr0': Arquivo existe
mknod: `/dev/slamr1': Arquivo existe
mknod: `/dev/slamr2': Arquivo existe
mknod: `/dev/slamr3': Arquivo existe
mknod -m 600 /dev/slusb0 c 213 0;   mknod -m 600 /dev/slusb1 c 213 1;   mknod -m 600 /dev/slusb2 c 213 2;   mknod -m 600 /dev/slusb3 c 213 3;  echo -n
mknod: `/dev/slusb0': Arquivo existe
mknod: `/dev/slusb1': Arquivo existe
mknod: `/dev/slusb2': Arquivo existe
mknod: `/dev/slusb3': Arquivo existe
make install KERNEL_VER=2.6.5-1.358
make[2]: Entering directory `/home/rodrigo/slmodem-2.9.10/drivers'
install -D -m 644 slamr.ko /lib/modules/2.6.5-1.358/extra/slamr.ko
install -D -m 644 slusb.ko /lib/modules/2.6.5-1.358/extra/slusb.ko
/sbin/depmod -a
make[2]: Leaving directory `/home/rodrigo/slmodem-2.9.10/drivers'
make[1]: Leaving directory `/home/rodrigo/slmodem-2.9.10/drivers'
install -D -m 755 modem/slmodemd /usr/sbin/slmodemd
rm -f -rf /var/lib/slmodem
install -d -D -m 755 /var/lib/slmodem
[root@localhost slmodem-2.9.10]# /usr/sbin/lsmodemd
bash: /usr/sbin/lsmodemd: Arquivo ou diretório não encontrado
[root@localhost slmodem-2.9.10]# /usr/sbin/slmodemd
error: mdm setup: cannot open dev `/dev/slamr0': No such device or address
error: cannot setup device `/dev/slamr0'

O que estou fazendo de errado?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!


Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.


Entrar agora
Entre para seguir isso  
Seguidores 0