Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
murilodyple

Ajuda com PIC

Recommended Posts

Olá, pessoal estou com um probleminha já trabelhei programando os microcontroladores como 80c51 e ARM mais recentemente mudei de emprego e aqui eles trabalham com pic 12F675, estou compilando no micro C pro e estou programando com o BeeProg aqueles programadores universal mais não sei o que faço de errado não consigo acender um led para ter certeza que tudo está funcionando fiz um programa simples para piscar um led pra ver se conseguia garantir que tudo ta funcionando mais não consegui sei que é meio difícil entender mais se alguém puder me ajudar com um passo a passo ou tiver skype e puder me ajuda eu só preciso garantir que tudo esta funcionando que configurei tudo certo que meu codigo fonte está correto desde já agradeço

Compartilhar este post


Link para o post
Compartilhar em outros sites

bom.. poste o código, e se possível diga se mais alguém mexeu com esse led que você está, vai que tá quebrado =/

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • #include <12F675.h>
    #use delay (clock=4000000)
    #fuses INTRC_IO, NOWDT, PUT, NOBROWNOUT, NOMCLR, XT

    #define LED pin_a5

    main()
    {
    while(true)
    {

    output_high(LED); delay_ms(20); output_low(LED);delay_ms(20);

    }
    }

    O código é esse e o led não esta com problemas, estou monitorando a saída com um osciloscopio também para garantir

    Editado por dif
    Use a tag CODE

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×