Ir ao conteúdo
  • Cadastre-se
danilomota

Função VBA para procurar valor

Recommended Posts

Bom dia!

Tenho em uma célula a seguinte fórmula:

=SE(É.NÃO.DISP(PROCV(SOMASES([Cadastro.xls]Estrutura!$C:$C;[Cadastro.xls]Estrutura!$A:$A;A2;[Cadastro.xls]Estrutura!$D:$D;"*FRASCO*");[Estoque.xls]Atual!$A:$E;5;FALSO));"";PROCV(SOMASES([Cadastro.xls]Estrutura!$C:$C;[Cadastro.xls]Estrutura!$A:$A;A2;[Cadastro.xls]Estrutura!$D:$D;"*FRASCO*");[Estoque.xls]Atual!$A:$E;5;FALSO))

Ela retorna o valor que eu preciso porém para atualizar este vínculo é necessário abrir a planilha cadastro toda vez que eu abro ela. Desta forma pensei que poderia ser melhor fazer uma função no VBA para substituir esta fórmula. O problema é que eu não sei fazer isso. Algum dos mestres do vba poderia me ajudar?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite!!

Você também quer que o código abara o arquivo?

Sub ZinhoVBA()
Range("A1").Formula = "=IF(ISNA(VLOOKUP(SUMIFS([Cadastro.xls]Estrutura!$C:$C,[Cadastro.xls]Estrutura!$A:$A,A2,[Cadastro.xls]Estrutura!$D:$D,""*FRASCO*""),[Estoque.xls]Atual!$A:$E,5,FALSO)),"""",VLOOKUP(SUMIFS([Cadastro.xls]Estrutura!$C:$C,[Cadastro.xls]Estrutura!$A:$A,A2,[Cadastro.xls]Estrutura!$D:$D,""*FRASCO*""),[Estoque.xls]Atual!$A:$E,5,FALSO))"
End Sub

Qual é o diretório?

Att

Compartilhar este post


Link para o post
Compartilhar em outros sites
Boa noite!!

Você também quer que o código abara o arquivo?

Sub ZinhoVBA()
Range("A1").Formula = "=IF(ISNA(VLOOKUP(SUMIFS([Cadastro.xls]Estrutura!$C:$C,[Cadastro.xls]Estrutura!$A:$A,A2,[Cadastro.xls]Estrutura!$D:$D,""*FRASCO*""),[Estoque.xls]Atual!$A:$E,5,FALSO)),"""",VLOOKUP(SUMIFS([Cadastro.xls]Estrutura!$C:$C,[Cadastro.xls]Estrutura!$A:$A,A2,[Cadastro.xls]Estrutura!$D:$D,""*FRASCO*""),[Estoque.xls]Atual!$A:$E,5,FALSO))"
End Sub

Qual é o diretório?

Att

Obrigado por responder.

Deu o mesmo problema. O Diretório é C:\Programa

O que eu precisava é de uma Function criada pelo VBA, que retornasse o valor que retorna esta função de excel.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×