Ir ao conteúdo
  • Cadastre-se
minoso

RESOLVIDO Somarproduto com Subtotal

Recommended Posts

@Patropi

 

Eu acho que entendi a lógica da fórmula, apesar de nunca ter usado SOMARPRODUTO. Contudo, estou com uma necessidade semelhante ao do nosso colega que abandonou o tópico, mas não estou conseguindo aplicá-la corretamente. Pode me ajudar por aqui ou prefere que eu crie um tópico novo?

 

Veja a planilha de exemplo. :(

 

Eu preciso disso pois terei vários grupos (de 1 a 9) com sublinhas em cada um, assim cada linha principal (nome do grupo) deverá ter um total das respectivas sublinhas. Eu estava usando o SUBTOTAL na mão, com range e tudo mais, mas quero deixar mais automatizado, pois quando for necessário acrescentar mais linha o usuário não precisa ficar editando a fórmula (range). Também pensei em usar o SOMASE, até funciona bem, mas na hora que mostro o totalzão de todos os totais dos grupos, ele soma tudo da coluna, não apenas os totais dos grupos :(

 

Consegue me auxiliar? O que estou fazendo de errado? :(

teste.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

@minoso

 

A função SOMARPRODUTO não aceita range sem determinar o inicio e o final.

 

Experimente:

 

=SOMARPRODUTO((A4:A100=B3)*(G4:G100))

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Patropi

 

Funcionou!

 

Na verdade, o efeito dele foi o mesmo que estava usando com "SOMASE".

 

O problema é que eu preciso dar um efeito a essa célula semelhante a um SUBTOTAL, pois depois somo toda a coluna como referência (L:L) e os sub-valores não podem ser somados, apenas esses SUBTOTAIS (onde está o SOMARPRODUTO).

 

E aí, alguma ideia? Existe alguma forma de usar o SOMASE com condição e dar o efeito de SUBTOTAL?

 

Por exemplo:

  • SOMASE a coluna dos valores SE a coluna de condição atender o critério e, claro, com resultado e efeito da fórmula SUBTOTAL  :cool:

 

Desculpa a quantidade de problemas e obrigado pela paciência e ajuda :)

Compartilhar este post


Link para o post
Compartilhar em outros sites

@minoso

 

Para falar a verdade eu não estou entendendo bem o que você deseja, pois a função subtotal soma apenas as células visíveis.

 

Coloque mais dados na tua planilha e demonstre o resultado esperado.

 

[]s

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Patropi

 

Segue exemplo.

 

Lembrando que, aparentemente, a solução mais viável seria usar a fórmula SUBTOTAL onde está em vermelho, mas não quero ter que gerar manutenção no range toda hora que eu incluir uma linha nos subitens, por isso estou buscando uma alternativa de range global (toda a coluna)

 

Obrigado mais uma vez ;)

teste.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim, me foi muito útil @Patropi

 

Agora... você tem a didática para me explicar o que raios é tudo isso?

 

=SOMARPRODUTO(SUBTOTAL(9;DESLOC($G$3:$G$100;LIN(G3:G100)-LIN(G3);0;1));--($D$3:$D$100=""))

 

Eu consegui alterar para o que eu preciso com base nos ranges e referências, mas se eu fosse montar isso do zero não conseguiria NUNCA! :(

 

Obrigado pela ajuda! Eu marcaria como 'resolvido' se fosse o autor do tópico...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde @minoso

 

Para manter a organização do fórum, eu movi tuas mensagens para um novo tópico, agora você pode marcar o tópico como resolvido.

 

Para você entender a fórmula o melhor é separar por função e ir vendo por partes, você vai entendendo o funcionamento.

A última parte eu coloquei como critério, pois percebi que onde deve somar, a coluna D encontra-se vazia.

 

[]s

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×