Ir ao conteúdo
  • Cadastre-se
Andrey_Silva

RESOLVIDO Macro - Média de valores diários

Recommended Posts

Olá pessoal, 

 

Gostaria, se possível, que me ajudasse com um problema.

O meu sistema gera um planilha com vários valores de Brix e Pureza no mesmo dia; o problema é que em um mesmo dia posso ter 2,3,4,5 valores diferentes.

Minha intenção é usar uma macro para fazer a Média dos valores diários e jogar-los para outra planilha, como poderão ver no arquivo anexo.

Poderiam me ajudar?

Desde já agradeço pelo ajuda.

 

 

Boletim Analítico da Fabricação do Açucar - Parte 2 - MASSA A.xls

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, Andrey.

 

Alguma razão para você escolher a solução por macro?
Pode ser por fórmulas?

em 'B1'

=MÉDIA(SE(Sheet0!A6:A1000=A2;Sheet0!C6:C1000))

em 'C1'

=MÉDIA(SE(Sheet0!A6:A1000=A2;Sheet0!D6:D1000))

ambas são matriciais, então após colar a fórmula na célula aperte 'F2' e em seguida Ctrl+Shift+Enter, em seguida selecione as duas e arraste

Compartilhar este post


Link para o post
Compartilhar em outros sites

Amigos Osvaldo, boa tarde!

 

Obrigado pela ajuda!

 

No entanto, não deu certo; tentei fazer e não funcionou! Tentei usar a fórmula MÉDIASE e nada!

 

Complicado viu....

Compartilhar este post


Link para o post
Compartilhar em outros sites

No entanto, não deu certo; tentei fazer e não funcionou! Tentei usar a fórmula MÉDIASE e nada!

 

Complicado viu....

 

Essa resposta é vaga e não nos fornece nenhum elemento para que possamos tentar te ajudar. Você não explicou o que fez, como fez, onde fez, o resultado que obteve e o resultado esperado.

 

Sugiro que você disponibilize o arquivo com as fórmulas aplicadas e com as explicações necessárias na própria planilha, assim poderemos tentar te ajudar. Coloque as fórmulas que passei e as outras que você diz ter tentado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde Osvaldo, 

 

Anexo a planilha com a fórmula que me enviou;

Ao usar a fórmula Médiase eu cometi  um erro e não daria certo de forma alguma.

Entendi a fórmula que me enviou porém, ao usá-la na planilha não deu certo (como poderá ver).

 

Abraços

Boletim Analítico da Fabricação do Açucar - Parte 2 - MASSA A.xls

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

Entendi a fórmula que me enviou porém, ao usá-la na planilha não deu certo (como poderá ver).

 

 

 

Andrey, leia novamente as dicas que passei no post #2 e aplique-as com bastante fé... :devil:;):P

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×