Ir ao conteúdo
  • Cadastre-se
lpaula

Erro conexão do xampp com mysql

Recommended Posts

Quando tento startar a conexão o xampp com o mysql aparece o seguinte erro:

 

Error: MySQL shutdown unexpectedly.
 [mysql]     This may be due to a blocked port, missing dependencies,
 [mysql]     improper privileges, a crash, or a shutdown by another method.
 [mysql]     Press the Logs button to view error logs and check
 [mysql]     the Windows Event Viewer for more clues
 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@lpaula  Olá, pode ser que estejas tentando rodar o xampp junto com outra aplicação que usa a porta 80.. skype ou teamviwer por exemplo.

 

Mas de qualquer forma, recomendo que  faça um backup da pasta htdocs caso tenha já algo desenvolvido e desinstale o xampp, e tudo relacionado a mysql e banco de dados.. passe o Ccleaner para limpar registro.

 

Depois baixe o EasyPHP 16.1 DEV-server e instale ele apenas.  Ele possui o servidor apache, mysql mais recente além do sgbd phpmyadmin. ele é bem melhor do que o xampp.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@dif Instalei o EasyPHP e continuo com o mesmo problema, ele não starta com mysql: 

 

2016-08-21T02:56:19.248170Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details). 2016-08-21T02:56:19.248170Z 0 [Warning] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They will be merged with strict mode in a future release. 2016-08-21T02:56:19.248170Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set. 2016-08-21T02:56:19.248170Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path. 2016-08-21T02:56:19.248170Z 0 [Note] ..\eds-binaries\dbserver\mysql5711x86x160820235516\bin\eds-dbserver.exe (mysqld 5.7.11) starting as process 6832 ... 2016-08-21T02:57:18.718680Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details). 2016-08-21T02:57:18.718680Z 0 [Warning] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They will be merged with strict mode in a future release. 2016-08-21T02:57:18.718680Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set. 2016-08-21T02:57:18.718680Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path. 2016-08-21T02:57:18.718680Z 0 [Note] ..\eds-binaries\dbserver\mysql5711x86x160820235516\bin\eds-dbserver.exe (mysqld 5.7.11) starting as process 10672 ... 2016-08-21T02:57:32.800811Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details). 2016-08-21T02:57:32.800811Z 0 [Warning] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They will be merged with strict mode in a future release. 2016-08-21T02:57:32.800811Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set. 2016-08-21T02:57:32.800811Z 0 [Warning] Insecure configuration for --secure-file-priv: Current value does not restrict location of generated files. Consider setting it to a valid, non-empty path. 2016-08-21T02:57:32.800811Z 0 [Note] ..\eds-binaries\dbserver\mysql5711x86x160820235516\bin\eds-dbserver.exe (mysqld 5.7.11) starting as process 9824 ...

Editado por lpaula

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não sei que o que possa ser esse erro.

Uso ele desde 2009 e nunca vi isso. 

 

Poderia descrever todos os passos que você fez?  

Depois de desinstalar o xampp, limpou o registro?

Compartilhar este post


Link para o post
Compartilhar em outros sites

@dif Fiz tudo como você falou, e no final limpei o registro, tudo certo! Mas no momento de conectar com o mysql ele nem sequer starta e quando consigo ele desconecta em poucos segundos. Outra é que não consigo acessar o phpmyadmin também.

Editado por lpaula

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esse seu erro, acusa muita coisa... impossível dizer o que é.. 

 

Tenta reinstalar de novo, mas não escolha o C:\Arquivos de programas.  

Instale em outra partição, ou outra pasta que não seja esta. 

Deixo aqui uns prints de como eu ativo o servidor.

 

Clicando duas vezes no EasyPHP, ele abre e minimiza para o painel perto das horas. Lá você vai ver o ícone dele, clica nele e depois clica na opção "Open Dashboard". Aí vai abrir uma tela com várias opções. Siga nas imagens anexadas.

Se mesmo assim o problema ainda persiste.. aí creio que seja na sua máquina.. 

 

dashboard-mysql.PNG

dashboard-mysql-2.PNG

mysql.PNG

 

Editado por dif

Compartilhar este post


Link para o post
Compartilhar em outros sites

@dif É aí mesmo que acontece o problema, clico no start do mysql como você mostrou no último print, ele ele até "starta" mas depois de poucos segundos ele se "auto desliga" e volta para o "botão verde" de start.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×