Ir ao conteúdo
  • Cadastre-se
Escarnor

Converter algoritmo para c

Recommended Posts

Alguém pode me disser como ficaria esse algoritmo em C?

algoritmo "5"
var
n, i: inteiro
inicio
escreva("Informe um número: ")
leia(n)
enquanto (n >= 0) faca
escreval("** Tabuada de multiplicar do número ", n, " **")
para i de 1 ate n faca
escreval(i, " x ", n, " = ", i * n)
fimpara
escreval("")
escreva("Informe um número: ")
leia(n)
fimenquanto
fimalgoritmo

 

Editado por DiF
Botão CODE <>

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Escarnor Olá, poste aqui uma tentativa de como tentou fazer. 

Mesmo que esteja errado. Não espere que os outros façam o seu trabalho de converter este código em C.

Não esqueça de usar o botão CODE <> para postar a sua tentativa.  Ele fica localizado entre o botão de citar e spoiler.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu n sei como deixar ele em um looping continuo e parar só quando o valor for negativo;

main(){
	int n = 0, i;
	printf("Digite um numero");
	scanf("%d", &n);
	
	for (i = 1; i <=10  ; i++){
	
	printf("%0.2d x %0.2d = %0.2d \n", i, n, i*n);
}
	
}

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×