Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
Makun

PHP Como acessar o site usando O EasyPHP ?

Recommended Posts

Ola estou tentando migrar de wamp para o easyphp e tentando instalar ele em um pendrive, ate ai tudo bem porém coloquei o site  na pasta "www" quando eu to http://127.0.0.1:10000/pastadosite so aparece a dashboard.

 

https://imgur.com/c7o7RAJ

Compartilhar este post


Link para o post
Compartilhar em outros sites

A escrita da URL está correta, tenta abrir pelo navegador ou verifica se não tem algum redirecionamento na página de índice. Para usar no USB, recomendo essa alternativa feita especificamente pra isso: https://www.uwamp.com/en/ - usei há algum tempo atrás e funcionou perfeitamente.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Makun Você está usando a versão beta do EasyPHP WEBserver.  Se você pretende abrir localmente, use o EasyPHP DEV-server que é a versão mais estável e de desenvolvedor.

 

Seria óbvio que iria entrar na dashboard. final é nesse endereço que ela está configurada... Você precisa acessar o local network: http://192.168.1.3:888   

 

Caso você queira disponibilizar para outra pessoa acessar de fora de sua rede, via internet o endereço que você deve fornecer é: http://191.251.159.243:888

 

Contudo,  deixo alertado que não é seguro. O próprio dashboard do easyphp webserver já avisa.  Não recomendo usar o servidor caseiro.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@DiF cara como e a primeira vez que faço o download dele realmente a versão que eu estava olhando em tutoriais com a porta por exemplo 1111 não estava batendo , baixei a versão "dev" no site e consegui, porém o HTTP server Inicia só que quando clico em start no DATABASE ele não inicia. 

 

Citação

Contudo,  deixo alertado que não é seguro. O próprio dashboard do easyphp webserver já avisa.  Não recomendo usar o servidor caseiro.

Não, na verdade estou tentando instalar ele em um pendrive , pra quando ir em outra residencia abrir o localhost diretamente por ele, 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Makun Provavel que seja um bug de versão ou foi feito proposital.

Até a versão passada, ele iniciava o apache e o mysql  automaticamente ao abrir o easyphp.  Nesta versão, notei que só inicia depois de clicar manualmente no start em ambos servidores( apache e mysql)

Isso não chega a ser problema.  

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 minuto atrás, DiF disse:

sso não chega a ser problema.  

No casa ate chega pra mim, como vou acessar phpmyadmin pra incluir o banco, sendo que nao inicia a mysql, no caso vou tentar reinstalar de novo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Makun Mas aí  basta iniciar o servidor. É simples.

 

Eu prefiro iniciar manualmente os dois, ou seja, só ativo um quando necessário. MAS, se preferir você pode configurar seu easyphp ( se for o DEV server) para inicial automaticamente..... embora as vezes dá um barulho de erro mas não apresenta erro.

 

Pode ser um problema de versão ou eles fizeram proposital. Como eu disse, não é problema, pois dá para contornar.

 

 

 

startar-servers.PNG

Compartilhar este post


Link para o post
Compartilhar em outros sites

@DiF habilitei as duas opções em settings & applications reniciei e só inicia HTTP SERVER , "quando eu clico em start em VERDE" o mesmo nao incia , volta como se nada tivesse acontecido.

https://imgur.com/owSmAYa

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Makun Talvez isso pode ser problema com o seu PC.  Aqui funciona, fazer ele iniciar os servidores automaticamente quando iniciar o programa. Ativando aqueles checkbox que mostrei acima.

 

Fiz o teste duas vezes. Parei os dois, fechei o navegador, fechei o easyphp.   Depois reabri o easyphp, esperei alguns segundos até ouvir um bipe( menos de 10 segundos) aí cliquei no ícone perto das horas, e cliquei em "open dashboard"

Depois deu outro bipe e pronto os servidores estavam ativos.

 

Se quiser até gravo um vídeo mostrando :thumbsup:

Compartilhar este post


Link para o post
Compartilhar em outros sites
43 minutos atrás, DiF disse:

@Makun Talvez isso pode ser problema com o seu PC.  Aqui funciona, fazer ele iniciar os servidores automaticamente quando iniciar o programa. Ativando aqueles checkbox que mostrei acima.

 

Fiz o teste duas vezes. Parei os dois, fechei o navegador, fechei o easyphp.   Depois reabri o easyphp, esperei alguns segundos até ouvir um bipe( menos de 10 segundos) aí cliquei no ícone perto das horas, e cliquei em "open dashboard"

Depois deu outro bipe e pronto os servidores estavam ativos.

 

Se quiser até gravo um vídeo mostrando :thumbsup:

Bom , não tem problema usei o Usbwebserver para rodar o mysql e o apache, minha segunda opção vai ser o wampserver que e bem pesado mas unica alternativa, é só pra olhar o php em outros locais sem precisar subir em um servidor.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×