Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Lucas Da Silva Aleixo

VisualG Calculo de juros em Visualg

Recommended Posts

9- Dados um capital, uma taxa de juros (em porcentagem) mensal e um período em meses, informe o montante ao final de cada mês. O programa deve funcionar como a seguir:

 

Juros: 10%

Capital: 100.00

Período: 3

 

1o mês R$ 110,00

2o mês R$ 121,00

3o mês R$ 133,10

 

OBS: Em VisualG.

Editado por Lucas Da Silva Aleixo
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

  • Curtir 3

Compartilhar este post


Link para o post
Compartilhar em outros sites

Evandro, apenas quero a resolução porque eu não estou conseguindo resolver, e acho que esse é o melhor fórum para perguntar, estou a quase 1 mês procurando a resposta.

adicionado 1 minuto depois

sabato, a fórmula eu já sei, apenas quero a resolução em visualG.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
6 minutos atrás, Lucas Da Silva Aleixo disse:

sabato, a fórmula eu já sei, apenas quero a resolução em visualG.

 

Poxa, mas a fórmula de juros compostos é 90% da resposta, os 10% é implementação... pegar os valores das variáveis do usuário, salvá-las na memória e calcular o valor final... Revise seu material de VisualG com carinho, que você responde fácil!

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Lucas Da Silva Aleixo Olá, ratificando o que o Moderador Evandro postou, significa que  de forma alguma iremos dar respostas de exercícios prontos.  Note que o exercício é somente seu e de mais ninguém. Sabendo a resolução você não aprende, apenas copia. Isso acaba lhe prejudicando e principalmente o seu professor irá pesquisar aqui e no google sobre as respostas dos exercícios, para ver se seus alunos copiaram. 

 

Por isso, recomendamos que você TENTE fazer, mesmo que errado e poste a sua tentativa. Com base no seu código postado, os demais poderão corrigir e/ou dar dicas para obter o resultado esperado.

 

Certo de sua compreensão,

Agradeço desde já.

Moderador DiF

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
15 minutos atrás, Lucas Da Silva Aleixo disse:

Quer saber, esquece. Já tentei 2 vezes pedir a resolução, vou procurar outro fórum.

 

Sem ofensa, se você não é capaz de resolver esse problema de posse da fórmula de juros compostos, deveria rever o conteúdo que você já aprendeu ou pensar seriamente se quer aprender programação.

  • Haha 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Somente ESSE exercício que não consigo fazer, quero a resolução para estudar o algoritmo e depois fazer sozinho, os outros exercícios consigo fazer, este é um exercício a parte.

adicionado 7 minutos depois

O que eu consegui fazer até agora:

 

algoritmo "Execício 9 - Para"
// Função : Este programa pede ao usuário informar a taxa de juros, o capital e o período. Ao final exibe o montate do 1° Mês, 2° Mês e o 3° Mês.
// Autor : 
// Data : 10/03/2018
// Seção de Declarações 
var
  montante1, montante2, montante3, capital, i, n :real
inicio
  escreval("Informe a taxa de juros(%): ")
  leia(i)
  
  escreval("Informe o capital: ")
  leia(capital)
  
  escreval("Informe o período: ")
  leia(n)
  
  montante1 := (capital*(1 + i ^ n))
  montante2 := (capital*(1 + i ^ n)*(1 + i ^ n))
  montante3 := (capital*(1 + i ^ n)*(1 + i ^ n)*(1 + i ^ n))
  
  escreval("1° Mês: ", montante1)
  escreval("2° Mês: ", montante2)
  escreval("3° Mês: ", montante3)
fimalgoritmo

Só que não está dando certo, por isso queria a resolução, para estudar o algoritmo e elaborar o algoritmo certo.

Editado por Lucas Da Silva Aleixo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tente usar a fórmula descrita no site que citei acima. Um exemplo de pseudocódigo:

armazene na memória o valor investido inicialmente como a variável "P"
armazene na memória a taxa de juros (mensal) como a variável "i"
armazene na memória o prazo de rendimento (em meses) como a variável "n"
Montante final "M" é igual a "P" vezes (1 mais "i") elevado a "n"
retorne ao usuário o montante final "M"

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Assim?

algoritmo "semnome"
// Função :
// Autor :
// Data : 10/03/2018
// Seção de Declarações 
var
  m, p, i, n :real
inicio
  escreval("Informe o capital: ")
  leia(p)
  
  escreval("Informe a taxa de juros: ")
  leia(i)
  
  escreval("Informe o período: ")
  leia(n)
  
  m := p*(1 + i) ^ n

  escreval("Montante: ", m)
fimalgoritmo

 

Editado por Lucas Da Silva Aleixo

Compartilhar este post


Link para o post
Compartilhar em outros sites
22 minutos atrás, Lucas Da Silva Aleixo disse:

Assim?


algoritmo "semnome"
// Função :
// Autor :
// Data : 10/03/2018
// Seção de Declarações 
var
  m, p, i, n :real
inicio
  escreval("Informe o capital: ")
  leia(p)
  
  escreval("Informe a taxa de juros: ")
  leia(i)
  
  escreval("Informe o período: ")
  leia(n)
  
  m := p*(1 + i) ^ n

  escreval("Montante: ", m)
fimalgoritmo

 

 

Me parece que está praticamente lá. Eu baixei o VisualG para testar e vi alguns problemas:

1) O número que está sendo retornado é 133100 ao invés de 133,10

2) Não sei se no seu exercício você precisa retornar apenas o último mês ou todos os meses até o último mês. Se for a última opção você precisa colocar um loop para retornar o montante de cada mês.

Compartilhar este post


Link para o post
Compartilhar em outros sites

1° Como faço para retornar 133,10 ao invés de 133100?

2° Sim, preciso retornar todos os meses até o último mês. Saberia me dizer como coloco esse loop?

 

Agradeço.

adicionado 3 minutos depois

Não é que que não sou capaz de resolver esse problema (como você disse na sua resposta anterior), apenas estou pedindo ajuda, pois estou iniciando. 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Lucas Da Silva Aleixo.

 

1 hora atrás, Lucas Da Silva Aleixo disse:

1° Como faço para retornar 133,10 ao invés de 133100?

 

Então, tudo começa do entendimento do problema!!! Pelo que observei, já está com uma boa base... está faltando "traduzir" corretamente para o Visualg, veja:

 

A fórmula utilizada para o montante final foi essa:

3 horas atrás, Lucas Da Silva Aleixo disse:

m := p*(1 + i) ^ n

Logo:

m = montante, P = principal, i = taxa de juros e n = número de períodos

 

No seu código anterior, estava errando aqui:

5 horas atrás, Lucas Da Silva Aleixo disse:

  escreval("Informe a taxa de juros(%): ")
  leia(i)

Pois na fórmula do montante, o i  já está com a % inclusa (o seu valor que é em %, não a fórmula), daí ao solicitar a taxa em %, vai acabar obtendo uma taxa 100 vezes maior do que deveria, ou seja, se a taxa fosse de 10%, o usuário vai apenas escrever 10, em vez de 10/100 (no caso 0.10 ou 0.1)... ai o valor fica 100 vezes maior (não foi dividido por 100)

 

 

Veja, no seu último código está correto:

  escreval("Informe a taxa de juros: ")
  leia(i)

Ou seja, não diz que a % já está inclusa... o usuário iria informar 0.10 (que representa o 10%)

 

Repare:

Em 09/03/2018 às 22:16, Lucas Da Silva Aleixo disse:

Juros: 10%

Entende? não é apenas "10". 10 = 10/100..

 

Resumindo: se você quiser que o usuário digite 10 para corresponder um juros de 10%, você precisará dividir esse valor por 100 antes de jogar na fórmula. Algo como i:=i/100.

 

Logo:

Ou recebe em % e divide por 100 antes de jogar na fórmula;

Ou já recebe o valor dividido por 100 e joga direto;

 

 

 

Sobre:

2 horas atrás, Lucas Da Silva Aleixo disse:

2° Sim, preciso retornar todos os meses até o último mês. Saberia me dizer como coloco esse loop?

Ai também depende de você... como sugerido, primeiro terá que entender o problema... mas vou tentar adiantar, veja: basta considerar cada mês como sendo o montante final.
Para o primeiro mês, o n=1; para o segundo, n=2; para o n=3... para n'ésimo mês, n=n. Como para cada mês vai incrementando de 1 em 1, poderá utilizar um para que controla uma variável que vai de 1 a n. E usar essa variável na fórmula.

 

Tente ai fazer...

 

 

 

Sobre:

2 horas atrás, Lucas Da Silva Aleixo disse:

Não é que que não sou capaz de resolver esse problema (como você disse na sua resposta anterior), apenas estou pedindo ajuda, pois estou iniciando. 

Justamente! pré-entendemos que de fato você consegue! Estamos aqui para ajudar você a aprender a aprender...

 

 

 

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fiz assim:

var
i, meses: inteiro
capital, taxa, juros: real
inicio
// Seção de Comandos 

escreva("Informe o capital investido: ")
leia(capital)
escreva("Informe a taxa de juros (%): ")
leia(taxa)
escreva("Informe o período em meses ")
leia(meses)
juros <- (taxa/100)

para i de 1 ate meses faca
capital <- (capital) + (capital*juros)
escreval(i, "° mes = R$ " ,capital)
fimpara

fimalgoritmo

 

Editado por Simon Viegas
Inserir tag CODE
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá;

 

Sobre:

Em 01/08/2018 às 15:12, Lucas Jarenko disse:

escreva("Informe o capital investido: ")
leia(capital)
escreva("Informe a taxa de juros (%): ")
leia(taxa)
escreva("Informe o período em meses ")
leia(meses)
juros <- (taxa/100)

 

Pelo que entendi do problema, tem um pequeno detalhe, vejam:

 

Em 09/03/2018 às 22:16, Lucas Da Silva Aleixo disse:

Juros: 10%

Capital: 100.00

Período: 3

 

Esses 10% não é o juros, mas sim a "taxa do juros". Por exemplo, no terceiro período, R$ 100, com taxa de juros 10% por período, terá um juros de 33,10.

 

Não pode confundir uma coisa com a outra! 

 

Então, na prática, está se calculando montante mês a mês... efetuando os ajustes poderia ficar algo assim:

algoritmo "FCdH"
var
   M :real    //montante
   C :real    //capital
   i :real    //taxa de juros
   t :inteiro //tempo

   taxa :real    //taxa de juros em %
   x    :inteiro //utilizado no para

   //M = C.(1+i.t)

inicio
escreva ("Capital investido: R$ ")
leia(C)
escreva ("Taxa de juros (%): ")
leia(taxa)
i <- taxa/100
escreva ("Período em meses : ")
leia(t)

escreval("")
escreval("Capital inicial : R$ ",C:1:2)
escreval("Montante a cada mês: ")
M <- C //montante inicial
para x de 1 ate t faca //para cada um dos meses
   M <- M*(1+i) //calcula o montante do mês
   escreval(x:2,"° mes R$ ",M:1:2)
fimPara
fimAlgoritmo

 

 

 

adicionado 4 minutos depois

 

Utilizando Juros Compostos:

escreval("")
escreval("Capital inicial : R$ ",C:1:2)
escreval("Montante a cada mês: ")
para x de 1 ate t faca //para cada um dos meses
   M <- C*(1+i)^x //calcula o montante do mês
   escreval(x:2,"° mes R$ ",M:1:2)
fimPara

 

adicionado 10 minutos depois

Calculando o juros (Por Juros Simples)

escreval("")
escreval("Capital inicial : R$ ",C:1:2)
escreval("Montante a cada mês: ")
M <- C //montante inicial
para x de 1 ate t faca //para cada um dos meses
   J <- M*i //calcula o juros do mês
   M <- M+J //calcula o montante do mês
   escreval(x:2,"° mes R$ ",M:1:2,"   (Juros no mês R$ ",J:1:3,")")
fimPara
fimAlgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Nem lembrava disso mais. Enfim já havia conseguido:

algoritmo "Montante"
// Função : Retornar o montante ao final de cada mês.
// Autor :
// Data : 24/07/2018
// Seção de Declarações
var
capital, juros, montante :real
periodo, x :inteiro
inicio
escreval(" ============")
escreval(" = MONTANTE =")
escreval(" ============")
escreval()

escreva(" - Informe o capital: ")
leia(capital)
escreva(" - Informe a taxa de juros mensais: ")
leia(juros)
escreva(" - Informe o período: ")
leia(periodo)

escreval()

juros := (juros / 100)

se (periodo < 0) então
   escreval("**********************************************************************************")
   escreval("* Período inválido.                                                              *")
   escreval("**********************************************************************************")
senao

   para x de 1 ate periodo faca
      montante := (capital * (1 + juros) ^ x)
      escreval(" *", x, "° Mês:", montante)
   fimpara

fimse
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

1#

Sobre:

19 minutos atrás, Lucas Da Silva Aleixo disse:

escreva(" - Informe a taxa de juros mensais: ")
leia(juros)

 

Como já citado, isso não é "juros", mas sim "taxa de juros".

 

 

2#

Sobre:

19 minutos atrás, Lucas Da Silva Aleixo disse:

juros := (juros / 100)

 

Essa parte do cálculo deve ficar dentro do senão.

 

Obs.: lembrando que isso NÃO É JUROS. Juros é um "valor em R$"... o que está calculando aí é a taxa (o i da fórmula).

 

 

 

3#

Sobre:

19 minutos atrás, Lucas Da Silva Aleixo disse:

se (periodo < 0) ENTÃO

 

Creio eu que deveria ficar "<=0".

 

 

***

 

Att

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

É eu sei que não é juros, coloquei como nome da variável para ficar mais fácil de visualizar.

 

Já troquei o <= 0 e coloquei o juros := (juros / 100) no senão.

 

algoritmo "Montante"
// Função : Retornar o montante ao final de cada mês.
// Autor :
// Data : 24/07/2018
// Seção de Declarações
var
capital, juros, montante :real
periodo, x :inteiro
inicio
escreval(" ============")
escreval(" = MONTANTE =")
escreval(" ============")
escreval()

escreva(" - Informe o capital: ")
leia(capital)
escreva(" - Informe a taxa de juros mensais: ")
leia(juros)
escreva(" - Informe o período: ")
leia(periodo)

escreval()

se (periodo <= 0) então
   escreval("**********************************************************************************")
   escreval("* Período inválido.                                                              *")
   escreval("**********************************************************************************")
senao
   juros := (juros / 100)

   para x de 1 ate periodo faca
      montante := (capital * (1 + juros) ^ x)
      escreval(" *", x, "° Mês:", montante)
   fimpara

fimse
fimalgoritmo

 

Editado por Lucas Da Silva Aleixo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×