Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
Paulo Henrique_Bq

C Programa entrando no automatico

Recommended Posts

#include <stdio.h>
#include <stdlib.h>
#include <stdbool.h>
#include <string.h>

struct lista{

    char nome[50];
    char telefone[20];

};

int main(){

    int posicao = 0, cadastros = 0, opcao[2], i;
    struct lista agenda[50];
    char busca[50];
    bool pesquisa=false;

    while (opcao[0] != 5){
        printf("****** Agenda: To Perdidao ******\n\n");
        printf("1 - Cadastrar Contato\n");
        printf("2 - Pesquisar Contato\n");
        printf("3 - Exibir Todos Contatos\n");
        printf("4 - Excluir Contatos\n");
        printf("5 - Sair\n\n");
        printf("****** Agenda: To Perdidao ******\n\n");
        scanf("%d", opcao);
        if (opcao[0] == 1){
            fflush(stdin);
            printf("\n\nCadastrando novo contato:\n");
            printf("Entre com o nome: ");
            gets(agenda[posicao].nome);
            printf("Entre com o telefone: ");
            gets(agenda[posicao].telefone);
            fflush(stdin);
            cadastros++;
            posicao++;
        }
        if (opcao[0] == 2){
            fflush(stdin);
            printf("\n\nDigite o nome que deseja procurar: ");
            gets(busca);
        }
        for (i=0; i<cadastros; i++){
            if (strcmp(busca, agenda[i].nome)==0){
                pesquisa = true;
                printf("\n\nO nome do contato e %s e seu telefone e %s\n\n", agenda[i].nome, agenda[i].telefone);
                break;
            }
            if (pesquisa == false){
                printf("nome nao encontrado, tente novamente!\n\n");
            }
        }
    }
    return 0;
}

Problema é o seguinte, apos executar o codigo que fiz acima, eu coloco opção 1 de cadastrar, faço o cadastro, e aparece a mensagem de "nome não encontrado, tente novamente" que é uma condição da opção 2... mas eu não selecionei a opção 2.

Compartilhar este post


Link para o post
Compartilhar em outros sites

você fala na opção? Não alterei para int, mas continua com o mesmo problema...

adicionado 3 minutos depois

encontrei o erro... o for está fora do laço if da opção 2...

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×