Ir ao conteúdo
  • Cadastre-se
Andrias Matheus

PIC Não consigo fazer funcionar o gravador de PIC K150

Recommended Posts

Olá. Eu comprei um gravador de PIC, conectei ele na USB e instalei o driver (Prolific versão 1.7.0). Após isso, retirei o gravador do usb e instalei novamente. Mas quando eu coloco 

o gravador novamente na usb para continuar o processo e instalar o programa, lá no gerenciador de dispositivos, o driver ainda continua com o ponto de exclamação e com a

seguinte mensagem em sua propriedade: 

Este dispositivo não pode ser iniciado. (Código 10)

Foi especificado um dispositivo inexistente.

 

Aparentemente o gravador está funcionando, pois o led de indicação de funcionamento fica aceso quando conectado na USB.

Já vi alguns vídeos no youtube de como instalar os drivers e vi que fiz tudo corretamente. 

Alguém pode me ajudar? Eu queria saber onde posso encontrar outras versões desse mesmo driver parar testar instalar outras versões também...

Agradeço.
 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Comprei um gravador K150 e não funcionou, estou desistindo, por enquanto, preciso de ajuda com presença fisica. 

No passado.....distante. Aprendi a programar e gravar em assemble, estou reaprendendo em C,  mas não tenho tempo agora. Estou com um dispositivo mecanico pronto e preciso entregar. Tem 2 solenoides, botão de partida, 2 reed switch, uma placa  com display de 7seg que eu montei para o timer(2 saidas do PIC e 1 entrada)

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

 sem desespero...

opção 1: vá no setup bios e altere alguma opção do usb

opção 2: execute como adminstrador

opção 3: execute no modo compatibilidade com sistemas anteriores

opção 4: faça um outro programador. Tem vários na net. Ja usei com sucesso jdm e  schaer na saudosa época das seriais e paralelas com zero driver complicado http://www.ic-prog.com/index1.htm  só pra mc antigo.De repente tem o seu...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá,

Já passei por esse mesmo problema.

Acredito que esteja usando Windows 10 correto? Se sim, podem existir 2 problemas aí, primeiro, imcompatibilidade de algumas versões desse chip prolific com a versão do Windows, segundo, chip falsificado.

Se o seu problema for só a imcompatibilidade, arrume um outro PC com Windows Xp ou 7 (pode ser máquina virtual inclusive) e tente instalar.

Se for chip falsificado, terá que arrumar versões de driver antigas e testar.

Minha recomendação é que troque esse conversor usb/serial por conversores que usam chip FTDI, bem melhor que prolific. Mesmo que o conversor seja interno ao gravador, essa modificação não é difícil de fazer.

 

Att,

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×