Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Geraldo Ahnert Montovaneli

VisualG RESOLVIDO Se ele digitar outra coisa, ele sai da assistência.

Recommended Posts

Postado (editado)

Olá pessoal!

 

Eu quero fazer um algoritmo que se caso a pessoa falar outra coisa a não ser o SIM, o sistema recusaria o pedido de ajuda da mesma.

algoritmo "Central_de_assistencia"

var
   P1: Caractere
inicio
   EscrevaL("Olá senhor, você está na central de assistência, digite OK para continuar")
   Leia(P1)
   Se (P1 = OK) então
    Escreval("Ok, vamos continuar então...")
   senao
    Escreval("Ok, obrigado por colaborar do mesmo jeito")
   Fimse 
fimalgoritmo

 

Este é o algoritmo, como eu faço?

 

ESSE FOI O QUE EU TENTEI FAZER, MAS ESTÁ ERRADO

Editado por Geraldo Ahnert Montovaneli
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Geraldo Ahnert Montovaneli    seu código está bom , mas como é uma string  precisa colocar  entre aspas dupla , com shift ,   essa linha aqui  :

Se (P1 = "OK") então

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, devair1010 disse:

@Geraldo Ahnert Montovaneli    seu código está bom , mas como é uma string  precisa colocar  entre aspas dupla , com shift ,   essa linha aqui  :


Se (P1 = "OK") então

 

ou meu mano brigadão, eu tinha visto uma outra vídeo aula e vi algo relacionado com essas aspas, e não pensei em testar, mas tinha quase certeza que daria certo, obrigado por me dizer.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Complementando:

 

Sobre:

19 horas atrás, Geraldo Ahnert Montovaneli disse:

 Se (P1 = OK) então


Desta forma, o Visualg entende que está tentando comparar o conteúdo da variável P1 (que é do tipo caractere, ou seja, um texto), com o conteúdo de outra variável de nomenclatura OK.

 

No entanto, você precisava comparar era o conteúdo da variável P1 (um texto), com um outro texto.


Seria também possível usar variável, por exemplo:

algoritmo "Central_de_assistencia"
var
   respUsuaio     :caractere
   respConfirmacao:caractere
inicio
respConfirmacao <- "OK"
escrevaL("Olá senhor, você está na central de assistência, digite OK para continuar")
leia(respUsuaio)
se (respUsuaio = respConfirmacao) então
   escreval("Ok, vamos continuar então...")
senao
   escreval("Ok, obrigado por colaborar do mesmo jeito")
fimSe
fimAlgoritmo

 

Poderia também usando constantes:
 

algoritmo "Central_de_assistencia"
const
   respConfirmacao = "OK"
var
   respUsuaio :caractere
inicio
escreval("Olá senhor, você está na central de assistência, digite OK para continuar")
leia(respUsuaio)
se (respUsuaio = respConfirmacao) então
   escreval("Ok, vamos continuar então...")
senao
   escreval("Ok, obrigado por colaborar do mesmo jeito")
fimSe
fimAlgoritmo

Constantes seriam como uma variáveis, só que de valores constantes. ^_^

 


Percebe que usando variáveis ou constantes, caso queira mudar mudar essa "resposta de confirmação", bastaria mudar o valor da variável... aí, em todo lugar que a variável está sendo usada, passaria a usar o novo valor. Usando textos diretamente como foi feito, caso precisasse alterar, teria que ir alterando um por um manualmente.

 

Como seu código é mais simples, acho que a forma que fez fica melhor. Apenas estou tentando demonstrar outras possibilidades.

 

Att.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×