Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
Caio Bornia

Controlador de Sonda Lambda HHO

Recommended Posts

Postado (editado)

Olá Pessoa, é o seguinte, instalei o gerador de hho no meu carro e para melhor funcionamento tenho que instalar o controlador (enganador) da sonda lambda, fui ver no mercado e achei o preço um pouco salgado para um equipamento muito simples, então resolvi fazer um e encontrei um site americano que disponibilizou um pdf com todas informações para a fabricação de um controlador. Eu fiz todo o sistema eletrônico seguindo os passos fazendo as soldas e tudo como no pdf, mais por final não funcionou, então resolvi fazer no programa PROTEUS 8, e para a minha surpresa tmb não funcionou como deveria mesmo ligando ou desligando a chave ( q deixa sinal original ou alterado) ou rodando a outra chave (que faz a modificação do sinal), então achei que o Circuito eletrônico do pdf poderia estar errado ou es por ser novato no programa comendo barriga em alguma coisa! Vou disponibilizar a foto para conferir se tem algo errado na montagem e se alguém tem a solução para o problema, vou postar junto o pdf original e um arquivo traduzido em word para facilitar a compreensão do equipamento! 

 

 

Spoiler

 

 

A função principal desse equipamento e receber um sinal de 0 á 1v (0 á 1000mv) na entrada do equipamento, e no equipamento mesmo eu poder regular a tensão de saida, podendo assim eu deixar a mistura mais fica (mais próxima de 1v) ou a mistura pobre (mais próxima a 0v) a sonda por padrão fica oscilando conforme o funcionamento do carro, pois ela controla a injeção de combustível dependendo da leitura. No equipamento tem uma chave com 6 posições, conforme vou girando ela, teria que aumentar ou diminuir a saída do sinal no equipamento (sendo assim o enganador de sonda) mas no programa não esta ocorrendo como deveria, pois esta entrando uma tensão variável de 0 á 1v, mas na saída esta um valor fixo e mesmo rodando a chave não esta ocorrendo alteração! Se tiverem alguma solução me ajudaria muito!

 

https://mega.nz/#!ChtBRKIY!0qsyiPOux4jdhIdA544q2FEfdL4Ki-VdDkMXZtspltY (Documento original Pdf)

https://mega.nz/#!WplAnbhJ!XYjb8u601zG0IR2qKxXFvMgq83LmwNehfzh3qaPI_Mw (Documento traduzido Word)

https://mega.nz/#!eothRbBS!WJHD21PVg50U9fnGHS4rwjLCt66iDKv14o8Stia8BG4 (Arquivo do Programa PROTEUS 8)

 

Esse vídeo a seguir explica um pouco do funcionamento da sonda e do enganador da sonda!

Spoiler

 

 

 

Agradeço a Atenção a Todos...

Editado por Caio Bornia
Lincks dos Arquivos Atualizados

Compartilhar este post


Link para o post
Compartilhar em outros sites

Cara, tem coisa errada nesse desenho ou então está muito mal explicado. O que vejo são 2 geradores de sinal entrando, os sinais sendo trabalhados e o resultado não vai a lugar algum. Para não dizer que não há alguma saída temos o LED. Se a intenção do circuito for fazer sinalização... mas creio que não é isso. Dos links que postou o único que funcionou foi o RAR do arquivo Proteus, os demais deram erro.

Olhando melhor para o circuito, entendo que o segundo gerador de sinal na verdade é a sua saída. Nunca que um simulador irá entender esse circuito, deveria ter colocado no lugar desse segundo gerador uma saída, indicá-la como output e na simulação verificar seu comportamento ante as variações de entrada.

Não entendo de elétrica automotiva, mas esse circuito transformou um sinal de 0 a 1V num comparador de nível com seleção manual.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Postado (editado)
39 minutos atrás, Sérgio Lembo disse:

Cara, tem coisa errada nesse desenho ou então está muito mal explicado. O que vejo são 2 geradores de sinal entrando, os sinais sendo trabalhados e o resultado não vai a lugar algum. Para não dizer que não há alguma saída temos o LED. Se a intenção do circuito for fazer sinalização... mas creio que não é isso. Dos links que postou o único que funcionou foi o RAR do arquivo Proteus, os demais deram erro.

Olhando melhor para o circuito, entendo que o segundo gerador de sinal na verdade é a sua saída. Nunca que um simulador irá entender esse circuito, deveria ter colocado no lugar desse segundo gerador uma saída, indicá-la como output e na simulação verificar seu comportamento ante as variações de entrada.

Não entendo de elétrica automotiva, mas esse circuito transformou um sinal de 0 a 1V num comparador de nível com seleção manual.

@Sérgio Lembo Como sou muito leigo nesse programa eu ainda não entendo muito dele, por isso vim aqui para que alguma pessoa possa me dar uma luz. Mais você esta certo ele realmente é um comparador de nível com seleção manual. Eu atualizei os links q estavam off, no pdf da para você entender melhor a função desse equipamento e explicando bem detalhadamente como é o funcionamento. Onde eu coloquei 2 voltimetros é onde eu monitorava a tensão de entrada e a tensão de saida do equipamento! um fio vem da solda lambda, e o outro q sai do equipamento vai para a central do carro, esse equipamento fica em meio termo nessa instalação automotiva para fazer essas alterações nos valores da sonda!

Muito Obrigado Pela Atenção!

Editado por Caio Bornia

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esse integrado LM3914 é usado para fazer bargraph de leds, daí eu ter dito que transformou um sinal de 0 a 1V num comparador de nível. Para entender o que tudo isso faz tem que entender o LM3914.

O PDF original recomenda ajustar a entrada de referência do LM3914 (pino 6) em 500mV.

Observe que o sinal que vem da sonda é dividido por 2 resistores de 1M cada um, sendo que o segundo resistor ainda tem um capacitor em paralelo. Isso resulta numa corrente de 500nA quando a sonda estiver fornecendo 1V ou 100nA para 0,2V. Qualquer borra nos pontos de solda matam esse sinal. Faça uma boa limpeza na placa. Da mesma forma, se o capacitor em paralelo com o segundo resistor de 1M, se apresentar fuga o sinal já era.

Outro ponto de  problemas nesse circuito é o temporizador formado por C1, R5 e Q2. Fuga do capacitor ou distração na polaridade dele na montagem assim como borras de solda podem te atrapalhar. Note que a temporização dele não é pequena, se o simulador só enxergar os primeiros segundos você nunca que verá o circuito em stead state.

Procurando os problemas por partes:

- note que o 3914 possui uma saída open colector. Coloque a chave rotativa na primeira posição (pino 15 do 3914) e variando o sinal de entrada o cursor da chave deverá apresentar uns 11V quando a entrada for < 500mV e cair para quase zero quando a entrada passar dos 500mV. Aumentando 1 ponto na chave o processo se repete para 600mV. Se isso não acontecer o problema está no CI ou antes dele.

- supondo que o teste anterior não presente problemas, refaça o procedimento observando a tensão no coletor de Q1. Quando a entrada estiver baixa deverá apresentar 0V e quando alta quase 12V.

- supondo que o teste anterior não presente problemas, refaça o procedimento observando a tensão no coletor de Q2. Quando a entrada estiver baixa deverá apresentar 0V e quando alta uns 4V. Se ficar em zero ou próximo a isso a malha temporizadora que alimenta Q2 tem problemas ou o próprio Q2. Cuidado com as posições de base, coletor e emissor, variam muito de modelo a modelo de transistor, confira no datasheet se não há erro.

adicionado 7 minutos depois

- Confira se o pino 9 está jumpeado com o pino 3.

adicionado 41 minutos depois

- Voltando a falar da corrente, note que o consumo típico de corrente na entrada do CI (pino 5) é de 25nA, podendo chegar a 100nA (datasheet da Texas Instruments). São valores muito próximos ao ponto de operação (50nA por 100mV). Um integrado de má qualidade que tenha um consumo de entrada mais elevado e o seu circuito não funciona.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×