Ir ao conteúdo
  • Cadastre-se
yuseirender

VisualG erro no programa visualg

Recommended Posts

Bem, tenho um erro na linha 10 de meu programa e não consigo encontrar qual é o problema, na minha percepção está tudo certo.

 

Segue o algoritmo:

algoritmo "repeticao"
var
soma:real
numeros,i:vetor[1..20] de inteiro
valoresn:inteiro
x:inteiro
inicio
x<-0
escreval ("DIGITE OS 20 NÚMEROS:")
leia(numeros)
para x de 1 ate 20 faca
soma<-i+x
escreval ("OS 20 VALORES SOMADOS DÃO ",soma)
fimpara
se i<0 então
leia(valorn)
escreval ("OS NÚMEROS NEGATIVOS INSERIDOS SÃO: ",valorn)
fimse
fimalgoritmo 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá. A variável valorn não foi declarada. Use Control-G para indentar o código, fica muito mais compreensível.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde. Qual a mensagem de erro?

Use indentação no código para facilitar nossa leitura. TAG de código <>

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
7 minutos atrás, yuseirender disse:

https://i.imgur.com/qfqq5k3.png

 

segue imagem do erro

Entendi.

'numeros' é um vetor e 'i' também é um vetor. você está usando i como índice nessa linha.

adicionado 1 minuto depois

Declare i como inteiro e não como um vetor.

Compartilhar este post


Link para o post
Compartilhar em outros sites

entendi, então o erro é que ao alocar a variavel numeros, tambem acabei transtormando ela num vetor, então devo remover a variavel numeros da junção

Compartilhar este post


Link para o post
Compartilhar em outros sites

numeros[] está certo.

Você tem que usar outro laço de repetição PARA para ler os 20 números. Defina o i como inteiro.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

@yuseirender, depende de como quer implementar o algoritmo. Pode ser com uso de vetores ou com variáveis simples... ou pode ser de outras formas.....

 

Se for usar vetores, primeiro você ler o vetor (os números), depois faz os processamentos e exibir as respostas depois.

Se for com variáveis simples, a medida que for lendo os números, vai fazendo os processamentos e exibe as respostas depois.

Se for de outra forma, faz da outra forma.....

 

Então, você não postou um enunciado, mas no código tem que quer algo como:

- Exibir a soma dos 20 números;

- Exibir os números negativos da lista.

 

Sugiro que inicialmente tente fazer apenas um dos 2. Faz um, só depois de pronto faz o outro. Não precisa fazer ao mesmo tempo. Perceba que no seu código não está nem lendo o vetor... logo como vai poder efetuar cálculos? Entende? tem que ser implementado por etapas!

 

Vamos pegar o primeiro: "Exibir a soma dos 20 números". Daí teria que ver se vai usar vetores ou não... vamos supor que vai!!!

 

Desta forma, seria algo como:

1- Ler o números (preenche o vetor);

2- Faz a soma dos números;

3- Exibe a soma dos números.

 

Abaixo fiz um esboço para a primeira parte:

algoritmo "Repetição"
var
   numeros :vetor[1..20] de inteiro //vetor para armazenar os números
   i       :inteiro //variável auxiliar para servir de índice no vetor

inicio
//leitura dos dadosa
escreval("DIGITE OS 4 NÚMEROS:")
para i de 1 ate 4 faca //deixei com 4 para facilitar os testes!!!! Depois muda!
   escreva("Número",i,": ") //inserir isso apenas para ficar mais intuitivo na hora de executar
   leia(numeros[i]) //i vai variar de 1 a 4, logo lerá numeros[1], numeros[2], numeros[3] e numeros[4]
fimPara










fimAlgoritmo

Então... a primeira etapa seria ler o vetor... a princípio está pronta. Agora, implementaria a parte de calcular a soma. Oras! que a soma do quê? não é a soma dos números do vetor, posição por posição?

 

Logo, implementa outro PARA para ir de 1 a 4. Pega cada posição e vai acumulando numa variável. Para acumular seria algo como:

somaNumeros <- somaNúmero + numeros[i] //a soma vai sendo igual a propria soma mais o que quer adicionar

 

 

Ai exibe o resultado final.

 

 

Se tiver dúvidas sobre alguma parte, é só perguntar.

 

 

obs.: foque só na SOMA, só depois para para pensar em como vai fazer para exibir os negativos.

 


No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
52 minutos atrás, yuseirender disse:

puxa, muito obrigado,realmente me perdi na questão de alocar vetores e variaveis juntas

 

Qualquer coisa posta o código completo para reanalisarmos... caso tenha dúvidas, informar em qual parte.

 

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×