Ir ao conteúdo
  • Cadastre-se
T. Brito

Frequência de Overclock oscilando no CPUZ

Recommended Posts

Fala meu povo, tudo bem?

 

Pessoal, comecei a "brincar" com hardware atualmente, depois de sanar algumas dúvidas inclusive aqui no Clube do Hardware passei a me "arriscar" mais em algumas coisas pra não ser sempre um usuário tão comum haha.

 

é o seguinte, estou com um i5 8600k, minha placa-mãe é uma z370m aorus gaming, não é das topos de linha para over, porém aguenta tranquilo.

Ontem acabei fazendo um overclock simples, sem mexer em tensão para 4.7ghz, estabilizou.

Porém a minha dúvida é a seguinte, no CPUZ a frequência do processador fica oscilando como quando ele estava em stock, pelo que sei isso é por conta do speedstep, não sei se o nome ainda se mantém o mesmo. A minha dúvida é, não era para o processador estar trabalhando em 4.7ghz constantes? pois vi overclocks no mesmo processador e a frequência no CPUZ estava cravada. Em stock no cinebench eu conseguia uma marca de 1050pts em multithread, depois do over subiu para 1150, porém não achei nada na bios para desabilitar o speedstep, então não sei se mesmo fazendo o over deveria manter constante os 4.7ghz que pra mim está excelente, não pretendo subir pra 5ghz. Será que fiz algo errado, ou é assim mesmo?

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante

Tem bios que tem opção de não manter ele sempre no topo, mas pode as vezes desestabilizar. você fez teste de stress com aida 64 por exemplo por 10 minutos para ver se esta estavel?

 O Cool'n'Quiet na bios permitir que ele reduza o clock mas diminue a estabilidade (Esse é o nome da AMD, da intel eu nao lembro como chama)

Com o CnQ desativado, ele vai ficar com o clock travado no maximo, vai aumentar um pouco o consumo em idle, mas, consumo e calor vai ser gerado mais quando ele estiver fazendo esforço. No meu eu deixei ativado para não ficar sempre no maximo e ta estavel mas não forcei muito.

(Intel chamada de SpeedStep)

Compartilhar este post


Link para o post
Compartilhar em outros sites
8 minutos atrás, KisBR disse:

Tem bios que tem opção de não manter ele sempre no topo, mas pode as vezes desestabilizar. você fez teste de stress com aida 64 por exemplo por 10 minutos para ver se esta estavel?

 O Cool'n'Quiet na bios permitir que ele reduza o clock mas diminue a estabilidade (Esse é o nome da AMD, da intel eu nao lembro como chama)

Com o CnQ desativado, ele vai ficar com o clock travado no maximo, vai aumentar um pouco o consumo em idle, mas, consumo e calor vai ser gerado mais quando ele estiver fazendo esforço. No meu eu deixei ativado para não ficar sempre no maximo e ta estavel mas não forcei muito.

(Intel chamada de SpeedStep)

Então no aida ainda nao fiz, da ultima vez que fiz passou, mas em stock, realmente me esqueci de ver em quanto ficou, mas creio que não vai ter subido muito não, talvez no máximo 10 graus, por enquanto o clima anda meio frio, então em idle a temperatura está em 35º, então não devo me preocupar com a oscilação em overclock ne?

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
9 minutos atrás, T. Brito disse:

Então no aida ainda nao fiz, da ultima vez que fiz passou, mas em stock, realmente me esqueci de ver em quanto ficou, mas creio que não vai ter subido muito não, talvez no máximo 10 graus, por enquanto o clima anda meio frio, então em idle a temperatura está em 35º, então não devo me preocupar com a oscilação em overclock ne?

Se for só isso nao. Mas veja os testes, as temperaturas e se vai travar.  O que pode fazer é baixar um pouco para ver se para porque pode estar faltando energia mas nao te aconselho a subir o v. Deixa ver mais opinioes de quem tem mais experiência.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, T. Brito disse:

Ontem acabei fazendo um overclock simples, sem mexer em tensão para 4.7ghz, estabilizou.

É, provavelmente estabilizou porquê a placa-mãe aumentou a tensão automaticamente. E por "aumentou", entenda-se "exagerou", coisa que é ruim para seu PC. Você perguntou se...

1 hora atrás, T. Brito disse:

Será que fiz algo errado

...e a resposta é sim, você deixou a tensão no automático. Vá e controle manualmente.

 

 

1 hora atrás, T. Brito disse:

Porém a minha dúvida é a seguinte, no CPUZ a frequência do processador fica oscilando como quando ele estava em stock, pelo que sei isso é por conta do speedstep, não sei se o nome ainda se mantém o mesmo. A minha dúvida é, não era para o processador estar trabalhando em 4.7ghz constantes? pois vi overclocks no mesmo processador e a frequência no CPUZ estava cravada. Em stock no cinebench eu conseguia uma marca de 1050pts em multithread, depois do over subiu para 1150, porém não achei nada na bios para desabilitar o speedstep, então não sei se mesmo fazendo o over deveria manter constante os 4.7ghz que pra mim está excelente, não pretendo subir pra 5ghz.

O CPUZ não é muito bom para olhar a tensão, é melhor usar um programa como o HWMonitor.

 

Em todo caso, se o processador estiver ocioso, é normal que o clock caia para economizar energia. E quando o sistema entra em carga, o clock sobe de novo para dar desempenho. Isso é normal, e mesmo fazendo OC, não muda. Você até pode desabilitar esse recurso de economia de energia, mas não há nenhuma vantagem em fazer, então não é como se você devesse se preocupar.

 

51 minutos atrás, KisBR disse:

Tem bios que tem opção de não manter ele sempre no topo, mas pode as vezes desestabilizar. você fez teste de stress com aida 64 por exemplo por 10 minutos para ver se esta estavel?

Ainda é um teste fuleiro que meio que não serve para nada. Eu particularmente defendo o uso de Prime95, mas mesmo OCCT ou o próprio Intel XTU Burn Test já seriam decentes.

 

43 minutos atrás, T. Brito disse:

realmente me esqueci de ver em quanto ficou, mas creio que não vai ter subido muito não, talvez no máximo 10 graus,

MonkaS

 

Primeira coisa que você faz quando faz OC é olhar a temperatura, pois é ela que danifica seu PC...

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
8 minutos atrás, Imakuni disse:

É, provavelmente estabilizou porquê a placa-mãe aumentou a tensão automaticamente. E por "aumentou", entenda-se "exagerou", coisa que é ruim para seu PC. Você perguntou se...

...e a resposta é sim, você deixou a tensão no automático. Vá e controle manualmente.

 

 

O CPUZ não é muito bom para olhar a tensão, é melhor usar um programa como o HWMonitor.

 

Em todo caso, se o processador estiver ocioso, é normal que o clock caia para economizar energia. E quando o sistema entra em carga, o clock sobe de novo para dar desempenho. Isso é normal, e mesmo fazendo OC, não muda. Você até pode desabilitar esse recurso de economia de energia, mas não há nenhuma vantagem em fazer, então não é como se você devesse se preocupar.

 

Ainda é um teste fuleiro que meio que não serve para nada. Eu particularmente defendo o uso de Prime95, mas mesmo OCCT ou o próprio Intel XTU Burn Test já seriam decentes.

 

MonkaS

 

Primeira coisa que você faz quando faz OC é olhar a temperatura, pois é ela que danifica seu PC...

kkk oloco, qual seria uma tensão ideal então para colocar? e onde exatamente eu devo alterar? se tiver um tempinho olha esse vídeo, eu fiz exatamente como está aqui, pois sou meio leigo no assunto como pode perceber. Fiz tudo igual, com exceção do clock que usei o preset do proprio i5 8600k na bios de 4.7 e fiz as alterações conforme no vídeo, mudando apenas onde tem 50 para 47. Minha placa-mãe é exatamente a mesma que ele utilizou. Eu não vi o temperatura no caso no aida, mas na bios, de 30, foi pra 40.

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
3 minutos atrás, T. Brito disse:

kkk oloco, qual seria uma tensão ideal então para colocar?

Não tem um número certo, vai depender do seu chip.

 

9 minutos atrás, T. Brito disse:

e onde exatamente eu devo alterar?

Na BIOS, é na Advanced Voltage Settings.

 

10 minutos atrás, T. Brito disse:

se tiver um tempinho olha esse vídeo, eu fiz exatamente como está aqui, pois sou meio leigo no assunto como pode perceber. Fiz tudo igual, com exceção do clock que usei o preset do proprio i5 8600k na bios de 4.7 e fiz as alterações conforme no vídeo, mudando apenas onde tem 50 para 47. Minha placa-mãe é exatamente a mesma que ele utilizou

Jesus... qual é a dificuldade dos caras fazerem um tutorial de OC decente, o cara faz uma lambança legal nisso aí... Mas enfim. Comece indo na BIOS, provavelmente na aba Save & Exit, e restaurando o padrão, para se livrar das besteiras do cara.

 

Depois, ative o XMP entre no PC sem OC mexer em mais nada e abra o HWMonitor. Rode um teste de stress (aqui, a versão mais recente do Prime95) no padrão Small FFT por uns 5min e fique de olho no seguinte:

  1. A temperatura. Se passar de ~87C, pare o teste.
  2. O VCore que aparece no HWMonitor - vai ser essa nossa tensão inicial.

A partir daí, é seguir o guia rápido de overclock:

Citação

Guia rápido:

  1. Coloque a tensão em um valor fixo (aquele lá que apareceu no HWMonitor).
  2. Teste por 5min com Prime95 Small FFT, e se a temperatura máxima ficar
    1. em 82 ou menos, aumente a tensão.
    2. entre 82~85, siga adiante.
    3. mais que 85, baixe a tensão.
  3. Achado a tensão máxima, é só achar o clock máximo. Vá aumente o multiplicador (core ration) em 1 e teste por uns 30min. Se não der nenhum erro, aumente de novo. Se der, volte para o valor antigo e pronto, seu OC básico está feito.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
11 minutos atrás, Imakuni disse:

Não tem um número certo, vai depender do seu chip.

 

Na BIOS, é na Advanced Voltage Settings.

 

Jesus... qual é a dificuldade dos caras fazerem um tutorial de OC decente, o cara faz uma lambança legal nisso aí... Mas enfim. Comece indo na BIOS, provavelmente na aba Save & Exit, e restaurando o padrão, para se livrar das besteiras do cara.

 

Depois, ative o XMP entre no PC sem OC mexer em mais nada e abra o HWMonitor. Rode um teste de stress (aqui, a versão mais recente do Prime95) no padrão Small FFT por uns 5min e fique de olho no seguinte:

  1. A temperatura. Se passar de ~87C, pare o teste.
  2. O VCore que aparece no HWMonitor - vai ser essa nossa tensão inicial.

A partir daí, é seguir o guia rápido de overclock:

 

meu medo é dar treta, até me desanima mexer em tensão :( voce pediu pra ativar o xmp, mas ele no caso não é para aumentar frequência de memoria?

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante

 caso o pc desligue com o prime95 ele salva os testes?

Compartilhar este post


Link para o post
Compartilhar em outros sites
18 minutos atrás, T. Brito disse:

meu medo é dar treta, até me desanima mexer em tensão :( 

Ué, mas é por isso que eu coloquei passos metódicos, justamente para não dar erro. Você começa colocando o valor padrão como sendo manual, e depois vai baixando / aumentando conforme a temperatura. Inclusive, as que eu coloquei são até que seguras, tem uma margem de erro aí para eventuais burradas.

 

20 minutos atrás, T. Brito disse:

voce pediu pra ativar o xmp, mas ele no caso não é para aumentar frequência de memoria?

Sim. Isso é meio que independente do processador, então você pode se dar ao luxo de simplesmente ligar o XMP e esquecer a RAM.

 

7 minutos atrás, KisBR disse:

 caso o pc desligue com o prime95 ele salva os testes?

Você diz no modo de benchmark / operação normal? Porque no modo de stress, ele não salva nada.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
2 minutos atrás, Imakuni disse:

Ué, mas é por isso que eu coloquei passos metódicos, justamente para não dar erro. Você começa colocando o valor padrão como sendo manual, e depois vai baixando / aumentando conforme a temperatura. Inclusive, as que eu coloquei são até que seguras, tem uma margem de erro aí para eventuais burradas.

 

Sim. Isso é meio que independente do processador, então você pode se dar ao luxo de simplesmente ligar o XMP e esquecer a RAM.

 

Você diz no modo de benchmark / operação normal? Porque no modo de stress, ele não salva nada.

Ah beleza... porque raramente minha tela fica toda verde e nao é nem o monitor e nem o cabo... As vezes acho que é o ryzen 2200g ja que nao tenho placa de video dai ia deixar o teste rolando mas se a tela ficar verde nao vou ver nada e só reiniciando. Os drivers estão todos atualizados.

Compartilhar este post


Link para o post
Compartilhar em outros sites
11 minutos atrás, Imakuni disse:

Ué, mas é por isso que eu coloquei passos metódicos, justamente para não dar erro. Você começa colocando o valor padrão como sendo manual, e depois vai baixando / aumentando conforme a temperatura. Inclusive, as que eu coloquei são até que seguras, tem uma margem de erro aí para eventuais burradas.

 

Sim. Isso é meio que independente do processador, então você pode se dar ao luxo de simplesmente ligar o XMP e esquecer a RAM.

 

Você diz no modo de benchmark / operação normal? Porque no modo de stress, ele não salva nada.

Saquei, mas se eu deixar ele em stock mesmo, seria ideal deixar numa tensão fixa ou deixar no automático padrão mesmo? eu desfiz o do gordinho da pichau...

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante

A tensão é recomendado começar em qual? Sei que nao devemos passar de 1.4v

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 minutos atrás, T. Brito disse:

Saquei, mas se eu deixar ele em stock mesmo, seria ideal deixar numa tensão fixa ou deixar no automático padrão mesmo? eu desfiz o do gordinho da pichau...

"Em stock" você diz a tensão, ou a frequência do processador? Em ambos os casos, você deve colocar no modo fixo; a diferença é que se quiser deixar a tensão em stock, você vai fazer OC no processador até onde der com ela, ao passo de que se deixar o processador no padrão, você vai diminuindo a tensão para economizar energia e diminuir a temperatura do processador.

 

2 minutos atrás, KisBR disse:

A tensão é recomendado começar em qual? Sei que nao devemos passar de 1.4v

Genericamente falando, depende de uma série de coisas: cooler, SKU, geração do processador, opinião pessoal, entre outras. Uma forma mais fácil de determinar é deixar a placa-mãe rodar no padrão, ver que tensão marca e começar por aí.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
6 minutos atrás, Imakuni disse:

"Em stock" você diz a tensão, ou a frequência do processador? Em ambos os casos, você deve colocar no modo fixo; a diferença é que se quiser deixar a tensão em stock, você vai fazer OC no processador até onde der com ela, ao passo de que se deixar o processador no padrão, você vai diminuindo a tensão para economizar energia e diminuir a temperatura do processador.

 

Genericamente falando, depende de uma série de coisas: cooler, SKU, geração do processador, opinião pessoal, entre outras. Uma forma mais fácil de determinar é deixar a placa-mãe rodar no padrão, ver que tensão marca e começar por aí.

Não suponhamos o seguinte, acabei de montar a máquina, não fiz nada, não mexi na bios, apenas instalei o windows, processador em stock, preciso deixar numa tensão fixa? porque eu nunca mexi com isso não, de certa forma, acho que irei ler mais sobre o assunto antes de tentar, essas informações são meio confusas de início kkk mas eu agradeço ai a humildade de explicar!

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
8 minutos atrás, Imakuni disse:

"Em stock" você diz a tensão, ou a frequência do processador? Em ambos os casos, você deve colocar no modo fixo; a diferença é que se quiser deixar a tensão em stock, você vai fazer OC no processador até onde der com ela, ao passo de que se deixar o processador no padrão, você vai diminuindo a tensão para economizar energia e diminuir a temperatura do processador.

 

Genericamente falando, depende de uma série de coisas: cooler, SKU, geração do processador, opinião pessoal, entre outras. Uma forma mais fácil de determinar é deixar a placa-mãe rodar no padrão, ver que tensão marca e começar por aí.

Imaginei isso. Deixar rolar um teste no stock ver quanto vai dar no maximo e começar dar. O meu foi no automatico pela placa-mãe, ficou estavel de 3.5 para 3.85 mas temp de 68 e 1.4v. Talvez se cosenguir diminuir a tensão pode ser melhor. Ou assim ja esta bom?

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 minutos atrás, T. Brito disse:

suponhamos o seguinte, acabei de montar a máquina, não fiz nada, não mexi na bios, apenas instalei o windows, processador em stock, preciso deixar numa tensão fixa?

Você não "precisa" no sentido de "vai ter problema se não mexer", pode deixar tudo como está e não se preocupar com nada. Mas como traz vantagens controlar manualmente e você pagou mais caro por uma placa-mãe que permita isso, seria um desperdício não mexer.

 

3 minutos atrás, T. Brito disse:

porque eu nunca mexi com isso não, de certa forma, acho que irei ler mais sobre o assunto antes de tentar, essas informações são meio confusas de início kkk mas eu agradeço ai a humildade de explicar!

Normal, ninguém nasce sabendo, todo mundo se embanana no começo.

adicionado 3 minutos depois
1 minuto atrás, KisBR disse:

Imaginei isso. Deixar rolar um teste no stock ver quanto vai dar no maximo e começar dar. O meu foi no automatico pela placa-mãe, ficou estavel de 3.5 para 3.85 mas temp de 68 e 1.4v. Talvez se cosenguir diminuir a tensão pode ser melhor. Ou assim ja esta bom?

Se possível, tente baixar, 1.4v é relativamente alto. Mas também não tem problema, 68C ainda é aceitável.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
3 minutos atrás, Imakuni disse:

Você não "precisa" no sentido de "vai ter problema se não mexer", pode deixar tudo como está e não se preocupar com nada. Mas como traz vantagens controlar manualmente e você pagou mais caro por uma placa-mãe que permita isso, seria um desperdício não mexer.

 

Normal, ninguém nasce sabendo, todo mundo se embanana no começo.

beleza meu brother, chegar em casa eu rodo o prime 95 e vejo qual a tensão que da la né? no caso a máxima no momento do teste, mas na questão de mudar o clock eu devo mexer em que mais la? porque o gordinho ai mexeu nessas outras coisas no vídeo que eu nem sei porque 

Compartilhar este post


Link para o post
Compartilhar em outros sites
3 minutos atrás, T. Brito disse:

beleza meu brother, chegar em casa eu rodo o prime 95 e vejo qual a tensão que da la né?

Isso.

 

3 minutos atrás, T. Brito disse:

no caso a máxima no momento do teste, mas na questão de mudar o clock eu devo mexer em que mais la?

Você mexe só no multiplicador (Core Ratio), não precisa mudar mais nada.

 

4 minutos atrás, T. Brito disse:

porque o gordinho ai mexeu nessas outras coisas no vídeo que eu nem sei porque 

É, eu também não sei de onde ele inventou essa.... provavelmente, ele fez isso para tentar cravar o clock no valor do OC e evitar ligações de clientes inexperientes (ele é de loja) reclamando que o OC não ativou, ou algo do tipo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
41 minutos atrás, Imakuni disse:

Isso.

 

Você mexe só no multiplicador (Core Ratio), não precisa mudar mais nada.

 

É, eu também não sei de onde ele inventou essa.... provavelmente, ele fez isso para tentar cravar o clock no valor do OC e evitar ligações de clientes inexperientes (ele é de loja) reclamando que o OC não ativou, ou algo do tipo.

Não preciso nem desabilitar o turbo boost? vou te deixar é maluco com tanta pergunta kkk

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 minuto atrás, T. Brito disse:

Não preciso nem desabilitar o turbo boost?

Não.

Compartilhar este post


Link para o post
Compartilhar em outros sites
8 minutos atrás, Imakuni disse:

Não.

Entendi, eu reli ali em cima o que você disse, então estou editando esse comentário! valeu mesmo pelas dicas, então o truque é achar incialmente uma tensão que não force muito a temperatura, na margem de 87º em seguida é achar o clock máximo que faz o sistema subir de forma estável.

Só mais uma dúvida quais números são ideias pra colocar? 1.2, 1.3? tipo o valor tem que seguir algum padrão? 

Compartilhar este post


Link para o post
Compartilhar em outros sites
3 horas atrás, T. Brito disse:

Ok eu vou fazer o seguinte, eu vou setar em 4.7 inicialmente sem mexer no v core (tensão ne?), e vou rodar o prime 95, eu to usando watercooler de entrada masterliquid 120, se não passar de 85º durante 10 min de teste eu posso deixar como tá, no automático ou mesmo assim tu me recomenda mexer na tensão, nesse caso o V core ne?

É, basicamente sim...

 

Mas spoilers: vai passar de 85C sem dificuldade.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 21/06/2018 às 17:56, Imakuni disse:

É, basicamente sim...

 

Mas spoilers: vai passar de 85C sem dificuldade.

Fala Imakuni beleza? te falar, ontem eu tive tempo de mexer melhor no over, só que, o Prime95 só fica "estavel" no teste FFT que voce me solicitou fazer se estiver em stock. A tensão durante o teste máxima foi de 1.104 durante 10 minutos. A temperatura chegou no máximo em 75º. Fazendo os testes eu consegui subir o sistema em 1.2v (joguei essa tensão pra ver se rolava) a 4.7ghz, o sistema funciona normal, porém no prime os Workers ficam stop, na verdade só um estava "passando", os outros mostravam erro = 1, mas sem nenhum warning, aumentei o Vcore e continuava do mesmo jeito no prime (Worker stopped) Jogando estava normal, sem travar e fazendo testes de render também. Você sabe o que pode ser? Minha fonte é uma 80 plus white da EVGA de 600w, tava sem grana pra comprar uma melhor... será que guenta?

Compartilhar este post


Link para o post
Compartilhar em outros sites
15 horas atrás, T. Brito disse:

Fala Imakuni beleza? te falar, ontem eu tive tempo de mexer melhor no over, só que, o Prime95 só fica "estavel" no teste FFT que voce me solicitou fazer se estiver em stock. A tensão durante o teste máxima foi de 1.104 durante 10 minutos. A temperatura chegou no máximo em 75º. Fazendo os testes eu consegui subir o sistema em 1.2v (joguei essa tensão pra ver se rolava) a 4.7ghz, o sistema funciona normal, porém no prime os Workers ficam stop, na verdade só um estava "passando", os outros mostravam erro = 1, mas sem nenhum warning, aumentei o Vcore e continuava do mesmo jeito no prime (Worker stopped) Jogando estava normal, sem travar e fazendo testes de render também. Você sabe o que pode ser? Minha fonte é uma 80 plus white da EVGA de 600w, tava sem grana pra comprar uma melhor... será que guenta?

Resumindo, seu sistema está instável, ele não aguenta 4.7ghz a 1.2v . Você teria que ou aumentar a tensão, ou diminuir o clock. E no caso, é mais fácil diminuir o clock.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×