Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
heitor54322

VisualG VISUALG - o que está errado?

Recommended Posts

exercício: Elaborar programa que lê uma disciplina e respectiva nota (de 0 a 10, com uma casa
decimal), e informa se o aluno passou na disciplina, repetindo o ciclo até que a nota
lida seja zero. O aluno passa quando tira 7 ou mais.

 

código:

Algoritmo "q5"
Var
// Seção de Declarações das variáveis 
opcao,quant,abaixo5:inteiro
nota,soma,media:real

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
repita
 escreval("1-Digitar Nota")
 escreval("2-Resultados")
 leia(opcao)
 limpatela
 escolha(opcao)
 caso 1
  ((quant) <- ((quant) + 1))
  escreval("Digite sua nota")
  leia(nota)
  limpatela
 (soma <- (soma+nota))
  se (nota < 5) então
   (abaixo5 <- (abaixo5+1))
  fimse
  se(nota > 10) ou (nota < 0) então
   escreval("ERRO")

 caso 2
  ((media) <- (soma/quant))
  escreval("Media: ", media)
  escreval("Quantidade de notas: ", quant)
  escreval("Notas abaixo de 5: ", abaixo5)
 outrocaso
  escreval("ERRO")
  fimalgoritmo

 fimescolha
ate (nota>10)
Fimalgoritmo

por algum motivo tá dando erro e já tentei ajustar de várias formas, ainda estou aprendendo, podem me ajudar??

adicionado 32 minutos depois

já consegui :D

não encontrei como apagar o tópico (não sei se dá)

Compartilhar este post


Link para o post
Compartilhar em outros sites

@heitor54322, poste seu código para analisarmos.

 

Em relação ao código original, poderia ficar mais ou menos assim:

algoritmo "q5"
var
   // Seção de Declarações das variáveis
   opcao,quant,abaixo5:inteiro
   nota,soma,media:real

inicio
// Seção de Comandos, procedimento, funções, operadores, etc...
repita
   escreval("1-Digitar Nota")
   escreval("2-Resultados")
   leia(opcao)
   limpatela
   escolha(opcao)
   caso 1
      //((quant) <- ((quant) + 1))
      quant <- quant+1
      escreval("Digite sua nota")
      leia(nota)
      limpatela
      //(soma <- (soma+nota))
      soma <- soma+nota
      se (nota < 5) ENTÃO
         abaixo5 <- abaixo5+1
         //fimse
      senao
         se (nota > 10) ou (nota < 0) ENTÃO
            escreval("ERRO")
         fimSe
      fimSe
   caso 2
      media <- soma/quant
      escreval("Media: ", media)
      escreval("Quantidade de notas: ", quant)
      escreval("Notas abaixo de 5: ", abaixo5)
   outrocaso
      escreval("ERRO")
      //fimalgoritmo
   fimEscolha
ate (nota>10)
fimAlgoritmo

 

Alguns pontos:

1- Está verificando a nota após tratá-la, ou seja, está contabilizando na soma e na quantidade, mas não deveria;

2- A condição de para "maior que 10" também não está interessante... por ai vai

 

Além do código completo, poste o enunciado para revisarmos.

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×