Ir ao conteúdo
  • Cadastre-se
BernardorValle

Excel RESOLVIDO Separar dados de uma coluna

Recommended Posts

Bom dia, 

tenho uma base onde as informações estão todas acumuladas em uma coluna apenas. Porém sempre seguem uma ordem - Data/Despesa/Valor.

 

Gostaria de saber como posso fazer para organizar em uma planilha em colunas diferentes, onde cada uma esteja na linha correspondente.

 

Parece bem banal, mas não tenho ideia de como fazer, qual função utilizar.

 

Segue planilha como exemplo

Ex Duvida.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Ricardov disse:

Olá. Na aba Dados use a função Texto para coluna.

Ricardo, me desculpe a ignorância,

mas já tentei de todas as formas utilizando a função Texo para Coluna.

 

como eu configuro a função para ficar no formato que quero?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Agora que vi que os dados estão misturados em duas colunas. Uma maneira é copiar tudo para um editor como Notepad++, e colocar cada despesa em uma linha, inserir um separador como ; e depois importar para o Excel como texto, adequando os campos.  Aguarde outras opiniões.

Compartilhar este post


Link para o post
Compartilhar em outros sites
4 minutos atrás, Ricardov disse:

Agora que vi que os dados estão misturados em duas colunas. Uma maneira é copiar tudo para um editor como Notepad++, e colocar cada despesa em uma linha, inserir um separador como ; e depois importar para o Excel como texto, adequando os campos.  Aguarde outras opiniões.

No caso, está em um padrão repetido, onde ex A1 = data, A2=Despesa, A3=valor, se repetindo nesse padrão (a4=Data, A5=Despesa, A6=valor...)

 

Quando vou puxar a formula para copiar apenas os valores, o excel não reconhece esse padrão e puxa aleatoriamente.

 

Sabe se existe alguma formula que consigo adicionar um contador à celula que quero retornar?

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite, @BernardorValle

 

Use essas fórmulas nas células em:

 

H5:  =ÍNDICE($B$4:$B$15;3*(LIN($B4)-LIN($B$4)) +1 ;1)

 I5 :  =ÍNDICE($B$4:$B$15;3*(LIN($B4)-LIN($B$4)) +2 ;1)

 J5:   =ÍNDICE($B$4:$B$15;3*(LIN($B4)-LIN($B$4)) +3 ;1)

 

Depois clique e arraste cada fórmula para baixo.

 

Também dá pra fazer usando uma só fórmula para uma linha de dados, mas na forma matricial. Faça o seguinte:

 

1) Se seu Excel for mais novo (2013, 2016) em H5 insira a fórmula:

    =ÍNDICE($B$4:$B$15;3*(LIN($B4)-LIN($B$4)) + {1\2\3} ;1)

Se for mais antigo, use:

   =ÍNDICE($B$4:$B$15;3*(LIN($B4)-LIN($B$4)) + {1.2.3} ;1)

2) Selecione o intervalo H5:J5

3) Pressione a tecla de função F2

4) Finalize com CTRL+SHIFT+ENTER (tudo junto).

5) Arraste para baixo.

 

No anexo estão exemplificadas as duas formas.

Ex Duvida.xlsx

  • Curtir 2
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
17 horas atrás, Edson Luiz Branco disse:

Boa noite, @BernardorValle

 

Use essas fórmulas nas células em:

 

H5:  =ÍNDICE($B$4:$B$15;3*(LIN($B4)-LIN($B$4)) +1 ;1)

 I5 :  =ÍNDICE($B$4:$B$15;3*(LIN($B4)-LIN($B$4)) +2 ;1)

 J5:   =ÍNDICE($B$4:$B$15;3*(LIN($B4)-LIN($B$4)) +3 ;1)

 

Depois clique e arraste cada fórmula para baixo.

 

Também dá pra fazer usando uma só fórmula para uma linha de dados, mas na forma matricial. Faça o seguinte:

 

1) Se seu Excel for mais novo (2013, 2016) em H5 insira a fórmula:

    =ÍNDICE($B$4:$B$15;3*(LIN($B4)-LIN($B$4)) + {1\2\3} ;1)

Se for mais antigo, use:

   =ÍNDICE($B$4:$B$15;3*(LIN($B4)-LIN($B$4)) + {1.2.3} ;1)

2) Selecione o intervalo H5:J5

3) Pressione a tecla de função F2

4) Finalize com CTRL+SHIFT+ENTER (tudo junto).

5) Arraste para baixo.

 

No anexo estão exemplificadas as duas formas.

Ex Duvida.xlsx

Muito obrigado Edson, ajudou demais.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×