Ir ao conteúdo
  • Cadastre-se
Anna Vic

VisualG Problema com vetor e procedimentos

Posts recomendados

Me ajudem a resolver os erros por favor

 

 

algoritmo "Cadastro e Busca de Funcionarios"
// Função :Cadastro e Busca de Funcionarios
// Autor :
// Data : 18/05/2019
// Seção de Declarações 
var
nomes:vetor[0..4] de caractere
salarios:vetor[0..4] de real
cargos:vetor[0..4] de caractere
i,j,s:inteiro

procedimento inicializa()

inicio
enquanto op<>"3" faca
escreval ("----------------------------------------")
escreval ("                 menu                   ")
escreval ("----------------------------------------")
escreval("(1)Cadastrar funcionário")
escreval("(2)Buscar funcionário")
escreval("(3)Sair")
escreva("Opção:")
leia(op)
se op="1" entao
limpatela
se s=10 entao
escreval("Esgotou o limite de cadastros")
senao
cadastra_funcionario()
fimse
fimse
se op="2" entao
limpatela
buscar_funcionario()
fimse
se op="3" entao
para i de 0 ate 4 faca
nomes<-"x"
fimpara
limpatela
escreval("Obrigado!,volte sempre!")
fimse
fimenquanto
fimprocedimento

procedimento cadastra_funcionario()
inicio
para i de 0 ate 4 faca
se (nomes[1]="") entao
escreva("Nome:")
leia(nomes)
escreva("Salario:")
leia(salario)
escreva("Cargo:")
leia(cargos)
voltar_menu()
i<-i+1
limpatela
fimse
fimpara
escreval("Esgotou o limite de cadastros")
fimprocedimento

procedimento voltar_menu()
inicio
escreval("Voltar para o menu (S/N)?")
leia(op)
se op="S" entao
i<-i+1
limpatela
inicializa()
senao
limpatela
cadastra_funcionario()
fimse
fimprocedimento

procedimento buscar_funcionario()
inicio
j<-0
escreva("Digite o nome do funcionário:")
leia(nome)
para i de 0 ate 4 faca
se nome=nomes entao
escreval("nome:",nomes)
escreval("salario:",salarios)
escreval"cargo:",cargos)
j<-j+1
fimse
fimpara
se j=0 entao
escreval("Funcionario inexistente")
fimse
voltar_menu2()
limpatela
fimprocedimento

procedimento voltar_menu2()
inicio
escreva("Voltar para o menu (S/N)?")
leia(op)
se op="S" entao
limpatela
inicializa()
senao
limpatela
buscar_funciorario()
fimse
fimprocedimento

inicio
inicializa()

//Complemente com o código dos exercicio 1 a 3

fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá. Para postar o código use o botão <> do editor, fica melhor. Indentar o código facilita a leitura e compreensão, o Visual G tem uma opção para corrigir isso.

Tem um erro digitação:

procedimento cadastra_funciorio()

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 19/05/2019 às 16:08, Anna Vic disse:

Me ajudem a resolver os erros por favor

 

@Anna Vic, poste seu código atual e onde está com dúvidas.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!