×
Ir ao conteúdo
  • Cadastre-se

Outro Apenas 1 "seletor" roda, alguém sabe informar porque?


Posts recomendados

//Só consigo fazer rodar o seletor de mulher loiro, o do homem não reconhece. Poderia me ajudar a encontrar meu erro?

 

var
   I,C,cast,loiro:inteiro
   S,R:caractere
   F,M:logico

inicio
// Seção de Comandos
   F<- (S=F)
   M<- (S=M)
   cast <- 0
   loiro <-0
   Repita
   EscrevaL("=============================")
   EscrevaL("      Seletor de Pessoas     ")
   EscrevaL("=============================")
   Escreva("Qual o sexo? [F/M]:")
   Leia(S)
   Escreva("Qual a idade?")
   Leia(I)
   EscrevaL("Qual a cor do cabelo?")
   EscrevaL("[1]Preto")
   EscrevaL("[2]Castanho")
   EscrevaL("[3]Loiro")
   EscrevaL("[4]Ruivo")
   Leia(C)
           Se (S=M) e (I>=18) e (C=2)entao
           cast <- cast + 1
           FimSe
                Se (S=F) e (I>=25) ou (I<=30) e (C=3)entao
                loiro <- loiro + 1
                FimSe
   EscrevaL("Quer continuar [S/N])")
   Leia(R)
   Limpatela
   Ate (R= "N")
          EscrevaL("Total de homens com mais de 18 anos e cabelos castanho",cast)
          EscrevaL("Total de mulheres entre 25 e 30 anos e cabelos loiros",loiro)
fimalgoritmo

  • Obrigado 1
Link para o comentário
Compartilhar em outros sites

@DaniMay    mas creio que mesmo o seletor de feminino não esteja funcionando , pois na comparação para o tipo caractere precisa colocar entre aspas duplas ,   e no visualG não tem diferença de maiúsculas e minúsculas ,  então melhor deixar tudo em minúsculo mesmo ,  e um outro modo de fazer as comparações quando são mais de uma , seria usando vários se um dentro do outro ,  e não precisaria usar parênteses e nem operador lógico , e seu código poderia ficar assim :

Algoritmo "seletor"
var
  i,c,cast,loiro : inteiro
  s,r            : caractere
  f,m            : logico
inicio
  // Seção de Comandos
  f     <- (s=m)
  m     <- (s=m)
  cast  <- 0
  loiro <- 0
  repita
    escrevaL("===========================")
    escrevaL("    Seletor de Pessoas     ")
    escrevaL("===========================")
    escreva ("Qual o sexo ? [F/M] -----: ")
    leia( s )
    escreva ("Qual a idade ? ----------: ")
    leia( i )
    escreval("Qual a cor do cabelo ? --: ")
    escreval(" [ 1 ] Preto               ")
    escreval(" [ 2 ] Castanho            ")
    escreval(" [ 3 ] Loiro               ")
    escreva (" [ 4 ] Ruivo ------------: ")
    leia( c )
    se s = "m" entao
      se i >= 18 entao
        se c = 2 entao
          cast <- cast + 1
        fimse
      fimse
    fimSe
    se ( s = "f" ) e ( i >= 25 ) ou ( i <= 30 ) e ( c = 3 ) entao
      loiro <- loiro + 1
    fimse
    escrevaL("Quer continuar [ S / N ]")
    leia(r)
    limpatela
  ate r = "n"
  escreval("Total de homens com mais de 18  anos "      )
  escreval("cabelos castanho ------------------: " ,cast)
  escreval("Total de mulheres entre 25 e 30 anos "      )
  escreval("e cabelos loiros ------------------: ",loiro)
fimalgoritmo

 

Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!