Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
Entre para seguir isso  
xanok

[Resolvido] Gravador não funciona mais!

Recommended Posts

Olá. Comprei um gravador de pic semana passada. Estava funcionando perfeitamente até hoje quando decidiu dar "Verificação falhou o endereço 0000h". Quando eu mando ler a pic, manda sempre o mesmo programa. Não está funcionando para eu limpar ela (eu mando limpar e leio de de novo, e continua o mesmo programa)

Estou de cara (_(

Não acho que seja a pic, pois usei ela muito pouco para me trair tão cedo ^_^

Estou preocupado, não quero chegar ao ponto de ter que comprar um gravador USB que custa 123982189389218192 reais ¬¬'

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro xanok,

já tive problema desse tipo também, com gravadores diferentes inclusive, e que descobri não ser "defeito" do gravador até certo ponto.

Enfim, já presenciei erro desse tipo geralmente quando tentava gravar um programa qualquer no PIC e por determinada razão não aparente, talves erro de código no programa, erro de configuração dos fuses, ou sei lá o que o gravador dizia que o PIC estava com código protegido (e isso sem eu ter feito a configuração pra proteger nada) e a partir daí eu não consegui ZERAR o PIC ao estado de virgem novamente, enfim, não conseguia fazer mais nada e sempre dava o mesmo tipo de erro, tanto para apagar o PIC, quanto pra gravar novamente, e isso quando o gravador não reconhecia o PIC inserido!!!:mad:

Eu chegava a desligar, ligar, mexer, etc etc etc...e nada...até que eu resolvi todos esses tipos de "erros do além" apenas retirando o PIC do gravador, então "fingia"/simulava que ia gravar um programa, até o gravador me dar a mensagem que não existia chip a ser gravado (coisa assim)...então aí eu desligava tudo e encaixava o PIC novamente, a partir daí tudo passava a funcionar okay como antes, no que diz respeito a conseguir gravar o PIC novamente ou apaga-lo!

Uma outra forma que eu fazia, era quando dava esse tipo de erro, eu colocava um outro PIC igual no lugar (com tudo desligado claro) e também a partir daí, tudo voltava a funcionar bem, então eu removia o PIC que eu não queria usar pra testes e colocava o PIC que iniciou o erro (o PIC cobaia de gravacoes e apagamentos...rs).

Isso é o máximo que posso te dizer...Apenas contei minha propria experiencia para ver se você consegue tirar algum proveito!;)

P.S.: Mas penso eu que se apos isso ainda continuar dando erro e repetido...algo se "corrompeu" e pode ser mesmo problema mais grave.

Sucesso!

Abração,

R.Costa.

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • valeu! tentarei esses métodos obscuros do além usando POG (programação orientada a gambierra), se mesmo assim não rolar, utilizarei a ferramente mais útil até então inventada (martelo) rss

    acredito que tenha algo a ver com os capacitores e com a tensão na minha porta serial, pois para apagar a pic tem que ter uma tensão mínima (foi o que li, não tenho certeza)...

    Gostaria de saber se quem fez seu próprio gravador (seja ele com ou sem fonte externa) teria esse mesmo problema. Porque no final acho que terei que fazer meu próprio gravador mesmo =/

    Desisto

    Vou formatar um pc velho aqui que tem a porta também então.

    Editado por Bcpetronzio
    Post seguidos em menos de 24 horas, use a opção Editar

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    por isso digo... comprem um ICD2, ele grava TODOS os pics e ainda debuga, alem de ter auto-tester para identificar erros e defeitos.

    voce testou com outros pics? esse pode estar queimado.... outra possibilidade é cabo quebradoi e mau contato

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Já verificou se a porta COM está selecionada corretamente no programa?

    só tenho uma porta COM.

    desisti, encomendei um gravador USB mesmo ¬¬

    fechem esse tópico, estou brabo e indignado, pois não posso testar meus circuitos na prática até próxima semana (quando chegar o novo gravador) :angry:

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Ô! caro colega XenoK!, não desista assim tão rápido!..., como o colega Lucas disse, seu Pic pode estar danificado!, lembre-se que estes CI's são muito vulnerável à estáticas...ok?

    Abraços.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    experiencia propria, eu tinha problemas com a gravacao de alguns pics, so mais tarde descobri que eram os pics que estavam queimados, razoes bobas como inverter a alimentacao, colocar o pic invertido na hora de gravar, etc...

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Agora foi, comprei o USB. Vou comprar mais pics também. É que o pc que eu uso não tem a saída pra conectar o gravador, só um outro, dai toda hora tenho que ir pra p* qu* p* gravar a PIC ¬¬'.

    Valeu galera, se foi pic queimada terei mais cuidado!

    Abração!

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Ok! Valeu seu retorno!...

    Obrigado!

    Caso o autor do tópico necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

    Editado por Bcpetronzio
    Post seguidos em menos de 24 horas para fechar tópico como desejo do autor...

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Visitante
    Este tópico está impedido de receber novos posts.
    Entre para seguir isso  





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×