Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
LAROZA

[Resolvido] EXTRAIR SOMENTE Nºs DE CÉLULA EXCEL

Recommended Posts

Caros

Existe alguma função no excel 2003 que possibilita a extração de somente os números de uma sequência aleatória alfanumérica contida em uma ou mais células?

Grato!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite LAROZA

Esta fórmula retorna só só números de uma célula com números e textos.

=SE(E(CÓDIGO(A2)>=48;CÓDIGO(A2)<=57);A2;"")

e esta fórmula retornar só texto: =SE(E(CÓDIGO(A2)>=48;CÓDIGO(A2)<=57);"";A2)

Dê retorno

Abraços

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro Patropi, Boa Noite.

Qual seria o resultado desta fórmula se na célula A2 tivesse abc123def45ghi6789jklmn0 ?

Tentei aqui e não obtive o resultado esperado.

Acho que cometí algum engano.

Estava esperando receber 1234567890 como resultado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite Mazzaropi

Falha minha eu entendi errado o que ele queria

Estas fórmulas na verdade servem para separar números ou texto, mas funciona assim: Por exemplo se na coluna A tem linha com números e outras linhas com texto, na coluna B você coloca uma das fórmulas e ela copia ou só o texto ou só o número , conforme a fórmula que você optar.

Abraços

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro Patropi, Boa Noite.

Agora eu entendí.

Obrigado pelo esclarecimento.

Vou guardá-las aqui, porque com certeza serão úteis.

Abraços,

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Boa noite LAROZA

    Esta fórmula retorna só só números de uma célula com números e textos.

    =SE(E(CÓDIGO(A2)>=48;CÓDIGO(A2)<=57);A2;"")

    e esta fórmula retornar só texto: =SE(E(CÓDIGO(A2)>=48;CÓDIGO(A2)<=57);"";A2)

    Dê retorno

    Abraços

    Caro Patropi

    Grato pela Ajuda, porém o resultado que necessito é aquela citado pelo Mazzaropi, ou seja, "A2 = AP 11 - RESID. DELL PIANO - BL. A" o resultado obtido pela fórmula em B2 seria "11".

    Valeu!

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Caros

    Resolvido através do VBA:

    Function LetterOut(rng As Range)

    Dim Ret As String

    Dim i As Integer

    For i = 1 To Len(rng)

    If Asc(Mid(rng.Value, i, 1)) >= 48 And Asc(Mid(rng.Value, i, 1)) <= 58 Then

    Ret = Ret & Mid(rng.Value, i, 1)

    End If

    Next i

    LetterOut = Ret

    End Function

    Valeu!

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Boa tarde Laroza

    Se você tivesse colocado o texto

    "A2 = AP 11 - RESID. DELL PIANO - BL. A" o resultado obtido pela fórmula em B2 seria "11".,

    na tua primeira postagem eu teria entendido o que você queria e teria dado a fórmula certa. Mas aí vai a fórmula:

    =EXT.TEXTO(A2;CORRESP(VERDADEIRO;ÉNÚM(1*EXT.TEXTO(A2;LIN($1:$100);1));0);3)

    Como é uma fórmula matriacial, em vez de ENTER, dê CTRL+SHIFT+ENTER

    Abraços

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Caso o autor do tópico necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Visitante
    Este tópico está impedido de receber novos posts.
    Entre para seguir isso  





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×