Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
Sandreble

Dois transistores (PNP e NPN) na mesma base...

Recommended Posts

Olá a todos.

Desculpem se o titulo não foi muito condizente com minha dúvida, mas não consegui pensar em algo melhor.

Estou tentando bolar um circuito que em determinado ponto eu preciso acionar dois transistores com dois botões. O problema é que devido a uma limitação física de onde irei usar o circuito, só disponho de uma via para acionar os dois. (circulado em vermelho)

semttulo1pj.png

O modo mais fácil que pensei foi o do circuito postado. O esquema funciona. Ao pressionar o botão que envia (+) o 548 aciona seu led, e ao pressionar o (-) o 558 acende seu led também.

O problema, que é o que me fez abrir este tópico, é que ao deixar os dois botões em aberto, os dois transistores passam a conduzir, ficando assim os dois led acesos. Creio que seja devido a corrente que retorna pelas bases.

Preciso que fiquem apagados quando os botões estão em repouso.

Se alguém souber de um jeito simples, e de preferência sem muitos componentes eu ficarei agradecido.

Muito obrigado pela visita, uma boa semana a todos !

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ai tens uma solução cujos valores dependem da tensão, mas não da topologia..

Para poder colocar valores imaginei a tensão de alimentação como sendo 12 Volts.

Necessitas de dois diodos zener, 9V, 0,5 Watts, (pode ser de 9,1 Volts também) esse dai por exemplo: http://proesi.com.br/diodo-zener-1/diodo-zener-1-4w/diodo-zener-1-4w-1n757-9-1v-bzx79c9v1.html

E os dois resistores de base devem mudar de 10k para 2k2..

Aconselho também colocar em série com os dois botões um resistor de 100 ohms ou ligado ao terra ou ligado ao +Vcc.. Isso por que não faltará um ****** que vai apertar ambos os botões e botando a fonte em curto... O resistor de 100 ohms nessa hora limita a corrente pelos botões e não deixa a fonte arriar, queimar..

Bota3030o_zps868e498a.jpg~original

Edit: Desculpas mil.. Na pressa de upar peguei o desenho original..

Ai está o correto:

Bota3030o_zpsbe90785b.jpg~original

Editado por faller
  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Faller, muito obrigado pela ajuda.

Eu já havia tentado simular algo semelhante mas não obtive exito. Sou apenas curioso em eletrônica e me baseio em circuitos que acho que pela net ou testando na prática. Não poderia imaginar que seria tão simples assim.

O circuito é alimentado com 12v ~ 14v DC, esqueci de mencionar.

Sobre o resistor de proteção, já havia pensado sim, já que estará em ambiente automotivo, não há fonte para desarmar. Na verdade, a trilha de poucos mils da placa que irei fazer é quem seria o "fusivel" de proteção, no caso dos dois botões serem apertados simultaneamente.

Você postou a imagem do circuito novamente, creio que deva ter feito as alterações mas não salvou ou upou enganadamente.

Sem problemas, acho que já entendi o que disse.

semttulo3hv.png

Creio que deveria ficar mais ou menos assim, correto ? Na simulação funcionou (não tenho nenhum Zener aqui para testar agora...)

Só não tenho certeza se entendi bem como aplicar o resistor de 100 ohms para atuar como proteção em caso de curto. Mas creio que do jeito que coloquei ali irá funcionar bem.

O circuito na verdade não vai acionar LEDs, coloquei apenas para ilustrar melhor, mas o problema dos transistores conduzirem mesmo sem pressionar nenhum botão já está solucionado, o resto eu adéquo aqui.

Mais uma vez obrigado pela ajuda Faller, um abraço.

Editado por Sandreble

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você postou a imagem do circuito novamente, creio que deva ter feito as alterações mas não salvou ou upou enganadamente.

Peguei o desenho original.. Corrigido ai em cima, mil desculpas.., segue de novo:

Bota3030o_zpsbe90785b.jpg~original

Só não tenho certeza se entendi bem como aplicar o resistor de 100 ohms para atuar como proteção em caso de curto. Mas creio que do jeito que coloquei ali irá funcionar bem.

O circuito na verdade não vai acionar LEDs, coloquei apenas para ilustrar melhor, mas o problema dos transistores conduzirem mesmo sem pressionar nenhum botão já está solucionado, o resto eu adéquo aqui.

Mais uma vez obrigado pela ajuda Faller, um abraço.

Ai, do modo como colocaste o resistor, em nada vai adiantar, o resistor está em paralelo com um curto de fio... É como se ele não existisse..

O resistor deve ir do topo do botão superior até o Vcc ou de baixo do botão inferior a massa.. Basta em um desses lugares.. A posição onde ele for vai definir o botão que terá prioridade cuja ação preponderará ao pressionar ambos... Eu esqueci de desenhá-lo no circuito...

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

O faller não dá um tempo...fica todo mundo esperando ele responder com receio da resposta dele ser mais eficaz(pelo menos em circuitos eletronicos),bá...LOL.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ai, do modo como colocaste o resistor, em nada vai adiantar, o resistor está em paralelo com um curto de fio... É como se ele não existisse..

O resistor deve ir do topo do botão superior até o Vcc ou de baixo do botão inferior a massa.. Basta em um desses lugares.. A posição onde ele for vai definir o botão que terá prioridade cuja ação preponderará ao pressionar ambos... Eu esqueci de desenhá-lo no circuito...

Me desculpe Faller, realmente assim que deitei para dormir mentalizei o esquema e ví que realmente do jeito que liguei é o mesmo que nada... Entrei aqui torcendo para que não tivesse visto. ^_^

Fazer as coisas com sono é tenso.

Mas entendi o jeito correto de ligar. Vou editar a imagem novamente.

O faller não dá um tempo...fica todo mundo esperando ele responder com receio da resposta dele ser mais eficaz(pelo menos em circuitos eletronicos),bá...LOL.

Rsrsrs... O cara manja muito, sem dúvidas. Muito esclarecedor em suas respostas. Obrigado mais uma vez.

EDIT: Imagem editada.

Editado por Sandreble

Compartilhar este post


Link para o post
Compartilhar em outros sites

Se, por pouca sorte, pressionar os 2 botões o que acontece?

Em série com os led não devia ter resstência?

Talvez assim.

.

Editado por Bastassim

Compartilhar este post


Link para o post
Compartilhar em outros sites
Se, por pouca sorte, pressionar os 2 botões o que acontece?

Em série com os led não devia ter resstência?

Talvez assim.

.

Olá.

Sim, se a tensão for 12v eu deveria usar resistores em série sim.

Creio que eu não não expliquei no primeiro post, mas este esquema é apenas um exemplo, não vou usar leds. Foi só para ilustrar melhor.

Se apertar os dois botões simultaneamente, sem o R3 da ultima imagem que postei, ocorreria um curto entre os dois botões. Com o R3 não existe curto, e apenas um dois transistores conduz, no caso a "prioridade" é do BC 558 que como pode ver no exemplo, está com seu led aceso enquanto os dois push-buttons estão pressionados.

O exemplo que postou é o correto de se usar caso eu usasse os leds. Você colocou os resistores em série com eles.

E você também colocou dois resistores de preteção contra entre os botões, acho que só um resolveria o problema do curto. Por outro lado, usando os dois resistores, ao pressionar os dois botões, nenhum dos transistores conduz.

Bom pra quem não sabia nem como fazer isso até um dia atrás, acho que estou sabendo bem já... Rsrsrs...

Se falei algo errado, me corrijam por favor.

Abraço.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×