Ir ao conteúdo
  • Cadastre-se
Luiz Antônio de Almeida

RESOLVIDO Como classificar numa mesma tabela a condição física de meninos e meninas baseado no IMC

Recommended Posts

Gostaria de saber se há como numa mesma tabela - onde constam dados de meninos e meninas, baseado em IMC padrão - calcular a classificação física.

 

Anexo a planilha onde identifiquei como gênero: 1 para meninas e 2 para meninos.

 

Nas colunas M e N, fiz fórmulas para cada um dos gêneros, mas, o ideal seria uma coluna só para identificar o IMC de cada gênero.Classificacao IMC meninos e meninas.xlsx

 

Desde já, obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Experimente:

=SE(I5=1;PROC(L5;{0;17,1;18,9};{"NORMAL";"SOBREPESO";"OBESIDADE"});PROC(L5;{0;17,3;19,1};{"NORMAL";"SOBREPESO";"OBESIDADE"}))
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Osvaldo...

 

Experimentei a fórmula e realmente deu certo, porém, ficou uma dúvida...

 

Se reparar, no arquivo que anexei, a Tabela de IMC os valores divergem conforme a idade da criança e gênero entre 6 e 15 anos.

 

Na sua fórmula, para saber a classificação, foi considerado a idade de 7 anos...

 

Se eu quiser saber a classificação das demais idades como eu devo fazer?

 

Experimento iniciando a fórmula com a função SE e E ?

 

Mais uma vez, obrigado! :D

 

Classificacao IMC meninos e meninas.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

opção 1 - esta fórmula retorna #N/D se o IMC da pessoa for menor do que o IMC "Normal" para a idade e sexo dela

=SE(I5=2;ÍNDICE($C$4:$E$4;CORRESP(L5;ÍNDICE($C$5:$E$14;CORRESP(H5;$B$5:$B$14;0);0);1));ÍNDICE($C$17:$E$17;CORRESP(L5;ÍNDICE($C$18:$E$27;CORRESP(H5;$B$18:$B$27;0);0);1)))

opção 2 - esta outra retorna "Sub Normal" se ocorrer a situação referida acima

=SE(I5=2;SE(ÉERROS(ÍNDICE($C$4:$E$4;CORRESP(L5;ÍNDICE($C$5:$E$14;CORRESP(H5;$B$5:$B$14;0);0);1)));"Sub Normal";ÍNDICE($C$4:$E$4;CORRESP(L5;ÍNDICE($C$5:$E$14;CORRESP(H5;$B$5:$B$14;0);0);1)));SE(ÉERROS(ÍNDICE($C$17:$E$17;CORRESP(L5;ÍNDICE($C$18:$E$27;CORRESP(H5;$B$18:$B$27;0);0);1)));"Sub Normal";ÍNDICE($C$17:$E$17;CORRESP(L5;ÍNDICE($C$18:$E$27;CORRESP(H5;$B$18:$B$27;0);0);1))))

obs. Na sua planilha remova a expressão "mais de " no intervalo 'D5:E27' e deixe lá os valores numéricos, que serão utilizados pelas fórmulas acima.

dica - para excluir a expressão de todo o intervalo em uma tacada:

selecione aquele intervalo

aperte Ctrl+L

na caixa Localizar digite "mais de " (sem as aspas e com espaço no final)

clique em Substituir e nada digite naquela caixa

clique em Substituir tudo (serão feitas 40 substituições)

Editado por osvaldomp
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Luiz Antonio

 

Uni teus 2 tópicos sobre o mesmo assunto.

 

Não crie 2 tópicos sobre a mesma dúvida, era só continuar postando no mesmo tópico

 

Patropi-Moderador

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

- Olá Osvaldo!

 

- Sensacional! Ficou excelente! 

 

- Antes de você postar esta solução, eu havia acrescentado à sua fórmula inicial, mais uma condição SE, referente às idades de 6 a 15 anos. Ficou extensa demais, mas, deu resultado!

 

- Esta sua nova solução, além de ter uma fórmula mais curta, ainda acrescentou a classificação "subnormal".

 

- Mais uma vez, agradeço-te imensamente! 

 

- Só para você avaliar, segue anexo a solução que encontrei antes de você postar a sua, que cá entre nós, ficou muito melhor!!! :DClassificacao IMC meninos e meninas.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×