Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
Daniel Oragio

O que há de errado com meu circuito?

Recommended Posts

Olá! Sou iniciante com a ferramenta Isis do Proteus e estou tendo problemas ao realizar a simulação.

 

Meu circuito é o seguinte (imagem 1): aciono dois motores 24V, cada um tem sua Ponte H, que são acionadas pelo optoacoplador 4N25, que são acionados por chaves ((liga/desliga), apesar de estar com as chaves agora, depois que funcionar direitinho, vou acionar os quatro 4N25 com PWM), ou seja, chave (liga/desliga) ->  optoacoplador -> Ponte H -> Motor 24V. Obs.: é um projeto para uma cadeira de rodas.

 

Meu problema é o seguinte (imagem 2): quando tento fazer o teste com o simulador, me aparece esses erros e imediatamente interrompe simulação.

 

Será que alguém tem alguma solução? O que será que causa esse problema?

 

Muito obrigado!!! Abraços!

 

IMAGEM 1

CircuitoPonteH.png

 

IMAGEM 2

CircuitoPonteH_Erro.png

Editado por Daniel Oragio

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom, inverti o C com o E dos Optos. O erro ainda persiste. Aproveitei e adicionei os resistores antes do LED do Optos.

IMAGEM 1.png

IMAGEM 2.png

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sabe o que está faltando? Palavras mágicas. Te perdoo e acrescento + uns comentários...

-na prática nem deve funcionar mesmo. O mosfet precisa de tensão + alta no gate com relação ao source pra fechar. Existe até ci driver pra isso

-vejo outra anomalia: 5 e 24V no mesmo ponto vcc. Experimente aplicar um sinal dc 24V nos drenos e 30V nos C dos optos pra ver se o motor roda. Na prática não faça isso

-não vejo muito sentido em simular este circuito mas enfim cada mania com seu lôco

-use 2 relés reversíveis. Motor nos comuns dos relés NC´s no gnd, NF´s no 24. E um mosfet pra controlar a velocidade por pwm.

 

de nada...

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
6 horas atrás, Isadora Ferraz disse:

O mosfet precisa de tensão + alta no gate com relação ao source pra fechar. Existe até ci driver pra isso

 

 

 

Agora quem ficou em dúvida fui eu .... eu sempre aciono com sucesso os meus Mosfets com 5V no gate e eles estão ligados aos 12 Volts..... tem certeza dessa afirmação ????? 

 

Paulo

Compartilhar este post


Link para o post
Compartilhar em outros sites

sim. Por gentileza veja em algum d.s. o valor mínimo de Vgs para mosfet ficar com Rds on bem baixo, ou seja, fechar. Seria algo como Vbe maior que 0.7 pra "ligar" ou saturar um bjt

No caso do guri, perceba que numa condição ideal, o máximo que deve acontecer é dar um curto entre D e S do mosfet de cima. Considerando que pro motor girar tem que ter 24V no source, penso que o mosfet não fecha pois Vgs também = 0.

 

Mas não vá por mim não. Tire suas próprias conclusões

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Isadora Ferraz ,

 

Ops... falha minha .... esqueci que nos Mosfets tipo N o Source é semelhante ao Emissor dos BJTs....

 

Tem razão sobre os Mosfets da parte superior, para funcionar deveria ser do tipo P, algo semelhante a este circuito aqui :

 

http://www.bristolwatch.com/ele/moshbridge/MOSFETH.png

 

Paulo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Que tal colocar em cada GATE um resistor

Mesma coisa de colocar só um resistor  na base de um BIPOLAR

Compartilhar este post


Link para o post
Compartilhar em outros sites

@_xyko_ não deve melhorar

@aphawk pode ser sim tudo canal n desde que se aplique tensão maior que vcc no gate (ou melhor, maior que a do source). Mosfet canal n de alta corrente tende a ser mosca branca por vezes não muito barato por isso inventaram um 'driver' pro P 'de cima'. A qualquer momento me lembro do nome do ci...talvez amanhã pois tenho-os lá no trampo(se souber 1°, fique a vontade em compartilhar...).

Pode ajudar na simulação do guri (o qual devido à 'ausências generalizadas', não sei se vale a pena "investir" nele)

abç

Compartilhar este post


Link para o post
Compartilhar em outros sites
14 horas atrás, Isadora Ferraz disse:

Pode ajudar na simulação do guri (o qual devido à 'ausências generalizadas', não sei se vale a pena "investir" nele)

abç

 

Não vejo porque insistir na simulação, se todos já sabemos que sem trocar dois mosfets para o tipo P o circuito não vai funcionar de jeito nenhum, concorda ?

 

Paulo

Compartilhar este post


Link para o post
Compartilhar em outros sites
9 horas atrás, aphawk disse:

 

Não vejo porque insistir na simulação, se todos já sabemos que sem trocar dois mosfets para o tipo P o circuito não vai funcionar de jeito nenhum, concorda ?

 

Paulo

sim e não. Sim... o amigo já deve ter conseguido solucionar

Não.. você pode usar o tipo N em cima (tipo p tipo n ainda faço confusão.)

 

3569265200_1429625440.jpg

 

97831199151424.jpg

 

ok.. não é motor (parece um primario de um circuito qualquer) nem mosfet  (é um igbt primo dele) nem o ci que tenho (é primo dele) mas acho que dá pra ilustrar

 

Acho que já disse que se o amigo aplicar V=VCC+5 no coletor dos optos, ele tem uma chance mínima de sucesso na simulação e na prática.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×