Ir ao conteúdo
  • Cadastre-se
Lucas Da Silva Aleixo

VisualG Este exercício esta correto?

Recommended Posts

Enunciado:

 

9- Dados um capital, uma taxa de juros (em porcentagem) mensal e um período em meses, informe o montante ao final de cada mês. O programa deve funcionar como a seguir:

 

Juros: 10%

Capital: 100.00

Período: 3

 

1o mês R$ 110,00

2o mês R$ 121,00

3o mês R$ 133,10

 

Minha Resposta:

 

algoritmo "Exercício 9 - Para"
// Função : Este programa pede para o usuário informar a taxa de juros, o capital, o período e ao final é exibido o montante ao final de cada mês.
// Autor :
// Data : 01/04/2018
// Seção de Declarações 
var
  m, p, i :real
  x, n :inteiro
inicio
  escreva("Informe a taxa de juros(%): ")
  leia(i)
  
  escreva("Informe o capital: ")
  leia(p)
  
  escreva("Informe o período: ")
  leia(n)
  
  escreval()
  
  i := (i / 100)
  
  para x de 1 ate n faca
    n := (n + 1)
    m := (p * (1 + i) ^ n)
    escreval(x, "° Mês: R$", m)
  fimpara
fimalgoritmo

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Lucas Da Silva Aleixo   seu cálculo está errado,  você está elevando o número a n ,  e não precisa, o certo é somar o resultado com montante para calcular o próximo mês , então seu código seria assim :

escreval("O Calculo de ",p," em Cada Mês")
i := (i / 100)
para x de 1 ate n faca
  p:=p*i+p
  escreval(x, "° Mês: R$", p)
fimpara

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá a todos.

 

1#

17 horas atrás, devair1010 disse:

@Lucas Da Silva Aleixo   seu cálculo está errado,  você está elevando o número a n ,  e não precisa

Não necessariamente. Na verdade "a lógica" está certa, o que está errada é a "implementação da fórmula do montante". Mais abaixo no 3# comento.

 

 

 

2#

17 horas atrás, devair1010 disse:

o certo é somar o resultado com montante para calcular o próximo mês , então seu código seria assim :

Nesse sentido, seria "um" certo, ou seja, é uma forma diferente de enxergar o problema, ou seja, em vez de ficar "calculando o montante final a cada mês" (como foi idealizado inicialmente), poderá ir calcular o "juros" mês a mês (é dessa forma que eu também idealizei)... no final o resultado será o mesmo... (são duas formas diferentes de resolver um mesmo problema... obs.: podem existir n outras formas!)

 

Segue abaixo como poderia ficar:

   para x de 1 ate n faca
      m := (p * (1 + i) ^ x)
      escreval(x, "° Mês: R$", m)
   fimpara

 

 

Só para ficar mais claro... a fórmula do montante seria algo como:

M=C*(1+i)^t

Então, esse "t" seria "tempo total", ou seja, calcular qual seria o montante ao final de t períodos. Como está calculando mês a mês (a cada mês mostra o montante), no primeiro mês, t=1; no segundo, t=2; no terceiro, t=3... etc. Resumindo: estava usando a variável errada no algoritmo. Tipo, se N=12. N+1=13... daí, iria calcular blablabla^13? depois, blablabla^14? Não! Seria blablabla^1, blablabla^2... até blablabla^13. Entendem?

 

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×