Ir ao conteúdo
  • Cadastre-se
Buscador1985

Excel Copiar texto automaticamente para outra planilha

Recommended Posts

Olá!

 

Estou com uns problemas para solucionar nesta planilha e como não sei exatamente o problema, não consegui encontrar uma solução pesquisando.

 

Na verdade são dois problemas:

 

1º - Criei um índice com nome de funcionários, e ao clicar neles gostaria que o resultado apresentado levasse o nome do funcionário para o topo da tela automaticamente e não no meio dela.

 

2º - Tenho a Aba Funcionarios e Funcionários 19. Gostaria que a segunda aba funcionasse em função da primeira.

Por exemplo, se o acréscimo de Carlos na aba Funcionarios foi menor do que 6, os dados da das células B3, C3 e D3 se repetiriam automaticamente na aba Funcionarios 19.

 

Pensei em usar =SE, mas não consegui.

Alguma ideia do que posso fazer?

 

Obrigado!

AJUDA.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Em relação a segunda dúvida se for do jeito que estou pensado é simples.

Para ter os mesmo dados de uma célula em outra é só fazer o seguinte:

Na célula que você deseja que os dados sejam iguais aos da outra planilha clique nela e coloque: =

Clique na outra planilha, e clique na célula que deseja copiar o resultado. (Quando atualizar em uma atualiza na outra)

 

Na prática tem que ficar assim:

=Funcionarios!B3

ou

='Funcionarios 19'!B3 (Nessa fórmula possui (') pois contêm espaço, o mesmo serve para caracteres especiais)

 

O mais recomendado no seu caso seria usar uma tabela sem cabeçalho, pois ela puxa as fórmulas automaticamente para todas as células contidas dentro dela.

 

-----

 

Sobre a primeira dúvida, não entendi direito!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sobre a primeira dúvida, é assim:

 

Clicar no hyperlink, e leva até os dados de outra aba, mas ao clicar o nome da pessoa aparece numa altura aleatória.

 

Fica assim: 01.thumb.png.e19573b9ce07ced6d04d8f9ec808511e.png

 

E eu gostaria que ficasse assim:

 

02.thumb.png.802832b428a9a916faa2946636e28cf5.png

 

A segunda dúvida, precisa satisfazer uma condição. Ela só copiaria os valores das celuas B3, C3 e D3 se a célula E3 tivesse um valor menor do que 6. Por isso pensei em utilizar o =SE, mas não conseguir fazer funcionar corretamente as referencias delas na aba.

 

Obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Na primeira dúvida sem macro não funciona do jeito exato.

Mas você pode fazer o seguinte, em hyperlink na hora selecionar a célula de destino coloque A19:G36.

 

image.thumb.png.12fdb9e74979bdbb59a6e76b2b2d0cdc.png

 

Depende de onde vai parar com o scroll do mouse, se parar mais em baixo vai ficar do jeito que quer, mas se para em cima vai ficar igual a imagem acima mostra.

 

Caso queira faça o mesmo com o restante.

 

----------------

 

Segunda dúvida:

  • =SE(E3<6;=Funcionarios!B3 ;"")

E assim por diante...

 

Obs.: Lembrando que essa fórmula só irá retornar os valores (1, 2, 3, 4 e 5) por serem menor que 6. Caso queira que o 6 entre na fórmula coloque <=

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Acho que cheguei mais ou menos onde queria, a primeira dica ajudou bastante, embora não fique 100% preciso.

 

A segunda, era assim, a aba Funcionarios 19 deveria buscar os dados na Funcionarios que atendessem uma certa condição.

 

Eu usei o seguinte código na aba Funcionarios 19 e aparentemente deu tudo certo:

 

=SE(Funcionarios!F6<6;Funcionarios!C6;"")

 

Vou ter de verificar, acho que eu fiz umas besteiras na estrutura da planilha e dá pau com celulas mescladas. Vou ter que revisar tudo de novo.

 

Obrigado!

 

Vou mexer aqui e dou um retorno se ficou ok.

Compartilhar este post


Link para o post
Compartilhar em outros sites

kkkk, ok!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×