Ir ao conteúdo
  • Cadastre-se
Rafaela Soares

Portugol Mostre quantos números pares e ímpares existentes de 1 até 500.

Posts recomendados

programa
{
	
	funcao inicio() 
	{
		
		para(inteiro i = 1; i <= 500; i++)
		{
			inteiro num = i%2
			se(num%2==0){
				escreva("\nNúmero par: "+i)

			}senao{
				escreva("\nNúmero ímpar: "+i)
			}
			
		}
		
	}
			}

 

 

 

Preciso montar um algoritmo que mostre quantos números pares e quantos ímpares têm entre 1 e 500, no entanto, não sei como faço pra desenvolver o algoritmo para que haja a soma desses dois tipos de n°. Se alguém puder me ajudar a utilizar o tipo de laço 'para' nesse caso. Obrigada

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Rafaela Soares você pode criar duas variáveis de contadores, uma para par e outra para impar, depois basta incrementar essas variáveis, seguindo a lógica das condicionais que você fez.

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@navegantenarede

Agora deu a quantidade contada. Mas ainda sim, ele aparece número por número, será que há uma forma de eu mostrar só a quantidade final sem passar por todos os números? Obrigada!

Compartilhar este post


Link para o post
Compartilhar em outros sites
programa {
  funcao inicio() {
    para(inteiro i = 1; i <= 500; i++) {
      inteiro num = i%2
      se(num%2==0){
        par ++
      }
      senao {
        impar ++
      }
      mostrar par
      mostrar impar
   }
}

 

seria isso ?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Oi! Testei e não daria kkk, mas agora já consegui! Obrigada.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 31/05/2019 às 10:35, Guiihh disse:

programa {
  funcao inicio() {
    para(inteiro i = 1; i <= 500; i++) {
      inteiro num = i%2
      se(num%2==0){
        par ++
      }
      senao {
        impar ++
      }
      mostrar par
      mostrar impar
   }
}

 

seria isso ?

 

No Portugol Studio, poderia ser algo assim:

programa {
  funcao inicio() {
    inteiro par = 0
    inteiro impar = 0
    para(inteiro i = 1; i <= 500; i++) {
      inteiro num = i%2
      se (num%2==0) {
        par ++
      }
      senao {
        impar ++
      }
    }
    escreva("Pares  : ", par, "\n")
    escreva("Ímpares: ", impar)
  }
}

 

Outra forma mais simples:

programa {
  funcao inicio() {
    escreva("Pares  : 250 \n")
    escreva("Ímpares: 250 ")
  }
}

:)

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!