×
Ir ao conteúdo
  • Cadastre-se

VisualG Metodologia de pagamento - visualg


Posts recomendados

A questão é a seguinte: o cliente tem que escolher a metodologia de pagamento sendo: 

 Condição de pagamento 1 - Em dinheiro, recebe 12% de desconto.

 Condição de pagamento 2 - Cartão de crédito, recebe 5% de desconto.

 Condição de pagamento 3 - Parcelado no cartão de crédito em duas vezes, preço normal, sem juros.

 Condição de pagamento 4 - Parcelado no cartão de crédito em três vezes, com juros 5%.

 

A primeira parte roda com sucesso. Só estou com dificuldade para colocar a opção do cliente escolher a metodologia e assim ocorrer o calculo e seu devido desconto.

Obs: a parte que esta espaçado funciona perfeitamente porém não consigo aplicar o desconto 

var
   Codigo : Real
   Nome : caractere
   Valor: Real
   Media : Real
   I: inteiro
   Total: Real
   Qnt : real
   desc : real
   total_desc : real
   pagamento : caractere

Inicio
   Para I de 1 Ate 10 Faca
      Escreva ("Nome do Produto: ")
      Leia (Nome)
      Escreva ("Código do Produto: ")
      Leia (Codigo)
      Escreva ("Valor Unitario do produto: R$")
      Leia (Valor)
      Escreva ("Quantidade do Produto: ")
      Leia (Qnt)
      total <-(Valor * Qnt)
      Escreval( "O Valor total deste produto é: R$", total)
      media <- (total+media)
      escreval ("Total da compra é: R$", media)

      repita
         escreval ("Escolha a metodologia de pagamento: ")
         Leia (pagamento)
         escolha pagamento
      fimrepita

      enquanto op<>"4" faca
         Escreval ("(1) Dinheiro")
         Escreval ("(2) Cartão de Credito")
         Escreval ("(3) Cartão de credito (2x)")
         Escreval ("(4) Cartão de credito (3x)+ 5% de juros")

         Se op="1" então
            limpatela
            Dinheiro()
         fimse

         Se op="2" então
            limpatela
            Cartão de Credito()
         fimse

         Se op="3" então
            limpatela
            Cartão de credito (2x)()
         fimse

         Se op="4" então
            limpatela
            Cartão de credito (3x)+ 5% de juros()
         fimse
      fimenquanto
fimprocedimento

fimescolha
procedimento cadastra_item
para 1 faca
Escreval ("Medologia: Dinheiro")
Escreval ("Valor: R$ ", valor*12/100)

 

  • Amei 1
Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Como ganhar dinheiro montando computadores!

MINICURSO GRÁTIS!

Como ganhar dinheiro montando computadores!

CLIQUE AQUI E INSCREVA-SE AGORA MESMO!