Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
valter gyn

Diminuir o tamanho da formula

Recommended Posts

Boa tarde pessoal..... sou novo no forum e gostaria que vocês me ajudassem com uma duvida.....

me desculpem se tiver postado no lugar errado.....

A minha duvida é o seguinte, eu tenho a seguinte formula

=SE(OU($F3="0010";$F3="0020";$F3="0030";$F3="0045";$F3="0060";$F3="0072";$F3="0073";$F3="0074";$F3="0075";$F3="0076";$F3="0077";$F3="0078";$F3="0079";$F3="0080";$F3="0081";$F3="0082";$F3="0083";$F3="0084";$F3="0090";$F3="0091";$F3="0092";$F3="0093";$F3="0094";$F3="95";$F3="0100";$F3="0101";$F3="0110";$F3="0111";$F3="0112";$F3="0113";$F3="0115";$F3="0120";$F3="0121";$F3="0125";$F3="0126"$;F3="0127";$F3="0128";$F3="0129";$F3="0130";$F3="0131";$F3="0132";$F3="0133";$F3="0134";$F3="0135";$F3="0136";$F3="0137";$F3="0140";$F3="0141";$F3="0145";$F3="0146";$F3="0147";$F3="0150";$F3="0151";$F3="0155";$F3="0156";$F3="0200";$F3="0210";$F3="0211";$F3="0212";$F3="0213";$F3="0220";$F3="0222";$F3="0223";$F3="0224";$F3="0226";$F3="0222";);$A3;"")

Como vocês perceberão.... a formula esta enorme.... o que eu preciso é resumila

ao invés de te que digitar referencia por referencia..

ex: a se guinte sequencia =SE(OU($F3="0010";$F3="0020";$F3="0030";$F3="0040";$F3="0050";$F3="0100";$F3="0110";$F3="0120";$F3="0130";$F3="0140";$F3="0150";);$A3;"")

ficaria assim: =se(OU($F3="0010:"0050;$F3="0100":"10150");$A3;"") - neste caso eu estaria resumindo 0010;0020;0030;040;050 em {0010:0050} e 0100;0110;0120;0130,0140;0150 em {0100:0150}..

tenho essa planilha caso vocês queirão ver pra ficar mais clarohttp://www.4shared.com/file/76267668/3bbc8142/Pecas_veiculos17.html

lembrando que essa formula esta na celulua B3

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, Valter.

Dei uma olhada na sua planilha e estive pensando se na célula b3 em vez de colocar o sinal de igual (=), você usasse o sinal de diferente (<>)?

Aí a fórmula ficaria assim:

=SE(OU(F3<>"1200";F3<>"1300";F3<>"1500");A3;"").

Ficaria bem menor e resolveria seu problema.

É uma das soluções possíveis.

Espero ter ajudado.

Um abraço.

Wilson Fantim

rossefantim@hotmail.com

Compartilhar este post


Link para o post
Compartilhar em outros sites

Wilson...fiz o que você falou...mas não deu certo... a formula que você me passou, só faz repetir o numero que eu digito na coluna A...

Não sei se você perceber.. a planilha tem que ficar de uma forma que eu digite um codigo na coluna A.. e esse codigo seja repetido na coluna referente ao comprador daquela linha.. só que o problema que os compradores não pega uma sequência de codigos:

ex: o comprador wellington ao invés de ter a sequencia 0010,0020,0030,0040,0050,0060,0070,0080...

ele tem a sequencia assim 0010,0030,0050,0080,0100,0140.....

ai os outros codigos são distribuidos para os outros compradores....

Ai que esta a dificuldade de fazer uma formula menor

=SE(OU($F3="0010";$F3="0020";$F3="0030";$F3="0045");$A3;"")

com essa formula.. todo codigo que começar com 0010,0020,0030,0045 com esse 0010.020.002-5 vai aparecer na coluna B que é o wellington que compra, se eu pudesse resumir só as sequencias que tem na formula, já estaria otimo pra mim

Compartilhar este post


Link para o post
Compartilhar em outros sites

Osvaldo..... Ficou perfeito.... É isso mesmo que eu preciso.... Ficou bom de mais da conta........muito obrigado mesmo... Fico te devendo esta..

E os amigos wilson e casadohardware eu agradeÇo muito pela boa vontade.... Lembrando que a planilha da casadohardware me ajudou em outra funÇÃo....

valeu moÇada.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×