Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
Rafael.R

Espelhando HD em dos com XCOPY - dúvidas

Recommended Posts

Olá.

Preciso fazer cópias de um sistema fora de linha que tenho em meu trabalho. Ele roda em DOS 6.0. Em um fórum americano dizem para copiar este HD específico, com um boot com Diskette DOS e usando o comando XCOPY:

O comando é: xcopy d: * c:. / S / v , mas parece que o certo seria:

xcopy d:* c: /S /v

O primeiro problema é que comecei a mexer com linha de comando bem agora e tem que prestar atenção nos espaços...

Segundo é que para copiar arquivos oculto eu li em algum lugar que eu preciso usar "/h" no comando mas o XCOPY que eu uso não tem esse "h"

Duvidas:

Como consigo colocar esse "h" na linha de comando ou onde acho a versão do xcopy que tenha isso, e precisa ter um * (asterisco) entre as duas unidades na linha de comando para ter uma cópia fiel?

A cópia será feita em HDs diferente e da certo porque outros por aqui ja fizeram.

Abraço a todos.

Editado por Rafael.R

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Pessoal alguma ajuda? Eu tento fazer o espelhamento com o DOS (xcopy) e com o ImageDrive. Os arquivos ficam idênticos mas o hs simplesmente não boota. Na certa os arquivos de boot não são copiados. Existe algum programa fiel? Que copia um hd para outro diferente.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Quando você faz uma cópia, o programa deixa a partição "inativa". Solução: Instale o Partition Magic (recomendo a versão 8), e nele, tem uma opção de deixar a HD ativa novamente. Os arquivos são copiados sim, eles estão todos lá, mais é necessário fazer este procedimento.

    Depois diga se funcionou :P

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Utilize programas mais novos, como o Teracopy,Ultracopier, Toucan.

    O Xcopy é muito limitado, ainda possui o problema de ser oriundo do DOS que pode trazer problemas com arquivos com nome extenso.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Galera, obrigado pela ajuda. O hd roda em dos mesmo, é um sistema antigo. No momento estou usando o norton ghost pelo disquete, mas alguma coisa acontece pois o HD copiado esta idêntico ao HD original, mas o copiado não boota. Não sei se o norton não encherga estes arquivos. Será que existe algum programa específico para copiar arquivos de boot?

    Estou procurando algum tutorial do MBRTool, mas não acho.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Quando ligo a máquina ela diz que não tem sistema, mas usando o DOS, faço a comparação de arquivos e todos estão la, na mesma quantidade, idênticos, mas simplesmente não da boot, não carrega o sistema. Este sistema roda em dos 6.0, FAT16. Então eu suponho que o programa de cópia não está copiando corretamente o boot. É um assunto "meio" novo para mim.

    Editado por Rafael.R

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Você já tentou fazer o que eu disse, de "ativar" a partição novamente? Muito provavelmente, isso resolva.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Amigo Fapstation, muito obrigado por ajudar viu. Ja que conto com sua ajuda vou explicar melhor pra ficar mais claro.

    O sistema que tento copiar roda em DOS 6.0 em HDs de +- 400Mb. O pc é um 486 ou 386. Em um fórum americano existe um passo a passo para copiar este HD que é o seguinte:

    1 - bootar o HD original e quando ele começar a carregar o sistema apertar "ctrl+c", assim ele entra no DOS;

    2 - Com o DOS, criar um disquete de boot + os arquivos XCOPY e FDISK;

    3 - Colocar o HD bom como master e o vazio como slave;

    4 - Usando o DOS apagar todas as partições do D: (HD vazio) e criar uma partição DOS/FAT16

    *** É ai que entra a tua ajuda, nesta hora esta partição ja fica ativa;

    5 - reiniciar, bootar pelo disquete DOS fazer a cópia de HD para HD pelo seguinte comando: "xcopy d: * c:. / s / v"

    ***só que eu descobri que tem falhas nessa linha de comando pois os espaços estão errados. Eu também descobri que se colocar /h na linha de comando fará que se copie arquivos ocultos. Só que o xcopy não tem esse comando /h, ele retorna uma mensagem de erro e eu também não sei para que serve os * no comando. Então eu cheguei no seguinte comando: c:*.* d: /s /v . Um monte de arquivos é copiado, praticamente todos, mas depois o HD continua sem dar boot.

    Foi ai que eu comecei a usar o norton ghost.

    http://img809.imageshack.us/img809/1017/ghostot.jpg

    Durante o processo de cópia pelo ghost ele tem uma opção de copiar os setores de boot e mesmo assim não vai. Então vejo que preciso de alguma ajuda técnica, pois o HD está bem espelhado, só não boota.

    Abraço e obrigado por hora!

    Editado por Rafael.R

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Eu tentei mas não funciona, o HD copiado carrega o DOS e para. Estou tendo dificuldades para entender o MBRTOOL pois não tem tutorial em portugues. Eu pensei no seguinte: Fazer a clonagem usando o norton ghost, pelos DOS, e depois copiar o setor (ou setores) de boot de um HD para o outro. É possivel?

    Eu poderia pegar somente o BOOT de um HD e passar para o outro.

    Aguardo ajuda.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Peço ao moderador para mudar o titulo do meu tópico para se adequar melhor a minha dúvida.

    Gostaria que o titulo fosse: Clonando o setor de boot de um sistema.

    Talvez eu tenha mais ajuda com este titulo, pois clonar o HD eu consigo mas só o boot que por algum motivo não vai.

    Agradeço.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×