Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
luzivander rocha

Java "ajudem-me"

Recommended Posts

Foi feito no netbeans.

package af4;

import javax.swing.JOptionPane;

import java.text.DecimalFormat;

public class Ex18 {

public static void main(String[] args) {

int qtd;

qtd = Integer.parseInt(JOptionPane.showInputDialog("Quantidade de balas é: "));

if (qtd < 50) {

JOptionPane.showMessageDialog(null, "Por " + new DecimalFormat("0").format( qtd) + " balas deve ser pago, R$ " + new DecimalFormat("#,##0.00").format(qtd * 0.30));

} else if ((qtd > 50) && (qtd < 100)) {

JOptionPane.showMessageDialog(null, "Por " + new DecimalFormat("0").format( qtd) +" balas deve ser pago, R$ " + new DecimalFormat("#,##0.00").format(qtd * 0.25));

} else if ((qtd > 100) && (qtd < 200)) {

JOptionPane.showMessageDialog(null, "Por " + new DecimalFormat("0").format( qtd) +" balas deve ser pago, R$ " + new DecimalFormat("#,##0.00").format(qtd * 0.22));

} else if ((qtd > 200) && (qtd < 400)) {

JOptionPane.showMessageDialog(null, "Por " + new DecimalFormat("0").format( qtd) + " balas deve ser pago, R$ " + new DecimalFormat("#,##0.00").format(qtd * 0.17));

} else if (qtd > 400) {

JOptionPane.showMessageDialog(null, "Por " + new DecimalFormat("0").format( qtd) + " balas deve ser pago, R$ " + new DecimalFormat("#,##0.00").format(qtd * 0.15));

} else{

JOptionPane.showMessageDialog(null, "A quantidade inválida!");

}

}

}

ond eu to errando.

package af4;

import javax.swing.JOptionPane;

public class Ex28 {

public static void main(String[] args) {

int numero;

numero = Integer.parseInt(JOptionPane.showInputDialog("Informe um número:"));

if (Math.pow( (numero/100 + (numero-(numero/100)*100)),2)== numero) {

JOptionPane.showMessageDialog(null, "O número informado atende os requisitos.");

} else {

JOptionPane.showMessageDialog(null, "O número informado não atende os requisitos.");

}

}

}

esse também.

Editado por luzivander rocha

Compartilhar este post


Link para o post
Compartilhar em outros sites

está errando em não falar qual o erro?

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Desculpe, mas ja consegui mesmo assim obrigado na proxima eu prometo melhorar a pergunta.

    bom ta ai eu preciso de ajuda e espero ter explicado melhor.

    /*

    * algoritmo "semnome"

    // Função : Ler três valores e definir se cada um é par ou ímpar

    var

    valor : inteiro

    inicio

    escreva("Digite um valor inteiro: ")

    leia (valor)

    se (valor%2 = 0) então

    escreval("O valor ", valor, " é PAR")

    senao

    escreval("O valor ", valor, " é ÍMPAR")

    fimse

    escreva("Digite um valor inteiro: ")

    leia (valor)

    se (valor%2 = 0) então

    escreval("O valor ", valor, " é PAR")

    senao

    escreval("O valor ", valor, " é ÍMPAR")

    fimse

    escreva("Digite um valor inteiro: ")

    leia (valor)

    se (valor%2 = 0) então

    escreval("O valor ", valor, " é PAR")

    senao

    escreval("O valor ", valor, " é ÍMPAR")

    fimse

    fimalgoritmo

    */

    import javax.swing.JOptionPane;

    public class Ex1_repetiçoes{

    public static void main(String args[]){

    String saida="";

    String entrada=JOptionPane.showInputDialog("Entre com um numero");

    int i = Integer.parseInt(entrada);

    if(i % 2 == 0)

    saida+="O numero é par";

    else

    saida+="O numero é impar";

    //while;

    if(i % 2 == 0)

    saida+="O numero é par";

    else

    saida+="O numero é impar";

    if(i % 2 == 0)

    saida+="O numero é par";

    else

    saida+="O numero é impar";

    JOptionPane.showMessageDialog(null,"Valor "+saida,"Testa numero ",JOptionPane.INFORMATION_MESSAGE);

    System.exit(0);

    }

    }

    ta +- so que so pede uma vez e eu preciso de 3.

    Editado por luzivander rocha

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • /*

    * algoritmo "ex11"

    // Função :

    // Autor : Luzivander Rocha Lopes

    // Data : 14/04/2012

    // Seção de Declarações

    var

    numero,total:inteiro

    inicio

    // Seção de Comandos

    escreva("Informe o numero inteiro para calcular o seu fatorial: ")

    leia(numero)

    total<-numero

    enquanto numero>1 faca

    total<-total * (numero-1))

    numero <- numero-1

    fimenquanto

    escreva("O fatorial é: ", total)

    fimalgoritmo

    */

    /*algoritmo "Ex23"

    // Função :

    // Autor :Luzivander Rocha Lopes

    // Data : 16/04/2012

    // Seção de Declarações

    var

    r,t0,t26,t51,t76:inteiro

    inicio

    // Seção de Comandos

    enquanto r>=0 faca

    escreva("Informe a quantidade de resposta certa:" )

    se(r<26) e (r>0) então

    t0 <- t0+1

    senao

    se (r>25) e (r<51) então

    t26<-t26+1

    senao

    se (r>50) e (r<76) então

    t51<-t51+1

    senao

    se(r>75) e (r<100) então

    t76<-t76+1

    fimse

    fimse

    fimse

    fimse

    limpatela

    fimenquanto

    escreval("Resultados:")

    escreval("Entre [0,25]: ",t0)

    escreval("Entre [26,50]: ",t26)

    escreval("Entre [51,75]: ",t51)

    escreval("Entre [76,100]: ",t76)

    fimalgoritmo

    */

    preciso fazer esses programa em java alguém me ajude

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Bem.. no primeiro exercicio ali tente colocar todo o bloco dentro de um for.

    e no segundo exercicio terás que usar a recursividade para calcular o fatorial... ou seja, chamar a propria funçao dentro da funçao.

    abraço

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×