Ir ao conteúdo
  • Cadastre-se
Rafaela-Sama.

Fonte PWM 24V

Recommended Posts

Bom dia galera! Tópico novo porque até eu estava ficando muito perdida naquele outro tópico. Ele já ajudou muito, mas agora está ficando muito confuso!  

 

O que eu quero:

Criar uma fonte fixa de 24V para acionamento de uma carga indutiva.

 

Qual a fonte usada:

Será na verdade o sinal de saída de uma fonte MIG(15V quando soldando, e 75V quando não soldando), porém para testes em bancada estarei usando o 127V passando por um varistor(assim poderei variar a tensão), por uma ponte retificadora, e então sendo filtrada por um capacitor eletrolítico de 2200uF. Após a filtragem consigo um valor de até 180V na minha Fonte1. Pretendo considerar o uso dos 180V também.

 

Estou usando um microcontrolador( uC ) para fazer o controle do chaveamento do mosfet de canal N (irf840) que irá chavear o negativo do motor, de moto a ficar fixo a tensão de 24V.

 

Como driver do motor estou usando o TLP250(que me foi muito recomendado no post antigo, e realmente depois de checar os sinais de onda com um osciloscópio posso dizer que é o mais adequado para este circuito que estou construindo).

 

Estou usando a linguagem C para programar o uC.

 

 

Tendo em vista este meu projeto, a primeira coisa que preciso fazer é alimentar o uC, porém eu não sei qual o sinal de tensão que a máquina estará quando eu ligar ela(provavelmente os 75V).

Para que eu possa reduzir este valor(que varia) para 5 volts, fiz uso de uma 'Fonte de tensão série básica com uso de transistor'.

 

fonte24v.jpg

 

Está fonte não suporta alimentar cargas que exigem muita corrente, porém gera o sinal de 12Volts que preciso para acionar o mosfet e os 5Volts para alimentar o uC. Provavelmente eu troque o zener e recalcule os resistores para ter direto 12V, já que muito provavelmente não usarei estes 24v.

 

A partir daí, uC alimentador, preciso ler a tensão que tem na entrada(que varia  de 15V a 180V). Com base nisso fiz do uso de um divisor de tensão com resistores em série: 

 

serie.jpg

 

Pela lógica usada, em cima do R2 terei 3,65Volts de tensão no máximo.

Então peguei este valor, e joguei em uma porta analógica do uC (AN0).

 

Criei uma tabela, que corresponderá aos valores que terei no meu uC.

Veja:

 

tabela.jpg

 

Com base nesta tabela temos: 

Real Vin como a tensão atual da Fonte1. (15V ~180V)

Vin como a tensão após passar pelo meu divisor de tensão(0,31V ~ 3,65V) - AN0

read Vin como o valor que o uC estará entendendo (0 ~737)  (10 bits de resolução, ou seja, para 0V - 0 e para 5V - 1024).

Duty% como o valor de Duty que precisarei para que eu tenha sempre 24V na saída( de 15 até 24V o duty será sempre de 100%).

Duty1 dos valores que eu precisaria jogar na minha saída PWM. (Usei valores diferentes pois achava que o sinal de saída poderia variar apenas de 0- 255, mas estava enganada, então estou usando uma variável Long Int para jogar no CCP1).

E Vout a tensão que tive de saída, ou sejá, usando um resistor como carga obtive sucesso. 

 

O código para gerar esse valor de PWM foi: 

 

#INT_TIMER2
void timer2()
{
 
      Real_Vin=(read_Vin*30)/125;   //descobre tensão que eu tenho na Fonte1
      if(Real_Vin<24) Vin=24;           //Se essa tensão for menor que 24, faz com que Duty sejá 100%
      Duty_Por=(2400/Real_Vin);     //2400  =24v % de duty    
      duty1=(Duty_Por*10);             
 
 
      if(duty1>=999) duty1=999;
      if(duty1<=1) duty1=1;
 
 
      set_pwm1_duty(duty1); 
}
 
 
E como ficou a parte do driver/ acionamento da carga resistiva:
 
hrdware.jpg
 
O sinal no Dreno do mosfet ficou perfeito, vejam:
 
WP_20140121_028.jpg
 
A onda maior é o sinal de gate(12V), tem essa curva pois quando o gate do mosfet é energizado um capacitor também é carregado. 
E o sinal de saída, no caso, do dreno com apenas 5V.
Que onda perfeita, eu nunca teria conseguido ela sem o uso do TLP250 *-*.
 
Meu atual problema:
Quando ligo uma carga indutiva(motor, solenoide) o uC fica doido. Eu até cheguei a programar um display LCD de 16x2 para confirmar os valores que eu estou trabalhando e percebe-se que ele fica piscando que nem doido! Medindo com o sinal do osciloscópio a carga e gate, eles já não trabalham igual com o uso da carga resistiva. No entanto, eu não tenho meu sinal fixo de 24V.
 
O que eu devo fazer galera? Já vi em outros posts pessoas falando para ligar um capacitor de 100nF em paralelo com a carga, tentei e nada.
Deveria tentar fazer uso de um mosfet de canal P(ou até mesmo um IGBT?).
 
Para testes tentei pegar a alimentação do uC de uma fonte separada, e mesmo assim meu circuito teve muito ruído.
 
 
 
Obrigado a todos que leram, e desde já obrigada a todos que estão dispostos a me ajudar!
 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Oi, coloque o esquema do circuito todo inclusive do microcontrolador.

O esquema é esse que eu postei, bem simplificado. Mas se ficar dúvida em alguma parte é só falar.

 

 

Galera estou trabalhando com 1khz, se eu aumentar a frequência será que eu diminuo ou aumento esse ruído? 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Mas eu preciso ver o esquema da realimentação para o processador..

Ali na carga nunca vai ter 24V... você vai ter uma media de 24V mas pulsante, a realimentação precisa de uma dc, como você esta fazendo isso?

Quanto maior a frequencia melhor em termo de ruido, mas se foe muito alta a sua onda ai não vai ficar mais tão perfeita...

Compartilhar este post


Link para o post
Compartilhar em outros sites

O esquema é esse que eu postei, bem simplificado. Mas se ficar dúvida em alguma parte é só falar.

 

 

Galera estou trabalhando com 1khz, se eu aumentar a frequência será que eu diminuo ou aumento esse ruído? 

 

Oi está usando aquele diodo inversamente polarizado em paralelo com a alimentação do motor?

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Oi está usando aquele diodo inversamente polarizado em paralelo com a alimentação do motor?

 

Sim Albert eu coloquei ele. Apesar de não estar no desenho que fiz, ele está presente no projeto.

Mas eu preciso ver o esquema da realimentação para o processador..

Ali na carga nunca vai ter 24V... você vai ter uma media de 24V mas pulsante, a realimentação precisa de uma dc, como você esta fazendo isso?

Quanto maior a frequencia melhor em termo de ruido, mas se foe muito alta a sua onda ai não vai ficar mais tão perfeita...

 

 

mroberto98 a alimentação do meu microcontrolador está aqui: 

fonte24v.jpg 

Eu pego a tensão da Fonte1(que varia) e passo por esse circuito. Quanto a isso ele funcionou normal. Eu tenho os 5 volts fixo na saída dessa fonte. 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim Albert eu coloquei ele. Apesar de não estar no desenho que fiz, ele está presente no projeto.

 

 

mroberto98 a alimentação do meu microcontrolador está aqui: 

fonte24v.jpg

Eu pego a tensão da Fonte1(que varia) e passo por esse circuito. Quanto a isso ele funcionou normal. Eu tenho os 5 volts fixo na saída dessa fonte. 

 

http://www.rogercom.com/XBeeWIFI-QRcode.htm

Neste site é citado um filtro Snubber, que segundo o autor, protegeria o microcontrolador de interferências eletromagnéticas EMI.

 

http://www.newtoncbraga.com.br/index.php/eletronica/52-artigos-diversos/6914-reduzindo-emi-com-componentes-magneticos-art1095

Neste outro site tem um artigo interessante. 

 

 

Faça experiências:

Lambra da Gaiola de Faraday?

tente colocar seu microcontrolador num gabinete blindado e conectado ao GND. 

Este foto-acoplador também tem isolação de 2500 volts. Já seria uma isolação contra o motor.

Tente também conectar a carcaça do motor em GND.

Faça algumas experiência do tipo visando matar as interferências.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Coloque um capacitor de 470nF ali no meio do divisor resistivo que você fez pra tirar uma referencia para o micro!

acho que ja entendi o que você fez ai, você não esta usando uma Realimentação negativa da saida para o micro, você esta controlando o duty conforme a tensão que tem na entrada cerro?

Não se faz isso! coloque o capacitor que eu falei e ve se melhora, se conrinuar vai ter que refazer todo o circuito usando outro logica de funcionamento.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Um controlador analógico não pode ser descartado:

Sugiro o UR3843:

 

Garanto que este funciona. É imune a interferências eletromagnéticas.

Funciona nas piores condições.

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

http://www.newtoncbraga.com.br/index.php/eletronica/52-artigos-diversos/6914-reduzindo-emi-com-componentes-magneticos-art1095

Neste outro site tem um artigo interessante. 

 

 

Faça experiências:

Lambra da Gaiola de Faraday?

tente colocar seu microcontrolador num gabinete blindado e conectado ao GND. 

Este foto-acoplador também tem isolação de 2500 volts. Já seria uma isolação contra o motor.

Tente também conectar a carcaça do motor em GND.

Faça algumas experiência do tipo visando matar as interferências.

 

Este ultimo tópico está interessante eim! Estou analisando aonde está o ruído e vendo possíveis soluções.

 

Estou usando protoboard para fazer os testes, fica difícil blindar :(

Coloquei a carcaça do motor em comum com o GND, mas ainda estou com problemas. 

 

Um controlador analógico não pode ser descartado:

Sugiro o UR3843:

 

Garanto que este funciona. É imune a interferências eletromagnéticas.

Funciona nas piores condições.

 

Será que com este componente não terei os mesmos problemas que estou tendo com o uC? Pois com carga resistiva o sinal do PWM gerado pelo uC fica perfeito. Sem contar que ainda terei que encontrar este componente para comprar..

 

Não encontro datasheet deste componente... você poderia me ajudar? 

Coloque um capacitor de 470nF ali no meio do divisor resistivo que você fez pra tirar uma referencia para o micro!

acho que ja entendi o que você fez ai, você não esta usando uma Realimentação negativa da saida para o micro, você esta controlando o duty conforme a tensão que tem na entrada cerro?

Não se faz isso! coloque o capacitor que eu falei e ve se melhora, se conrinuar vai ter que refazer todo o circuito usando outro logica de funcionamento.

 

Roberto no meu protoboard está montado assim : 

 

analogica.jpg resi

 

Entre os resistores  de 75k coloquei um capacitor de 0,22uF e antes do resistor de 4k7 coloquei um de 0,1uF e um de 47uF. 

 

 

Vou checar no osciloscópio se eu estou tendo muito problema ainda nessa analógica, obrigada por lembrar! 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não vai ter porque esse outro ci funciona de outro jeito, o circuito com o seu microconteolador é mais imune a ruidos do que os analogicos kkkkkk se fazer do jeito certo é claro...

vou tentar abrir a sua mente, veja com o osciloscopio os pinos que você esta usando do micro, veja com carga resistiva e com a indutiva como anda neles...

O segredo é mandar para ele o correto, depois ele que processe com o codigo que você escreveu, e nisso não tem erro!

Se com carga indutiva der algum pepino nas tensoes de referencia que o micro pega para ajustar o pwm, ele vai fazer errado logicamente...

Veja os pinos dele, conforme o seu projeta analiso se o que esta acontecendo neles é o correto, se não for vai seguindo para a parte analogica o sinal e vendo onde esta o erro do circuito.

Retire o capacitor de 47uF, ele n prrcisa estar ai! Retire também o que está entre os resistores de 75k, deixe so o de 100n, mas ao invés de 100n ponhe o de 220n

Compartilhar este post


Link para o post
Compartilhar em outros sites

Este ultimo tópico está interessante eim! Estou analisando aonde está o ruído e vendo possíveis soluções.

 

Estou usando protoboard para fazer os testes, fica difícil blindar :(

Coloquei a carcaça do motor em comum com o GND, mas ainda estou com problemas. 

 

 

Será que com este componente não terei os mesmos problemas que estou tendo com o uC? Pois com carga resistiva o sinal do PWM gerado pelo uC fica perfeito. Sem contar que ainda terei que encontrar este componente para comprar..

 

Não encontro datasheet deste componente... você poderia me ajudar? 

 

Tenho toda a certeza que problemas de ruídos eletromagnéticos você não terá com ele.

Não ficará doido como acontece no microcontrolador. Este componente não é sensível a ruídos eletromagnéticos.

 

Segue o datasheet

http://pdf.datasheetcatalog.com/datasheet/SGSThomsonMicroelectronics/mXysvv.pdf

 

http://proesi.com.br/uc3843-circuito-integrado-dip-8.html

 

http://proesi.com.br/uc3845-circuito-integrado-dip-8.html

 

Eu lhe mandei uma mensagem privada explicando mais alguns detalhes.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Roberto e Albert consegui fazer!

 

Roberto muito obrigada por me lembrar dos ruídos que estavam na porta analógica do uC. Consegui melhorar a filtragem dela colocando capacitor direto na porta analógica do uC.

 

Olha o sinal como estava antes: 

WP_20140204_008.jpg

 

Testei vários valores de capacitores de poliester e o melhor resultado que eu consegui foi esse:

 

WP_20140204_009.jpg

 

Porém o projeto ainda não estava 100%, então obrigada Albert, dei uma boa pesquisada refente aos links que você me mandou e coloquei uma senoide em série com o motor. O sinal da entrada analógica melhorou mais um pouco, o suficiente para eu conseguir o que eu queria, 180V na entrada, 24V no motor! 

 

Olha o sinal, não está perfeito, mas foi suficiente:

 

WP_20140204_004.jpg

 

 

O meu projeto ainda não está pronto, mas concluí mais uma parte do desafio! Vou dormir feliz hoje! 

 

hahaha

 

Obrigada mesmo a todos pela ajuda!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esse último sinal é o analogico na porta do micro né?

Almente mais a frequencia do chaveamento e você vai ver como isso ai vai melhorar!! Outra coisa é cuidado com o ripple de 60hz que ja vem dos 180V... Esse ripple tem que aparecer na entrada do micro, só não pode ter a do chaveamento.

Ta vendo que o ruido sempre acontece mais na linha analogica? Heheh por isso que falei q digital é mais imune.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esse último sinal é o analogico na porta do micro né?

[...]

Ta vendo que o ruido sempre acontece mais na linha analogica? Heheh por isso que falei q digital é mais imune.

 

Sim mroberto98 é na entrada. Entrada muito sensível. 0 à 3.6v qualquer ruído atrapalha legal.

:) 

Agora ainda tem algumas coisas no projeto que eu tenho que tentar melhorar/implementar, mas só de estar funcionando fico feliz. 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pois é, você pode tirar aquele resistor de 4k7 e por o pino do uC direto no meio dos dois resistores..

Qualquer duvida na sua implementação é só falar! ;)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não vai ter porque esse outro ci funciona de outro jeito, o circuito com o seu microconteolador é mais imune a ruidos do que os analogicos kkkkkk se fazer do jeito certo é claro...

 

 

Não exatamente. Talvez você esteja se referindo a transmissão de sinais analógicos em comparação aos sinais que são transmitidos digitalmente.

Os circuitos que transmitem sinais analógicos sofrem mesmo com qualquer ruído, pois para funcionar, precisam de níveis infinitos de tensão e os ruídos sempre vão estar lá no meio do sinal.

 

Os circuitos que transmitem de forma digital não sofrem com interferências pois trabalham processando informações que chegam de forma digital, que na verdade são chaveamentos de tensão entre níveis alto e baixos, em altíssima velocidade, transmitindo um código que depois de decodificado revela o sinal analógico original.

Os ruídos sempre estão abaixo do nível alto do sinal, por isso os ruídos não interferem na transmissão.

Os circuitos que processam estes sinais digitais sempre levam em conta apenas os picos destes sinais: A parte do sinal que é entendida como sendo nível alto.

 

Já os circuitos analógicos que são imunes a ruídos que eu me refiro, também trabalham com sinais digitais, porém o processo para gerar estes sinais digitais são feito de forma analógica, não por software como é o caso de um microcontrolador.

O que eu tenho visto na prática é que desta forma os circuitos analógicos (os que geram sinais digitais) são mais imunes a ruídos do que microcontroladores, que geralmente costumam travar com ruídos.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Um ruido para atrapalhar um sinal digital seja transmitido pelo ar ou por uma trilha na placa precisaria ter uns 130% de amplitude do sinal digital, pra você ver que um codigo binario pra ser atrapalhado o ruido precisa ter ate mais q a propria amplitude que o sinal heheh...

Se em um ponto do circuito analogico for um sinal alto ou baixo então ai se compara igual com o digital... Alem de que o chip é blindado bem difícil do ruido acontecer la dentro... Enfim, os pepinos sempre acontecem fora, no circuito analogico e não no chip... Foi o que aconteceu, o ruido estava justamente numa linha analogica heheh :)

Não existe comparação com o sinal de tv com o digital da placa, pois são a mesma coisa, se o ruido estiver muito intenso no digital a tv vai travar, o processador vai travar e vai congelar a imagem etc.. A mesma logica que usa para o sinal transmitido no ar é o mesmo do que esta na placa...

No circuito analogico tem areas que trabalham com sinal analogico mesmo, como na realimentaçao, ai é que esta o pepino, alguns milivolts de erro pode fazer o pwm ir ao max e ir ao minimo... Foi ai o plablema dela, bem na realimentação ou referência que ela pegou, que é analogico...

sinais digitais são os verdadeiros imunes a ruidos, tente levar o sinal de um microfone por um cabo de uns 10m por exemplo hehe, ai codifique ele em digital e depois transmita por um cabo de 1km hehe.. Vai tar perfeito na outra ponta. Mesmo que o ruido exista em cima do sinal digital ele é ignorado pelo processador, porque só atrapalha o processador se o ruido estiver acima de 130%, no analogico qualquer xoisa vai estragar o sinal, seja audio ou seja niveis numa fonte analogica ou qualquer outra coisa analogica que dependa de niveis de referência.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Este é o problema:

18 meses enfrentando problemas com ruídos em microcontroladores. 

 

Esta placa da foto abaixo é analógica. Ela controla equipamento semelhante e de igual potência.

http://imageshack.com/a/img24/2927/gkj8.jpg

 

http://imageshack.com/a/img824/582/aqge.jpg

 

Esta placa não sofre nenhum problema com ruídos, jamais trava. É totalmente confiável. Opera 24 horas por dia por vários anos sem nunca parar.


Qualquer equipamento digital está sujeito a bugs e travamentos. Mas não estou dizendo que um ou outro seja ruim. É só uma questão de escolha no projeto.

 

Volto a dizer que esta placa é analógicas apenas do modo de funcionar, mas ela gera pulsos PWM.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Nenhum dos dois é ruim...

Acho que a pergunta para esses problemas que você ve bastante seria: A parte analogica que foi mal projetada (erros) ou a digital?

Se o ruido esta atrapalhando a fonte dele acho que o chaveamento esta sendo feito digitalmente, acha que é o chip que trava? Todas as chances sao erros externo e não do chip!

Nunca vi nenhum equipamento digital travar por causa de ruido.. Tv, pc, celular etc.. Agora analogicos sempre tem uns pepinos quando aparece algum ruido... mesmo os de marcas.. Ja vi sinal de celular fazendo um amp oscilar... Isso num amplificador de Marca, e eu que fiz um amplificador do zero transistorizado nãoexiste esses pepinos.

Nos digitais você escuta musica aonde for, perto de motores, perto de uma torre transmissora sem 1 ruido sequer..

Um processador é mais sensivel do que esses microcontrolador, um projeto certificado nunca para de funcionar só porque foi colocado numa area perto de alguma coisa que pegasse ruído..

Os erros sempre são do projeto externos que a pessoa fez..

No analógico não se ve por aí muitos casos porque normalmente os projetos são baseado ao fabricante do ci, aposto que se o cara fizesse um analogico do zero sem nenhuma referência daria pepinos piores ainda!

Eu sempre achei que isso seria por causa da logica do digital ser diferente da analogica, e por outro lado a analogica é incomparavelmente mais complexa que a digital!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você está fazendo comparações fora do contexto.

Apenas citei sobre travamentos de microcontroladores quanto ao controle de circuitos de potência, onde os circuitos analógicos são mais fáceis de se lidar por serem realmente mais imunes.

 

Como a criadora do tópico disse, a questão foi resolvida, então é isso aí.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@mroberto98,

Circuitos de alta potência, e ainda com cargas indutivas, tem de ser muito bem filtrado, pois os níveis de ruidos induzidos nas trilhas e até em fios que saem da placa acabam gerando tensões altas, que acabam interferindo até mesmo no circuito oscilador do microprocessador, podendo fazer ele travar sem nenhuma explicação. Existem muitos casos de pessoas que ficaram semanas procurando defeitos fantasmagóricos, muito difíceis de serem identificados no momento em que acontecem.

Já os circuitos analógicos de controle possuem uma tolerância bem maior a problemas de ruidos induzidos, e tem uma excelente vantagem : não tem como travar !

Eu concordo com o Albert, eu só insistiria em fazer isso microprocessado se tivesse um bom osciloscópio digital com uma boa memória e ajustes de trigger muito eficientes, e eu tivesse mais prática nesses circuitos....

Paulo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pois então somos dois, os problemas eu concordo também!

o que eu estava tentando dizer é que se levar em consideração ruídos eletricos e não magnéticos, pra começo de conversa que se tiver esse tipo de ruido é porque o circuito está mal feito, é obvio também que um processador só funciona com uma tensão bem precisa com baixa tolerância.. Mas isso não seria problema para um engenheiro certo?

Agora o ruido magnetico pelo ar para atrapalhar os dados binários, esse sim que é muito mais tolerante que o analogico, se river um sinal de 0 a 10V, precisaria de uns 14Vpp de amplitude de ruido para travar, e no analogico? Sera que pode ter tudo isso e ele ainda vai funcionar perfeitamente como o digital? peincipalmente o analogico que ta sempre na comparação de niveis de sinais de qualquer valores e no digital são apenas dois niveis..

Fora que é quase impossivel de se ter 130% de ruido em relação ao sinal, se o cara conseguir provocar isso tem que levar parabéns heehehe

Se travar se perde tudo, no analogicos não...

Sempre tem explicações... O problema é saber onde está acontecendo o pepino e arruma lo..

O problema éonde está a questão, ruidos atrapalhando os codigos ou ripple de fonte??? Ruido atrapalhar os codigos o digital ganha... Ripple da fonte o analogico ganha..

Mas qual é mais pepinoso? Um simples ripple ou ruidos pelo ar?

particularmente eu prefiro a analogica, pois é muito melhor para fonte, o funcionamento e mais eficiente etc..

Eu ja cansei de pegar projetos analogicos e digitais que não funcionam com esses pepinos.. Os analogicos funciona, mas adivinha!! Os analogicos eram mais bem feitos, e os digitais parece que o cara fez so pela logica digital e esqueceu da analogica.. Resultado, sempre da esses pepinos, que são pepinos analógicos, ruidos introduzidos em linhas analogicas do circuito, porque nas vias que transmite os codigos binario isso eu nunca vi... Pode se dizer que o pepino e na analogica ja que os ruidos entram em vias analogicas por mais que o circuito seja digital, no contexto então a "DIGITAL" é que é mais imune...

Era so isso que eu estava dizendo, mas eu ja disse que prefiro analogico para esses tipos de circuito.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@mroberto98,

Circuitos de alta potência, e ainda com cargas indutivas, tem de ser muito bem filtrado, pois os níveis de ruidos induzidos nas trilhas e até em fios que saem da placa acabam gerando tensões altas, que acabam interferindo até mesmo no circuito oscilador do microprocessador, podendo fazer ele travar sem nenhuma explicação. Existem muitos casos de pessoas que ficaram semanas procurando defeitos fantasmagóricos, muito difíceis de serem identificados no momento em que acontecem.

Já os circuitos analógicos de controle possuem uma tolerância bem maior a problemas de ruidos induzidos, e tem uma excelente vantagem : não tem como travar !

Eu concordo com o Albert, eu só insistiria em fazer isso microprocessado se tivesse um bom osciloscópio digital com uma boa memória e ajustes de trigger muito eficientes, e eu tivesse mais prática nesses circuitos....

Paulo

OFF TOPIC

 

Seu comentário me lembrou os malditos travamentos da fonte dos meus transceptores.

Na época ninguém achava o defeito da fonte... hehehe

Depois de um tempo começaram a aparecer comentários na internet sobre o comportamento das fontes chaveadas e a RF.

oh época que eu passei raiva.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×