Ir ao conteúdo
  • Cadastre-se
Mickael Mattos

O algoritmo deve imprimir na saída as palavras Comprar ou Vender, caso seja dia de compra ou venda. Caso não seja dia de venda ou compra o programa nã

Recommended Posts

Você foi contratado para escrever um algoritmo para um investidor da bolsa de valores. Este investidor acredita que se o preço de uma ação sobe três ou mais dias seguidos e desce no próximo dia, então este é um dia bom para vender a ação. Da mesma forma, se o preço da ação desce três ou mais dias seguidos e no dia seguinte sobe, então ele acredita que este é um bom dia para comprar a ação.

 

Os dados que o seu algoritmo deve ler são os seguintes:

 

 Primeiro, um valor inteiro N com a quantidade de preços de ações a serem lidos;

 Em seguida, N valores contendo os preços das ações em cada um dos dias.

O algoritmo deve imprimir na saída as palavras Comprar ou Vender, caso seja dia de compra ou venda. Caso não seja dia de venda ou compra o programa não imprime nada.

Considere que, no início do algoritmo, o investidor já possui uma quantidade qualquer de ações e, portanto, é possível vender ações antes de ter feito qualquer compra.

A seguir mostramos um exemplo de como deve ser feita a entrada e saída de dados. Em negrito estão os valores fornecidos pelo usuário do algoritmo.

Quantidade de dias? 15

Dia 1? 26.375

Dia 2? 25.5

Dia 3? 25.125

Dia 4? 25

Dia 5? 25.25

Comprar

Dia 6? 27.125

Dia 7? 28.25

Dia 8? 26

Vender

Dia 9? 25.5

Dia 10? 25

Dia 11? 25.125

Comprar

Dia 12? 25.25

Dia 13? 26.375

Dia 14? 25.5

Vender

Dia 15? 25.5

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Mickael Mattos

 

Por gentileza, poste aqui o que tentou fazer. Assim os demais podem ajudar você.

 

PS: Dê mais informações.. como linguagem estás desenvolvendo... e o principal, não espere algo pronto.. Como o exercício é seu qualquer um aqui pode só lhe indicar um norte.. OU reescrever seu código.. MAS para que isso aconteça..  deves postar suas tentativas.

 

ATENÇÃO

Antes de postar o código Leia este tópico ---->  http://forum.clubedohardware.com.br/topic/1136628-tags-code-como-e-para-que-usar/

Ensina COMO postar códigos aqui.

Compartilhar este post


Link para o post
Compartilhar em outros sites


var

dias:inteiro

preco:real

inicio

escreva ("Digite a Quantidade de dias ")

leia (dias)

preco <- 0.0

para preco de 1 ate dias faca

escreva ("Digite o preco ")

leia (preco)

se preco > preco então

escreva ("Comprar", preco)

senao

escreva ("Vender", preco)

fimse

fimpara

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×