Ir ao conteúdo
  • Cadastre-se
Osmarbg

Função se - ao colocar uma data mostrar quitado.

Recommended Posts

Boa tarde.

Tenho uma planilha com uma função SE que preciso fazer uma mudança mas estou tendo dificuldade.

Ao digitar x na coluna C, a coluna G aparece quitada, a coluna F4 mostra o valor pago e a coluna F6 mostra o valor que ainda resta pagar.

funciona tudo perfeito, exceto que eu não quero digitar X e sim a data que a obrigação foi paga, independente da data.

ou seja quero eliminar o X e no seu lugar digitar uma data para que as funções se apliquem.

segue anexo um modelo da planilha.

 

 

Pasta1.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Nem olhei a planilha mas você deve ter algo assim

 

Se(C2= "X";"QUITADO".....

 

Troque por isso

 

Se(C2<>"";"QUITADO"

 

O restante da formula você mantem

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fiz várias alterações.

  • Coloquei uma validação na coluna C q só permite a entrada de datas <=HOJE();
  • Inseri uma célula F5 com o número de parcelas;
  • A coluna E agora é preenchida automaticamente com base no valor da célula F5;
  • Alterei a fórmula da coluna G p/ =SES(ÉCÉL.VAZIA(B8);""; ÉNÚM(C8);"Quitada";B8-HOJE()<0;"Vencida";B8-HOJE()<5400;"A vencer");
  • Alterei a cor do "Valor do acordo" p/ destacar a célula como sendo p/ entrada de dados.

Deixei a coluna F sem cálculo automático p/ dar maior liberdade no estabelecimento do valor das parcelas.

A coluna B poderia ser preenchida automaticamente com valores incrementais de mês, mas não sei se é política do banco manter o dia, no seu exemplo tinha dia 10 e 29.

 

 

Acordo bancário de parcelamento.xlsx

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia DJunqueira.

Achei muito boa a ideia do preenchimento automático das parcelas.

Porém na coluna C, data do pagamento preciso que fique como antes, pois este pagamento pode acontecer em qualquer data.

E na coluna G, a formula colocada não esta funcionando, não aparece mais quitada, vencida e a vencer e sim estes caracteres:

#NOME?

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Osmarbg

 

Na coluna F4 coloca =SOMASE(C8:C184;">0";F8:F184)
Na Coluna G8 coloca =SE(ÉCÉL.VAZIA(B8);""; SE(C8<>"";"Quitada";SE(B8-HOJE()<0;"Vencida";SE(B8-HOJE()<5400;"A vencer";""))))

 

Epero ter ajudado


Decio
 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Na coluna C a regra de validação só limita a entrada de valores maiores q o dia de hoje, para alterar isto é só alterar as regras de validação, Dados / Validação de dados. Particularmente penso q seria estranho registrar a quitação de uma dívida antecipadamente.

Coluna G - provavelmente há um problema de versão, sua versão do Excel não deve ser a de 2016 em q você pode utilizar a nova função SES().

 

Então ficou assim: Deixei a coluna C p/ você alterar a regra de validação q não deixa mais inserir outra coisa q não seja data menor ou igual a de hoje e voltei com os múltiplos SE() na coluna G.

Acordo bancário de parcelamento.xlsx

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não entendo o que pode estar havendo, meu excel é 2016.

mas a coluna G situação, não aparece mais.

todas as células ficam assim

Nome?  

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
42 minutos atrás, deciog disse:

@Osmarbg

 

Na coluna F4 coloca =SOMASE(C8:C184;">0";F8:F184)
Na Coluna G8 coloca =SE(ÉCÉL.VAZIA(B8);""; SE(C8<>"";"Quitada";SE(B8-HOJE()<0;"Vencida";SE(B8-HOJE()<5400;"A vencer";""))))

 

Epero ter ajudado


Decio
 

 

Bom dia Décio, funcionou perfeitamente.

era isso mesmo que precisava.

obrigado.

ótimo dia.

O amigo DJunqueira também ajudou muito com a fórmula de colocar as datas automáticas.

obrigado a todos.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×