Ir ao conteúdo
  • Cadastre-se
Kaio Gomes

Verificar se o numero do documento existe no conjunto de Vetores

Recommended Posts

13)Elabore um algoritmo para ler e armazenar em um vetor o número do documento de 100 pessoas, depois ler o número de um documento, verificar se este número de documento existe no conjunto de documentos original e em qual posição do vetor este documento está armazenado, se o documento não existe no conjunto original exibir a mensagem “Documento não localizado”. 
 

Resposta:

 

algoritmo "semnome"
var
v1:vetor[1..5] de inteiro
i,x:inteiro
inicio
para i de 1 ate 5 faca
escreva("Numero do documento:")
leia(v1)
fimpara
i:=x
escreva("Documento procurado: ")
leia(v1)
se (x>0]) e (x<5]) então
escreva("Numero do documento é: ",x)
senao
escreva("Documento nao encotrado")
fimse
fimalgoritmo

 

Preciso de ajuda por favor!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Kaio Gomes     no primeiro leia está faltando colocar a dimensão do vetor que está sendo
lido coloque assim:

leia (v1[i])

para ler o documento procurado não pode ser no vetor v1, use outra variável
por exemplo o x assim:

leia(x)

Em seguida coloque um loop com a variável i para procurar no vetor de acordo com a quantidade de elementos do vetor, e dentro desse loop coloque assim:

se v1[i]=x então//x>0]) e (x<5]) então
    escreva("o Numero do documento é: ",x," encontrado na posição ",i," do vetor" )
fimse

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Só um adendo:

 

1) COMO POSTAR UM CÓDIGO

 

@Kaio Gomes, por favor, ao postar um código utilize a tag CODE (botão <>). Um pouco soube aqui:

Dessa forma, o seu código manterá melhor a estrutura de identação e evitará que "suma" as coordenadas "[i ]", como lá no v1.

 

***

 

Em relação ao código em si não tenho muito a acrescentar no momento. Sugiro que analise as sugestões de @devair1010 e corrija o seu código.

 

 

No aguardo.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×