Ir ao conteúdo
  • Cadastre-se
ET Bilu

Matrizes - notas de 5 alunos diferentes

Recommended Posts

Faça um programa que receba:

a. As notas de 15 alunos em cinco provas diferentes e armazene-as em uma matriz 15x5;

b. Os nomes dos 15 alunos e armazene-os em um vetor de 15 posições; O programa deverá calcular e mostrar: - Para cada aluno, o nome, a média aritmética das cinco provas e a situação (aprovado, reprovado ou exame – crie os limites de valores); - A média da classe:

 

Foi isso que eu consegui fazer até agora:

algoritmo "semnome"
// Função :
// Autor :
// Data : 01/12/2016
// Seção de Declarações
var
notas:vetor[1..15,1..5] de real
c,l,i:inteiro
nome:vetor[1..15] de caractere
inicio
para c de 1 ate 15 faca
   para l de 1 ate 5 faca
      leia(notas[c,l])
      somatorio<-somatorio+notas[c,l]
   fimpara
fimpara
para i de 1 ate 15 faca
   leia(nome[i])
fimpara


fimalgoritmo

Parece ser fácil, mas me confundiu um pouco. Preciso criar mais um vetor?

adicionado 31 minutos depois

Dei uma atualizada, mas continuo nao conseguindo.

 

algoritmo "semnome"
// Função :
// Autor :
// Data : 01/12/2016
// Seção de Declarações
var
notas,media,somatorio:vetor[1..15,1..5] de real
c,l,i:inteiro
nome:vetor[1..15] de caractere
inicio
para c de 1 ate 15 faca
   para l de 1 ate 5 faca
      leia(notas[c,l])
   fimpara
fimpara
para i de 1 ate 15 faca
   leia(nome[i])
fimpara
para c de 1 ate 15 faca
   para l de 1 ate 5 faca
      escreval(nome[c])
      escreval(notas[c,l])
      somatorio[c,l]<-media[c,l]+notas[c,l]
   fimpara
fimpara





fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@ET Bilu     no inicio dentro loop l na hora de ler as notas coloque uma informação para o
usuário saber o que fazer,  assim:

   escreva(" Digite a ",l," nota do ",c," aluno ")
      leia(notas[c,l])
      media[c,5]:=media[c,5]+notas[c,l]
   fimpara   // L
   media[c,5]:=media[c,5]/l

como a media para cada aluno é uma só, então pode usar uma coordenada fixa 
e o somatório também é um só então use uma coordenada fixa também para facilitar.
coloque por exemplo :

   somatorio[1,5]<-somatorio[1,5]+media[c,5]

e no final, antes do fimalgoritmo, para ver a media da classe pode colocar alguma
coisa tipo isso:

escreval(" Média Da Classe ",somatorio[1,5]/c

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Um adendo:

 

Em relação a média, recomendaria duas opções:

 

- Ou a média seria uma variável simples (sem ser vetor).

- Ou a média seria um vetor simples (de uma coordenada)

 

Recomendo a primeira opção, pois a média é basicamente um cálculo. Calcula ela e exibe. Não precisa armazenar essa informação.

 

Em relação ao somatório, se estiverem se referindo a "soma das notas do aluno", idem a médias: não precisa armazenar. Seria uma variável simples.

 

Exemplo de como poderia ficar as variáveis:

var
   nomes :vetor[1..15] de caractere
   notas :vetor[1..15,1..5] de real
   somatorio, media :real
   c,l,i :inteiro

 

 

No aguardo.

 

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×