Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
davidzinh

VisualG Meu algoritmo está com erro só não sei onde

Recommended Posts

Escreva um programa que receba números inteiros entre 10 e 35 (UTILIZE O ENQUANTO). Se o usuário digitar um número diferente, mostre a mensagem "Número Inválido" e solicite um número novamente. Caso digite o número correto, mostre a contagem do 10 até o número digitado e finalize o programa. 
Exemplo: 
Número 15
10-11-12-13-14-15

meu programa:

 var
 
num , i: inteiro
inicio
escreva("Informe um número em [10, 35]: ")
leia(num)
enquanto ((num >=10) e (num <=35)) faca
escreva("Número inválido. Reinforme um número em [10, 35]: ")
leia(num)
fimenquanto
i <- 10
enquanto (i <= num) faca
se( i = 10) então
escreva(i)
senao
escreva(" - ", i)
fimse
i <- i + 1
fimenquanto
escreval("")

quando eu escrevo 2 por exemplo ele roda, e não roda o 22 por exemplo

ja consegui resolver era um problema no <=35 ai não rodava só foi eu colocar >=36 q rodou :)

mas ainda roda os números abaixo de 10 se alguém souber me fale

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@davidzinh    sua lógica está boa mas precisa usar os comandos mais eficazmente ,  então modifiquei algumas linhas do seu código,   veja como ficaria :

Algoritmo "numeros entre dez e trinta e cinco"
var
  num,a,b : inteiro
inicio
  enquanto ( b = 0 ) faca
    b := 1  // b é o controle de número inválido
    escreva("Informe um número entre  10 e 35 : ")
    leia(num)
    se (num < 10) ou (num > 35) ENTÃO// se número fora de faixa
      b := 0  // b igual a zeros para repetir
      escreval("Número Inválido. Reinforme O número,   Tecle Enter")
      leia(num) // espera pressionar enter
    fimse
  fimenquanto
  a := 10  // a igual começo dos números à ser impressos
  escreval  // pula uma linha
  enquanto (a <= num) faca
    escreva(a," - ")// escreveo número na tela
    a := a+1  //  a igual ao próximo número
  fimenquanto
  escreval
Fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×