Ir ao conteúdo
  • Cadastre-se
gabriela0404

VisualG O que estou fazendo de errado??

Posts recomendados

Var
// Seção de Declarações das variáveis 
resto, cont : real

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 
enquanto  cont=1000 ; cont<2000 faca

inicio
resto <- cont mod 11
se (resto =  5) entao
escreva (cont)
fimse
fimenquanto
Fimalgoritmo

Algoritmo que verifique e mostre os números entre 1000 e 2000 (inclusive) que, quando divididos por 11, produzam resto igual a 5.

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@gabriela0404 se é inclusivo, então tem que ser menor ou igual a 2000 e parece que tá faltando o incrementador do contador, a cada iteração precisa incrementar de alguma forma para o 1000 passar para 1001 e verificar a condição da questão.

  • Curtir 1
  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@gabriela0404    seu código está bom ,  faltou alguns comandos e outros fora do lugar ,  e seu código com algumas  modificações poderia ser assim  :

Algoritmo "resta_5"
Var
  cont  : inteiro // o comando mod só funciona com inteiro, se usar outro tipo buga o compilador e trava tudo e é preciso fechar usando o ctrl + alt
  resto : real
Inicio
  cont := 1000//inicializar a variável
  enquanto (cont>=1000) e (cont<=2000) faca// duas comparações use expresão lógica
  //expresões lógicas < e ou nao > precisam ficar entre parenteses
    resto <- cont mod 11
    se resto = 5 entao     // uma comparação apenas , não precisa ficar entre parenteses
      escreva(cont)        // escreve na tela sem pular para outra linha
    fimse
    cont := cont + 1       // incrementar a variável para o loop proseguir até o final, senão loop infinito e buga tudo também
  fimenquanto              // precisa colocar o fimenquanto
  escreval
  escreval                 // pular linhas no final para efeito de apresentação
Fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Só um adendo:

 

1 hora atrás, devair1010 disse:

    resto : real

 

O resto também seria inteiro mesmo, pois sempre o resto será inteiro.

 

 

Outra forma de fazer seria utilizando o para/faca. Ex.:

algoritmo "resta_5"
var
   cont, resto : inteiro
inicio
   para cont de 1000 ate 2000 faca
      resto <- cont mod 11
      se resto = 5 entao
         escreva(cont)
      fimse
   fimPara
fimAlgoritmo

 

Em ambos os códigos, nem precisaria da variável resto. Ex.:

algoritmo "resta_5"
var
   cont : inteiro
inicio
   para cont de 1000 ate 2000 faca
      se cont mod 11 = 5 entao
         escreva(cont)
      fimse
   fimPara
fimAlgoritmo

 

Aí vai do gosto.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!