Ir ao conteúdo
  • Cadastre-se
Felipe Alencar

Excel - soma de células mescladas

Posts recomendados

Boa tarde amigos...

Estou com uma demanda enorme.

Queria melhorar um pouco pra agilizar o serviço.

 

Tenho que ter uma coluna com células mescladas.

E preciso que todas as células mescladas exibam o total das células correspondentes ao espaço de mesclagem da coluna anterior.

 

Podem ver na Planilha, Pasta São Sebastião.

COLUNA F e G precisam ser MESCLADAS de acordo com a Coluna B.

E os Resultados da Coluna F precisam ser a soma dos resultados da coluna E que corresponde ao espaço Mesclado na F.

 

valeu!

 

Pasta1.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Nao entedi muito bem o criterio para mesclar as celulas uma vez que as cidades se repetem em mesclagens em separado.

 

Qual o criterio para mesclar as celulas e mante-las em separado por exemplo a cidade de São Paulo nas linha 7 a 9 tem uma totalização e nas linhas 22 a 31 tem outra totalização em separado, esses totais podem ser calculados juntos?

 

No caso citado as linhas 7 a 9 temos um total de 8 e das linhas 22 a 31  30  ou seja apenas neste exemplo um total de 38 

 

Se sim uma tabela dinamica faz isso com facilidade. Se nao, por quê?

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não..

Cada grupo mesclado na coluna F deve ter o resultado das células que equivalem a mesclagem.

 

O motivo é esse... A Planilha é advinda de uma Tabela Dinâmica.

E antes de ter a planilha completa, ainda preciso completar dados manualmente.

 

Pra só então gerar as 2 ultimas colunas com soma e percentual!

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

11 minutos atrás, CasaDoHardware disse:

Nao entedi muito bem o criterio para mesclar as celulas uma vez que as cidades se repetem em mesclagens em separado.

 

Qual o criterio para mesclar as celulas e mante-las em separado por exemplo a cidade de São Paulo nas linha 7 a 9 tem uma totalização e nas linhas 22 a 31 tem outra totalização em separado, esses totais podem ser calculados juntos?

 

No caso citado as linhas 7 a 9 temos um total de 8 e das linhas 22 a 31  30  ou seja apenas neste exemplo um total de 38 

 

Se sim uma tabela dinamica faz isso com facilidade. Se nao, por quê?

 

 

Leia de novo o primeiro, eu editei enquanto você estava postando e coloquei uma tabela menor e mais fácil de entender.

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, deciog disse:

@Felipe Alencar

 

è isso que desejas??

 

Decio

 

Pasta1 Decio.xlsx

 

Mais ou menos...

Só que na formula ele soma tudo que tiver com o nome do município... E eu preciso que some apenas o que tiver nas linhas que estão mescladas!

 

Olhai a tabela completa... Dá pau porque soma tudo de SP na planilha e a soma deve ser apenas de SP que estão mescladas!

 

REPETE O NOME DO MUNICIPIO, MAS EM OUTRO GRUPO!

 

Litoral Norte - 2014.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

O grupamento q sua planilha faz é por município e subgrupo de procedimento, portanto a fórmula é simples de resolver:

=SE(B3&D3=B2&D2;"";SOMARPRODUTO(($G$3:$G$269)*($D$3:$D$269=D3)*($B$3:$B$269=B3)))

e

=SE(H3="";"";H3/21718)

Uma outra forma de formar subtotais pode ser visto na aba 'Ilhabela 1' q não tem células mescladas, mas onde montei uma formatação condicional p/ parecer mesclada e q só faz o cálculo do grupo na primeira célula.

 

O problema de ficar mesclando 'no olhômetro' é q você pode acabar mesclando cidades iguais, mas com subgrupo de procedimento diferente como ocorreu em uma de suas listas (Ilhabela 250;251;252).

 

Litoral Norte - 2014.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites
9 horas atrás, DJunqueira disse:

O grupamento q sua planilha faz é por município e subgrupo de procedimento, portanto a fórmula é simples de resolver:


=SE(B3&D3=B2&D2;"";SOMARPRODUTO(($G$3:$G$269)*($D$3:$D$269=D3)*($B$3:$B$269=B3)))

e

=SE(H3="";"";H3/21718)

Uma outra forma de formar subtotais pode ser visto na aba 'Ilhabela 1' q não tem células mescladas, mas onde montei uma formatação condicional p/ parecer mesclada e q só faz o cálculo do grupo na primeira célula.

 

O problema de ficar mesclando 'no olhômetro' é q você pode acabar mesclando cidades iguais, mas com subgrupo de procedimento diferente como ocorreu em uma de suas listas (Ilhabela 250;251;252).

 

Litoral Norte - 2014.xlsx

 

Resolvido...

Obrigado a todos...

 

Amigo, sei que excel e Mesclagem é treta...

Mas exigência do cliente!

adicionado 6 minutos depois

@DJunqueira Só uma coisinha, digamos que eu consiga convencer o cliente...

 

=SE(H3="";"";H3/Tabela2[[#Totais];[Quantidade de procedimentos]])

 

De onde viriam esses dados? Tabela2 [Totais] e [Quantidade de procedimentos] ???

Compartilhar este post


Link para o post
Compartilhar em outros sites

Quando você transforma uma  lista em tabela reconhecida pelo Excel as colunas são referenciadas de forma diferente.

Neste caso em particular a fórmula está indicando a linha de totalização na base da Tabela2 da coluna [Quantidade de procedimentos].

 

Tabelas do Excel usam o nome cabeçalho da coluna p/ indicar a coluna inteira, isso ajuda na hora de compreender a fórmula e promove o seu ajuste a qq entrada de novos dados.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Este tópico está parado há muito tempo. Certifique-se que a sua mensagem tem a ver com o tema sendo discutido. Obrigado.

Junte-se à conversa

Você pode postar agora e cadastrar-se depois. Se você tem uma conta, faça o login para postar.

Visitante
Responder

×   Você colou conteúdo com formatação.   Restore formatting

  Só é possível ter até 75 emoticons.

×   O link foi automaticamente convertido para mostrar o conteúdo.   Clique aqui para mostrá-lo como link comum

×   Seu texto anterior foi restaurado.   Limpar o editor

×   You cannot paste images directly. Upload or insert images from URL.






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!