Ir ao conteúdo
  • Cadastre-se
pedro hss

Ligar led em entrada usb

Recommended Posts

gustavo 555,

Na página anterior, respondendo a minha pergunta você disse:

PWM significa Pulse Width Modulation (acho que é isso mesmo), ou seja, modulação por largura de pulso. O circuito pisca muito rápido, e através de um potenciometro, ou chaves tactil (no caso de ser microcontrolado) você controla a largura do pulso, controlando assim a intencidade da luz.

-

Mas qual a vantagem de usar um sistema PWM sendo possível, simplesmente, usar um potênciometro direto?

-

Aguardando, obrigado.

-

-

Tiago.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Dá uma olhada ai:

http://www.eletronica.org/arq_apostilas/apostila_pwm.pdf

No caso do LED, quase não a perda em calor quando usado o potenciômetro, então tanto faz um ou outro, mas quando se precisa chavear, por exemplo uma carga de 5A? Teria de se fazer um circuito do gênero daquele mostrado na apostila ai acima, e a potencia transformada em calor seria muito grande. O resto é só você ler a apostila inteira...

Abraços!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ahhh sim! Obrigado!

Caramba, muito boa essa apostila!

Essa vai para minha listinha das que merecem ser impressas ^_^

-

Então beleza...

Irei usar apenas um potênciometro...

Mas como calcular o valor ideal do mesmo?

-

Aguardando, obrigado.

-

-

Tiago.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá a todos.

Primeiramente peço imensas desculpas por reviver um tópico morto há anos, mas o encontrei numa busca pelo Google e vi que é o exato caso que tenho.

 

Fiz uma luminária em minha mesa do PC, logo acima do teclado, pelo mesmo motivo do criador do tópico: iluminar o teclado por precisar apagar a luz do ambiente. Vi uns vídeos no YouTube e acabei fazendo minha luminária com 8 leds brancos de alto brilho (duas estações com 4 cada, separadas a uns 15cm uma da outra lateralmente), e até coloquei um botão I/O, por uma questão de praticidade em não ter que ficar tirando e colocando o cabo USB a cada uso. Usei 8 resistores de 100 ohms cada (4 em cada estação em equivalência de um para cada led).

 

Ocorre que a princípio o cabo esquentava bastante quando o sistema ficada desligado (me refiro ao botão I/O na posição desligado), e desaquecia quando ligado. Depois isso não veio mais a ocorrer, mas agora tenho dois problemas, que creio ser o mesmo problema em si: se ligo o PC a BIOS acusa que uma porta USB está dando erro de "device over current" (ou algo parecido) e desliga o PC, se eu desconecto o sistema liga normalmente. Quando o SO está ativo e ligo na USB a mensagem do Windows 10 é surto de tensão na USB, acusando que tem sido exigido mais energia que a porta gera.

 

NOTA: isso só ocorre se o botão I/O estiver na posição DESLIGADO, mas se estivar como LIGADO nenhum destes problemas ocorre.

 

Admito que entendo de eletrônica tanto quanto um corvo entenderia. Peço a ajuda daqueles que puderem me ajudar. Seria a falta de algum componente (diodo, capacitor ou algum outro)?

Compartilhar este post


Link para o post
Compartilhar em outros sites
4 horas atrás, HabibCdR disse:

Admito que entendo de eletrônica tanto quanto um corvo entenderia

isso explica tudo. Amigo é bem simples: você fez alguma cagadinha básica. Publique fotos ou desenhos da sua criação

É bem simples. Com quase menos de um clique no google imagens e achei isso

IMG_0083.JPG

Uma boa referência do que fazer e do que não fazer: cuidado pra não encostar o terminal do led na latinha e nunca jamais usar led verde

Compartilhar este post


Link para o post
Compartilhar em outros sites

Edit:

Pessoal, tirei umas fotos (estão meia-boca, mas tudo bem). A primeira e a segunda, da esquerda pra direita, são da parte do sistema que tem o botão I/O, e de onde a outra parte puxa energia (quarta foto). A terceira é do sistema desligado, quando ocorrem as mensagens.

 

No sistema liguei todos os leds a um fio em cada perna, e os resistores estão ligados em fila.

 

fotos.thumb.jpg.d8f92b0d16edf545145c86feba701420.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá pessoal, desculpem o double post. Como já tem uns dias e meu problema persiste, se alguém puder auxiliar ficarei imensamente grato.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ola.

 

A resposta já foi dada , seu circuito está exatamente como o amigo @Ricardo S Ferreira explicou.

 

Nota que na sua descrição das fotos diz :"

Em 10/11/2018 às 12:18, HabibCdR disse:

A terceira é do sistema desligado

 

O posição "I"  significa "CHAVE LIGADA" fechando os contatos e colocando em curto a sua porta USB .

 

Vou rascunhar rapidinho aqui um diagrama de como deveria ser o circuito , já vou postar , peraê ...

 

'_'

 

 

ckt-chd.png

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×