Ir ao conteúdo
  • Cadastre-se
MarcMarc

Algortimo que faça entrada de dados e só aceite valores superiores

Recommended Posts

Olá pessoal, preciso de um algortimo que faça entrada de dados e só aceite valores superiores aos que já foram fornecidos. Já tentei fazer de inúmeras formas, mas não consegui.

Obrigado desde já. 

obs. A linguagem é portugol 

Editado por MarcMarc
Melhorar o título
  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
25 minutos atrás, MarcMarc disse:

Olá pessoal, preciso de um algortimo que faça entrada de dados e só aceite valores superiores aos que já foram fornecidos. Já tentei fazer de inúmeras formas, mas não consegui.

Obrigado desde já. 

 

Cara, creio eu que ninguém vai simplesmente postar o algoritmos pronto aqui para você. Se você pelo menos não postar o que está tentando fazer, (rascunho) e dúvidas específicas em cima dele.

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a sua resposta está certa ou não, ou para que possamos ajudá-lo com a sua dúvida no desenvolvimento do exercício.

 

Infelizmente, não temos como resolver seus trabalhos por você. O objetivo do Fórum do Clube do Hardware é auxiliar você a sanar suas dúvidas, e não de responde-las em seu lugar. Além disso, copiar e colar respostas que não são de sua autoria é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

  • Curtir 3

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

Desculpe não postar minha resolução, achei que estava confusa e nada a ver.

Tentei fazer assim , mas so ta comparando dois numeros.. , o terceiro entra menor que os outros doisfuncao inicio()
 

   {
    inteiro x,y,maior,cont = 1
     escreva("digite um nro: ")
     leia(y) 
     maior = y
    
    enquanto (cont>0) {
    
    se (y<maior) {
        escreva("digitou um nro menor: ")
        cont = 0
    }
        se (y>maior) {
            
            escreva("digite um nro: ")
            leia(y)
            maior = y
            cont = cont + 1
        }
    }
        
    }
    
    
}

 

Editado por MarcMarc
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@MarcMarc Por gentileza, informe no seu post que linguagem estamos falando... Portugol, visualg.. e etc...  Assim você aumenta suas chances de resposta

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites
18 horas atrás, MarcMarc disse:

 

Desculpe não postar minha resolução, achei que estava confusa e nada a ver.

Tentei fazer assim , mas so ta comparando dois numeros.. , o terceiro entra menor que os outros doisfuncao inicio()
 


   {
    inteiro x,y,maior,cont = 1
     escreva("digite um nro: ")
     leia(y) 
     maior = y
    
    enquanto (cont>0) {
    
    se (y<maior) {
        escreva("digitou um nro menor: ")
        cont = 0
    }
        se (y>maior) {
            
            escreva("digite um nro: ")
            leia(y)
            maior = y
            cont = cont + 1
        }
    }
        
    }
    
    
}

 

 

Ao que me parece o único erro no seu algoritmo é a segunda comparação "SE" - se(y>maior)... pois no caso, como a primeira incrementação de "y" será igual a de "maior" essa condição nunca será verdadeira; troque por se(y>=maior) e teste.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@MarcMarc   Acredito que voce fez esse algoritmo usando visual g 3.     Seu codigo está

bom, mas está desorganizado, então organizei ele e removi aqueles colchetes, pois não

precisa deles.  seu algoritmo ficou assim:

Algoritmo "numero superior"
Var
x,y,maior,cont = 1:inteiro
Inicio
  escreva("digite um nro: ")
  leia(y)
  maior = y
  enquanto (cont>0)
    se (y<maior)
      escreva("digitou um nro menor: ")
      cont = 0
      se (y>=maior)
        escreva("digite um nro: ")
        leia(y)
        maior = y
        cont = cont + 1
      fimse
    fimse
  fimenquanto
Fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×