Ir ao conteúdo
  • Cadastre-se
Higor Gustavo Martins

VisualG Digitar 3 numeros e soma-los e depois Mostar o menor e maior numero.

Recommended Posts

Como eu faço para ver o maior e menor numero ? pois eu só consigo ver entre 2 Números.

algoritmo "MaioreMenor"

@devair1010
 

var
   N,Contador, S, Maior, Menor: inteiro
inicio
      Contador <- 1
      Maior <- N
      Menor <- N
      S <- N
      Enquanto (Contador <= 3) faca
               Escreva("Digite o ", Contador , "°. valor: ")
               Leia(N)
                   Se (N > Maior) entao
                        Maior <- N
                   Senao
                        Se (N > Menor)entao
                           Menor <- N
                        Fimse
                   Fimse
                        Contador <- Contador + 1
                        S <- S + N
    FimEnquanto
      Escreval("A soma de todos os valores foi: ", S)
      Escreval("O maior valor digitado foi: ", Maior)
      Escreval("O menor valor digitado foi: ", Menor)
fimalgoritmo

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Higor Gustavo Martins    você precisa pegar o primeiro número digitado para servir de referencia para os demais números digitados ,  então poderia ser assim  :

Algoritmo "maioremenor"
var
  N,Contador, S, Maior, Menor: inteiro
inicio
  Contador <- 1
  Enquanto (Contador <= 3) faca
    Escreva("Digite o ", Contador , "°. valor: ")
    Leia(N)
    se contador = 1 ENTÃO
      Maior := N
      menor := N
    fimse
    Se N > Maior ENTÃO
      Maior <- N
    Senao
      Se N < Menor ENTÃO
        Menor <- N
      Fimse
    Fimse
    Contador <- Contador + 1
    S <- S + N
  FimEnquanto
  Escreval("A soma de todos os valores foi: ", S)
  Escreval("O maior valor digitado foi: ", Maior)
  Escreval("O menor valor digitado foi: ", Menor)
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

1#

Sobre:

7 horas atrás, Higor Gustavo Martins disse:

o que Significa o := que você colocou entre o Maior e Menor ?

 

O ":=" é a mesma coisa que "<-". 

 

 

 

adicionado 8 minutos depois

2#

Como são quantidade de loops predefinidos, talvez serja melhor utilizar o para, em vez de enquanto().

 

 

3#

Sobre:

7 horas atrás, Higor Gustavo Martins disse:

Escreva("Digite o ", Contador , "°. valor: ")

Antes da variável numérica não precisa de espaço. E depois do "º" não tem ".".

   {escreva("Digite o ", Contador , "°. valor: ")}
   escreva("Digite o",Contador,"° valor: ")

obs.: eu particularmente não cololo espaços entre as ",", mas aí é facultativo. Onde não deveria ter espaços é na parte dentro das aspas duplas, pois o Visualg dá um espaço automaticamente (é um recurso da linguagem, mas que não foi uma boa ideia.... só atrapalha).

 

 

 

***

 

No aguardo.

  • Curtir 3

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Simon Viegas

 

Oh fera, muito obrigado pela ajuda... agradeço de coração mesmo... e mais uma coisa.. 

 

Que conselho você daria a uma pessoa que acabou de entrar no mundo da programação, uma pessoa que não sabe nada e quer ser um bom hacker.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
21 minutos atrás, Higor Gustavo Martins disse:

@Carol Machado

kkkkkk que legal... e você ja trabalha com Programação ou algo do tipo ? 

 

 

Nss eu to apanhando muito com Algoritmos kkkkkkkkk 

Trabalho em uma empresa de desenvolvimento de software, mas na parte de suporte e banco. Iniciei nela não faz muito tempo. Programar só em casa mesmo kkkkk

 

Puxaa.. algoritmo é complicadinho mesmo. Mas dica: exercite bastante em casa se está com dificuldade. Tudo é questão de prática.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Carol Machado

 

Eu faço um curso pela internet do Site: Cursosemvideo.com e la tem vários outros cursos sobre linguagem de programação... 

ai eu estou fazendo uns exercícios e a maioria deles eu fiz sozinho kkk mas tem outros que eu levo dias para fazer kkkkk

 

Ai eu vi nesse site aqui algumas resposta e ate pessoas que me ajuda... ai eu vou tentando fazer e peço ajuda aqui qualquer coisa kkkkkkkk  

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 minutos atrás, Higor Gustavo Martins disse:

@Carol Machado

 

Eu faço um curso pela internet do Site: Cursosemvideo.com e la tem vários outros cursos sobre linguagem de programação... 

ai eu estou fazendo uns exercícios e a maioria deles eu fiz sozinho kkk mas tem outros que eu levo dias para fazer kkkkk

 

Ai eu vi nesse site aqui algumas resposta e ate pessoas que me ajuda... ai eu vou tentando fazer e peço ajuda aqui qualquer coisa kkkkkkkk  

Ah simm hehehe o Gustavo Guanabara é o professor do curso em vídeo, muito boa a didática dele. Fiz outros cursos dele.

Mas é isso aí, vai tentando, testando os códigos, tenta todas as formas que imaginar... que depois que você entende a sintaxe e como aplicar os loops, seus códigos vão sair com mais facilidade e cada vez melhor em questão de desempenho!!

E pergunta mesmo, onde tiver que perguntar... que vamos nos ajudando!!! :)

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 09/10/2018 às 02:34, Higor Gustavo Martins disse:

o que Significa o := que você colocou entre o Maior e Menor ?

se contador = 1 ENTÃO 

Maior := N

menor := N

 

 

 

Provavelmente o @Simon Viegas deve ser programador Pascal e trabalha com Delphi. 😁

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×