Ir ao conteúdo
  • Cadastre-se
fabiano aladin

Problemas na saída de pré amplificador

Recommended Posts

Montei  o seguinte circuito  para ser usado como pré -amplificador para voz humana , porém ao testá-lo  encontrei na saída um sinal  alternado (ruído) indesejado   que passa para etapas seguintes , como faço  para  zerar esse pequeno1500867884_Cktrudo.png.a4af1951c079081948993c70cdcd827d.png ruído?Mesmo sem sinal de áudio o ruído aparece na saída , o sinal  de áudio entra por c3.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Circuitos de áudio são complicados. Pode ser ruído da alimentação, indução ou mesmo alguma RF. Conexões bem curtas, cabos blindados, conectores de qualidade, aterramento e caixa metálica ajudam. Poste foto da montagem.

Compartilhar este post


Link para o post
Compartilhar em outros sites
6 minutos atrás, Ricardov disse:

Circuitos de áudio são complicados. Pode ser ruído da alimentação, indução ou mesmo alguma RF. Conexões bem curtas, cabos blindados, conectores de qualidade, aterramento e caixa metálica ajudam. Poste foto da montagem.

É alimentado com bateria de 12 volts e teve algumas etapas que usei uma alimentação externa  ao invés de um divisor de tensão  para gerar 6 volts , mesmo sem  alimentação externa  e feita somente com a bateria o ruído persiste .Aterrei a caixa metálica  (liguei ao terra da placa).Mesmo no  simulador (multisim ) o ruído apareceu !

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não entendo muito de amplificadores mas este daí me lembra um oscilador.

Por curiosidade, você projetou este circuito do zero ou baseou em algum que acho na net? Qual? Publique também as formas de onda do ruído do simulador.

Talvez você precise filtrar melhor a referência 6V ou até mesmo dar uma "encorpada" nela com ampop seguidor de tensão. Também talvez a entrada e saída aberta sem carga ou alta impedância possa zoar um pouco.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Com osciloscópio pelo simulador não aparece só pelo  analisador de sinal .

Com sinal :579276462_comsinaldeentrada.thumb.png.bf14138cbaaf4b50eb45a538d2658139.png1203494313_comsinaldeentrada.thumb.png.123e044bf08b956e5273b2806629bb8c.png

sem sinal de entrada :215026743_semsinaldeentrada.thumb.png.ac7eb009c47fd32e7d14bc449ce0c954.png

adicionado 44 minutos depois

@Ricardov @Isadora Ferraz  , não sei se esse analisador de sinal é válido mesmo  ou se interpretei errado !

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

No primeiro circuito não há carga após C4 (saída o opamp). No simulador a possível carga está coberta pelos aparelhos. Experimente ler o sinal na saída do opamp. Afinal de contas, C4 é apenas um acoplador AC para o módulo seguinte, faz mais parte da entrada do módulo seguinte do que da saída deste. Pendure o scope na saída do opamp.

Não entendi a existência de C1. É como se quisesse aumentar o ganho para frequências elevadas. Voz humana é baixa frequência, nem mesmo a voz feminina alcança 1kHz. Note que em baixíssimas frequências sua impedância é alta e com isso o ganho do opamp será 1+R5/R3. Com aumento da frequência, C1 passa a desviar parte da corrente que retorna por R5 e sua consequência é obrigar o opamp a ter uma saída mais elevada para ter o balanço das entradas.

Caso a existência de C1 tenha por propósito fazer um filtro passa baixas coloque-o na mesma entrada do sinal, isto é, no nó entre C3 e R4.

Acredito que a simples eliminação de C1 deva resolver a questão do ruído.

Boa sorte.

adicionado 3 minutos depois

Analizando melhor, C1 é a causa do ruído. Está provocando um retardo na realimentação de um opamp de alta velocidade e consequente instabilidade.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Seu circuito tem ganho 1 para tensão contínua e vai aumentando, com o aumento da frequência, a partir de uns 4Hz.

em 40 Hz deve ter ganho de uns 10. Em 400Hz o ganho deve estar em 100. Em 4kHz o ganho já não responde direito. 

Não é surpresa que chegue mesmo a oscilar. 

Ops!

Frequências baixas também são atenuadas devido ao sinal de entrada passar por um filtro passa altas frequências.

Não tem esse seu operacional no meu simulador, mas dá tudo no mesmo. Para CC o ganho é um, pois tem 6Vcc na saída do operacional.

MOR_AL

PA.jpg

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@MOR

Grande Morris. Excelente tutorial! Assisti os 10 vídeos. No seu tutorial na parte da seleção do núcleo é considerado o tamanho do núcleo, a quantidade de energia a ser transferida por ciclo e a capacidade da janela em receber as espiras calculadas. A escolha da Thorton é importante para quem está na Terra Brasilis, vai ser difícil encontrar um núcleo TDK por aqui.

Uma coisa na qual ainda apanho (a surra de um é a surra de muitos) é a seleção do material. Para cada tamanho e geometria se tem entre 2 e 3 opções de material. Sem querer abusar e já sendo folgado, nessa play list de 10 vídeos caberia mais um falando sobre isso? Usar as opções Thorton de material nos será bem útil.

Abraços

Sérgio

Compartilhar este post


Link para o post
Compartilhar em outros sites

O problema não foi resolvido tirando  o capacitor , recoloquei e pelo menos hj  o problema aparece sempre que coloco a tensão de 6 volts  , mas somente nesses dois CI's. Mesmo sem sinal nenhum na entrada , retirei eletreto , cápsula e injetor de sinais que estava usando para testar o equipamento . XLV1 é um eletreto , xlv2 é uma cápsula de 32 ohm .Eu montei esse circuito primeiramente em blocos  em placas universais e funcionou perfeitamente , pedi para confeccionar a placa externamente , medi todas as trilhas nos componentes .Amanhã vou tirar  foto das ondas no ociloscópio e postarei aqui ,  tem aparecido  no  CI 1 no pino 6 uma senóide.Assim como acontece também no CI 2 nos pinos 2 e 6!

 

cktproblema.png

Compartilhar este post


Link para o post
Compartilhar em outros sites
14 horas atrás, fabiano aladin disse:

Eu montei esse circuito primeiramente em blocos  em placas universais e funcionou perfeitamente , pedi para confeccionar a placa externamente

Isto explica um pouco. Quem fez a pci provavelmente tem poucas noções das sensibilidades, trajeto das correntes vcc gnd, posicionamento dos caps, proximidade entretrilhas sensíveis, blindagens, disposição correta dos componentes, etc, ou seja, alguma experiência/prática neste ramo.

Claro, foi só suposição talvez equivocada. Publique fotos da pci dos 2 lados pra uma avaliação remota mais precisa.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Veio com erros amadores como  dissipadores de calor virado para dentro da placa tanto dos tda's como do LM7805 , falta de algumas trilhas e relês com  pinagens trocadas.

placafrente.jpg

placaverso.jpg

plamontadafrente.jpg

placamontadaverso.jpg

U1pino6.jpg

U1pino1.jpg

U2pino2.jpg

U2pino4.jpg

adicionado 3 minutos depois

@Isadora Ferraz me recomenda algum livro  ? Não mando mais as placas para fora não , só para fazer  mesmo , fiquei com medo de errar e acabou vindo com erros infantis!A ordem das imagens dos sinais  que não deveriam aparaecer  são : 1ª)U1 pino 6 , 2ª)U1 pino 1 /9acontece também no U2 pino 1) ,Pino 6 de U2 , pino 2 de U2 . Estou usando uma bateria para alimentar os 12V e uma fonte chaveada para alimentar os 6V quando necessário.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pois é mano... Provavelmente nenhum livro vai conseguir te passar as manhas, artimanhas e principalmente as manhas da arte de elaborar pcb com foco na redução de interferências. Apesar que me lembro vagamente que vi e participei  duma palestra da microchip sobre isso e me deram um cd sobre. O problema é achar.... talvez alguém mais organizado que tenha participado comigo na época lhe possa passar. Também não vou consegui-lo só com textos. Seria algo como você aprender a andar de bicicleta só lendo um manual e já sair empinando, entendes?

De fato sua pcb tá muito sinistra - pra dizer o melhor. De fato dá um pouco de "embaçamento técnico-visual" (inventei isso agora) se olhar muito tempo pra ela.

 

Outra coisa é isso:

43 minutos atrás, fabiano aladin disse:

uma fonte chaveada para alimentar os 6V quando necessário.

fonte chaveada e preamplificador não se dão muito bem. Pois ele pode preamplificar os ruídos inerentes dela, entendes? Como teste, tente usar uma linear ou pilhas/bateria de 6V.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fiz uns testes aqui e em um deles retirei o pino 7 do Ci U1 e o sinal sumiu  , colocando  o osciloscópio em uma tensão bem baixa vi uns ruídos  e provavelmente esteja sendo amplificado na realimentação , mas só acontece quando coloco o pino do ci no soquete , ou seja , com  o pino fora do soquete tanto  o ci ou o soquete não apresentam este pequeno ruído ,  mas quando conecto ,vejo esse pequeno ruído e  aparece esse sinal indesejado , será q se eu colocar um capacitor   para o terra elimino esse ruído?

só tenho q ver o valor  do capacitor!@Isadora Ferraz

adicionado 2 minutos depois
1 hora atrás, Isadora Ferraz disse:

Pois é mano... Provavelmente nenhum livro vai conseguir te passar as manhas, artimanhas e principalmente as manhas da arte de elaborar pcb com foco na redução de interferências. Apesar que me lembro vagamente que vi e participei  duma palestra da microchip sobre isso e me deram um cd sobre. O problema é achar.... talvez alguém mais organizado que tenha participado comigo na época lhe possa passar. Também não vou consegui-lo só com textos. Seria algo como você aprender a andar de bicicleta só lendo um manual e já sair empinando, entendes?

De fato sua pcb tá muito sinistra - pra dizer o melhor. De fato dá um pouco de "embaçamento técnico-visual" (inventei isso agora) se olhar muito tempo pra ela.

 

Outra coisa é isso:

fonte chaveada e preamplificador não se dão muito bem. Pois ele pode preamplificar os ruídos inerentes dela, entendes? Como teste, tente usar uma linear ou pilhas/bateria de 6V.

Tenho conhecimento  de alguns pontos mas não todos , por isso um material de estudo ajudaria bastante .Não  vai dá para confiar mais em  fazer o esquema do circuito e mandar para  fora fazer o layout  depois desse fato ocorrido  .

adicionado 24 minutos depois

Pensei em usar um filtro passa faixa  feito com resistor e capacitor entre a saída e realimentação!

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
23 minutos atrás, fabiano aladin disse:

retirei o pino 7 do Ci U1 e o sinal sumiu

Bem este não é o método ideal de identificar o problema, mas é o que você tem. Tem algum valor mas bem tecnicamente reduzido.

 

24 minutos atrás, fabiano aladin disse:

será q se eu colocar um capacitor   para o terra elimino esse ruído?

Não sei o que este pino faz. Não vi no esquema. Mas não vejo problema se você colocar um de 10nF.

 

31 minutos atrás, fabiano aladin disse:

Não  vai dá para confiar mais em  fazer o esquema do circuito e mandar para  fora fazer o layout  depois desse fato ocorrido

Aquela placa parece ter sido feita com auto route. Este é bem cego no tocante as "reverbações" provocadas por disposição de peças, espessura de trilhas e.. tudo que já disse. Pra aproximar de algo mais digamos, eletrico-ruido-eficiente, tem que alimentar muitos e muitos dados trilha por trilha, ponto a ponto e claro é um pns e nunca 100% confiável. No caso do ramo de amplificador, penso que alguns calos, visões dos elétrons passando, intuições, técnica-arte-magia, etc são mais rápidos e eficientes.

Imagina agora fazer projeto pra circuito da casa dos GHz?!! E de alta potência!! Só mesmo com simuladores e supercomputadores de preços estratosféricos.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×